aboutsummaryrefslogtreecommitdiff
path: root/editors/tamago
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-04-23 16:21:21 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-04-23 16:21:21 +0000
commit89999292aa22a8c36c5ecf6c28e5ecc249225569 (patch)
tree1ad1ea31837629dd4a95ee966e9f5bdcb8c4a8d4 /editors/tamago
parente5a5fc07e30d4a681ffc26eb601a955f1fac0a4b (diff)
downloadports-89999292aa22a8c36c5ecf6c28e5ecc249225569.tar.gz
ports-89999292aa22a8c36c5ecf6c28e5ecc249225569.zip
- Remove redundant lines and style clean-ups.
- Fix (accept-process-output) to use (with-local-quit). - Replace (inactivate-current-input-method-function) with (deactivate-current-input-method-function). - Replace (inactivate-input-method) with (deactivate-input-method).
Notes
Notes: svn path=/head/; revision=316369
Diffstat (limited to 'editors/tamago')
-rw-r--r--editors/tamago/Makefile10
-rw-r--r--editors/tamago/files/patch-egg-com.el32
-rw-r--r--editors/tamago/files/patch-egg.el19
3 files changed, 53 insertions, 8 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index bfdabeb1affb..133e908a9b6f 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tamago
PORTVERSION= 4.0.6.0.20041122.19
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/e/egg
@@ -24,8 +24,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_EMACS= yes
WRKSRC= ${WRKDIR}/egg-4.0.6+0.20041122cvs
-ELISPDIR= ${PREFIX}/${EMACS_LIBDIR_WITH_VER}/site-lisp
-PLIST_SUB= ELISPDIR="${EMACS_LIBDIR_WITH_VER}/site-lisp"
+PLIST_SUB= ELISPDIR="${EMACS_VERSION_SITE_LISPDIR}"
PORTDOCS= AUTHORS ChangeLog ChangeLog.1997-1998 \
ChangeLog.2000-2001 PROBLEMS README.ja.txt TODO \
README.Debian changelog.Debian
@@ -33,7 +32,10 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if ${EMACS_PORT_NAME} == emacs21 || ${EMACS_PORT_NAME} == emacs22 || ${EMACS_PORT_NAME} == emacs23 || ${EMACS_PORT_NAME} == emacs24
+.if ${EMACS_PORT_NAME} == emacs21 || \
+ ${EMACS_PORT_NAME} == emacs22 || \
+ ${EMACS_PORT_NAME} == emacs23 || \
+ ${EMACS_PORT_NAME} == emacs24
PLIST_SUB+= HAS_JISX0213=""
.else
PLIST_SUB+= HAS_JISX0213="@comment "
diff --git a/editors/tamago/files/patch-egg-com.el b/editors/tamago/files/patch-egg-com.el
new file mode 100644
index 000000000000..3a1e40f58056
--- /dev/null
+++ b/editors/tamago/files/patch-egg-com.el
@@ -0,0 +1,32 @@
+--- egg-com.el.orig 2013-04-23 16:10:35.000000000 +0900
++++ egg-com.el 2013-04-23 16:13:12.000000000 +0900
+@@ -828,9 +828,10 @@
+ ;; Do not move the point, leave it where it was.
+ (defmacro comm-accept-process-output ()
+ `(let ((p (point)))
+- (if (null (accept-process-output proc comm-accept-timeout))
+- (egg-error "backend timeout (comm-accept-process-output)"))
+- (goto-char p)))
++ (with-local-quit
++ (if (null (accept-process-output proc comm-accept-timeout))
++ (egg-error "backend timeout (comm-accept-process-output)"))
++ (goto-char p))))
+
+ (defmacro comm-require-process-output (n)
+ `(if (< (point-max) (+ (point) ,n))
+@@ -839,10 +840,11 @@
+ (defun comm-wait-for-space (proc n)
+ (let ((p (point))
+ (r (+ (point) n)))
+- (while (< (point-max) r)
+- (if (null (accept-process-output proc comm-accept-timeout))
+- (egg-error "backend timeout (comm-wait-for-space)"))
+- (goto-char p))))
++ (with-local-quit
++ (while (< (point-max) r)
++ (if (null (accept-process-output proc comm-accept-timeout))
++ (egg-error "backend timeout (comm-wait-for-space)"))
++ (goto-char p)))))
+
+ (defmacro comm-following+forward-char ()
+ `(prog1
diff --git a/editors/tamago/files/patch-egg.el b/editors/tamago/files/patch-egg.el
index af92d27123e4..ffe4f225f018 100644
--- a/editors/tamago/files/patch-egg.el
+++ b/editors/tamago/files/patch-egg.el
@@ -1,8 +1,11 @@
---- egg.el.orig 2013-03-30 17:08:47.000000000 +0900
-+++ egg.el 2013-03-30 17:11:22.000000000 +0900
-@@ -169,7 +169,8 @@
+--- egg.el.orig 2013-04-23 16:13:43.000000000 +0900
++++ egg.el 2013-04-23 16:15:26.000000000 +0900
+@@ -167,16 +167,17 @@
+ (setq egg-modefull-mode t)
+ (its-define-select-keys egg-modefull-map))
(setq egg-modeless-mode t))
- (setq inactivate-current-input-method-function 'egg-mode)
+- (setq inactivate-current-input-method-function 'egg-mode)
++ (setq deactivate-current-input-method-function 'egg-mode)
(setq describe-current-input-method-function 'egg-help)
- (make-local-hook 'input-method-activate-hook)
+ (if (fboundp 'make-local-hook)
@@ -10,6 +13,14 @@
(add-hook 'input-method-activate-hook 'its-set-mode-line-title nil t)
(if (eq (selected-window) (minibuffer-window))
(add-hook 'minibuffer-exit-hook 'egg-exit-from-minibuffer))
+ (run-hooks 'egg-mode-hook)))
+
+ (defun egg-exit-from-minibuffer ()
+- (inactivate-input-method)
++ (deactivate-input-method)
+ (if (<= (minibuffer-depth) 1)
+ (remove-hook 'minibuffer-exit-hook 'egg-exit-from-minibuffer)))
+
@@ -184,7 +185,7 @@
(defun egg-self-insert-char ()