aboutsummaryrefslogtreecommitdiff
path: root/editors/tamago
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-01-29 09:38:37 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-01-29 09:38:37 +0000
commitbce319e636920836b37010e2f82569d354ee9839 (patch)
tree75816bfbc7ff537e22da962efc473c6d2fc659f7 /editors/tamago
parent12bc1b264f488921b18651fbdb2bbaf890a581f1 (diff)
downloadports-bce319e636920836b37010e2f82569d354ee9839.tar.gz
ports-bce319e636920836b37010e2f82569d354ee9839.zip
- Call override-local-map to set menudiag minibuffer keymap securely.
This fixes "Text is read-only" error when a number is directly entered to select an entry. [*] - Deactivate input method when opening minibuffer for consistency. Reported by: ARAI Shun-ichi [*]
Notes
Notes: svn path=/head/; revision=378108
Diffstat (limited to 'editors/tamago')
-rw-r--r--editors/tamago/Makefile2
-rw-r--r--editors/tamago/files/patch-menudiag.el29
2 files changed, 25 insertions, 6 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index 687dc4d60813..927475220c58 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tamago
PORTVERSION= 4.0.6.0.20041122.19
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= editors elisp
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/e/egg
diff --git a/editors/tamago/files/patch-menudiag.el b/editors/tamago/files/patch-menudiag.el
index 6ca01d5726fd..fb190d627acc 100644
--- a/editors/tamago/files/patch-menudiag.el
+++ b/editors/tamago/files/patch-menudiag.el
@@ -1,6 +1,25 @@
--- menudiag.el.orig 2001-01-28 03:53:13.000000000 +0900
-+++ menudiag.el 2014-11-22 15:40:36.000000000 +0900
-@@ -296,7 +296,7 @@
++++ menudiag.el 2015-01-29 18:32:59.000000000 +0900
+@@ -226,6 +226,9 @@
+ (remove-hook 'minibuffer-setup-hook 'menudiag-minibuffer-hook)
+ (setq menudiag-minibuffer-list (cons (current-buffer)
+ menudiag-minibuffer-list))
++ (if (boundp 'deactivate-input-method)
++ (deactivate-input-method)
++ (inactivate-input-method))
+ (buffer-disable-undo)
+ (menudiag-receive-variables)
+ (menudiag-beginning-of-items)
+@@ -248,7 +251,7 @@
+ (string-width (cadr menu)))))
+ (add-hook 'minibuffer-setup-hook 'menudiag-minibuffer-hook)
+ (unwind-protect
+- (progn
++ (let ((overriding-local-map menudiag-mode-map))
+ (read-from-minibuffer "" "" menudiag-mode-map)
+ (menudiag-receive-variables))
+ (setq menudiag-minibuffer-list (cdr menudiag-minibuffer-list))
+@@ -296,7 +299,7 @@
(defun menudiag-goto-item ()
(interactive)
(menudiag-check-current-menu)
@@ -9,7 +28,7 @@
(n 0))
(setq n (menudiag-char-to-item-num ch))
(if (>= n (length menudiag-line))
-@@ -503,7 +503,8 @@
+@@ -503,7 +506,8 @@
(make-local-variable 'inhibit-read-only)
(setq buffer-read-only t
inhibit-read-only nil)
@@ -19,7 +38,7 @@
(add-hook 'post-command-hook 'menudiag-selection-align-to-item nil t)
(use-local-map menudiag-selection-map)
(setq mode-name "Menudiag Selection")
-@@ -595,10 +596,10 @@
+@@ -595,10 +599,10 @@
(set-buffer sel-buf)
(setq completion-reference-buffer tmp-buf)
(if event
@@ -32,7 +51,7 @@
(pop-to-buffer org-buf)
(while (and item-list (>= n (length (car item-list))))
(setq l (1+ l)
-@@ -619,7 +620,7 @@
+@@ -619,7 +623,7 @@
(unless (eq last-command 'menudiag-selection-goto)
(setq menudiag-goto-number-list nil
menudiag-original-point (point)))