aboutsummaryrefslogtreecommitdiff
path: root/editors/texmaker
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2019-07-25 18:20:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2019-07-25 18:20:23 +0000
commit7d534ce6499949188212c43032a257a0e0c23694 (patch)
tree0f463e5c5109afc01fd14c7ee8a57450d30f0d63 /editors/texmaker
parent4e66b621ef900065bed8b972f8ef19d6be9f38c4 (diff)
downloadports-7d534ce6499949188212c43032a257a0e0c23694.tar.gz
ports-7d534ce6499949188212c43032a257a0e0c23694.zip
editors/texmaker:
- Update to 5.0.3 - Remove dependency on poppler, texmaker uses pdfium since 5.0 - Update WWW PR: 238752 Approved by: maintainer timeout (4 weeks)
Notes
Notes: svn path=/head/; revision=507327
Diffstat (limited to 'editors/texmaker')
-rw-r--r--editors/texmaker/Makefile16
-rw-r--r--editors/texmaker/distinfo5
-rw-r--r--editors/texmaker/files/patch-pdfium_core_fxcrt_include_fx__system.h11
-rw-r--r--editors/texmaker/files/patch-pdfium_third__party_base_logging.h11
-rw-r--r--editors/texmaker/files/patch-texmaker.pro41
-rw-r--r--editors/texmaker/pkg-descr2
-rw-r--r--editors/texmaker/pkg-plist46
7 files changed, 70 insertions, 62 deletions
diff --git a/editors/texmaker/Makefile b/editors/texmaker/Makefile
index 314bb2026fc1..4165c09aca9b 100644
--- a/editors/texmaker/Makefile
+++ b/editors/texmaker/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= texmaker
-PORTVERSION= 4.5
-PORTREVISION= 19
+PORTVERSION= 5.0.3
PORTEPOCH= 3
CATEGORIES= editors
MASTER_SITES= http://www.xm1math.net/texmaker/
@@ -13,17 +12,18 @@ COMMENT= LaTeX Development Environment
LICENSE= GPLv2+
-LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell \
- libpoppler.so:graphics/poppler \
- libpoppler-qt5.so:graphics/poppler-qt5
+LIB_DEPENDS= libhunspell-1.7.so:textproc/hunspell
USES= compiler:c++11-lang desktop-file-utils ghostscript:x11,run \
- pkgconfig qmake qt:5 tar:bzip2
-USE_QT= concurrent network printsupport script webkit widgets \
+ gl pkgconfig qmake qt:5 tar:bzip2
+USE_GL= gl
+USE_QT= concurrent core gui network printsupport script widgets \
xml buildtools_build
USE_TEX= latex dvipsk
+
EXTRACT_AFTER_ARGS= --exclude hunspell
QMAKE_ARGS= ICONDIR=${PREFIX}/share/pixmaps \
- DESKTOPDIR=${DESKTOPDIR}
+ DESKTOPDIR=${DESKTOPDIR} \
+ METAINFODIR=${PREFIX}/share/metainfo
.include <bsd.port.mk>
diff --git a/editors/texmaker/distinfo b/editors/texmaker/distinfo
index 421b4948a2db..82b5e47da68a 100644
--- a/editors/texmaker/distinfo
+++ b/editors/texmaker/distinfo
@@ -1,2 +1,3 @@
-SHA256 (texmaker-4.5.tar.bz2) = 2ce9966e410bf878649d1c756e3dc2a077e55e1eaa9f4beb10aa7224cd94d614
-SIZE (texmaker-4.5.tar.bz2) = 11287724
+TIMESTAMP = 1561128794
+SHA256 (texmaker-5.0.3.tar.bz2) = 6074dffa82c431f8727c39e046f62cb70f5fe1457f158b46306e8f490b4f326f
+SIZE (texmaker-5.0.3.tar.bz2) = 15783226
diff --git a/editors/texmaker/files/patch-pdfium_core_fxcrt_include_fx__system.h b/editors/texmaker/files/patch-pdfium_core_fxcrt_include_fx__system.h
new file mode 100644
index 000000000000..f8a6959acc26
--- /dev/null
+++ b/editors/texmaker/files/patch-pdfium_core_fxcrt_include_fx__system.h
@@ -0,0 +1,11 @@
+--- pdfium/core/fxcrt/include/fx_system.h.orig 2017-04-16 14:53:52 UTC
++++ pdfium/core/fxcrt/include/fx_system.h
+@@ -40,7 +40,7 @@
+ #elif defined(_WIN64)
+ #define _FX_OS_ _FX_WIN64_DESKTOP_
+ #define _FXM_PLATFORM_ _FXM_PLATFORM_WINDOWS_
+-#elif defined(__linux__)
++#elif defined(__linux__) || defined(__FreeBSD__)
+ #define _FX_OS_ _FX_LINUX_DESKTOP_
+ #define _FXM_PLATFORM_ _FXM_PLATFORM_LINUX_
+ #elif defined(__APPLE__)
diff --git a/editors/texmaker/files/patch-pdfium_third__party_base_logging.h b/editors/texmaker/files/patch-pdfium_third__party_base_logging.h
new file mode 100644
index 000000000000..3db6cc89cbcd
--- /dev/null
+++ b/editors/texmaker/files/patch-pdfium_third__party_base_logging.h
@@ -0,0 +1,11 @@
+--- pdfium/third_party/base/logging.h.orig 2017-04-16 14:53:52 UTC
++++ pdfium/third_party/base/logging.h
+@@ -10,7 +10,7 @@
+
+ #ifndef _WIN32
+ #define NULL_DEREF_IF_POSSIBLE \
+- *(reinterpret_cast<volatile char*>(NULL) + 42) = 0x42;
++ *(reinterpret_cast<volatile char*>(__null) + 42) = 0x42;
+ #else
+ #define NULL_DEREF_IF_POSSIBLE
+ #endif
diff --git a/editors/texmaker/files/patch-texmaker.pro b/editors/texmaker/files/patch-texmaker.pro
index bb81f8957ad1..cb709c8c38e5 100644
--- a/editors/texmaker/files/patch-texmaker.pro
+++ b/editors/texmaker/files/patch-texmaker.pro
@@ -1,23 +1,18 @@
---- texmaker.pro.orig 2015-10-24 09:05:27 UTC
+--- texmaker.pro.orig 2018-10-31 06:58:22 UTC
+++ texmaker.pro
-@@ -19,11 +19,11 @@ DEFINES += HAVE_SPLASH
- unix:!macx {
- contains( QT_VERSION, "^5.*" ) {
- CONFIG += link_pkgconfig
--PKGCONFIG = poppler-qt5
-+PKGCONFIG = hunspell poppler-qt5
- DEFINES += POPPLER24
- } else {
- CONFIG += link_pkgconfig
--PKGCONFIG = poppler-qt4
-+PKGCONFIG = hunspell poppler-qt4
- DETECTEDPOPPLER=$$system(pkg-config --modversion poppler)
- contains( DETECTEDPOPPLER, "^0.18.*" ){
- DEFINES += OLDPOPPLER
-@@ -98,25 +98,6 @@ HEADERS += texmaker.h \
+@@ -21,6 +21,8 @@ QT += webenginewidgets
+ message("Qt>=5.7 is required.")
+ }
+
++CONFIG += link_pkgconfig
++PKGCONFIG += hunspell
+
+ CONFIG += qt hide_symbols warn_off rtti_off exceptions_off c++11 release
+ CONFIG -= precompile_header
+@@ -117,25 +119,6 @@ HEADERS += texmaker.h \
unicodeview.h \
- quickbeamerdialog.h \
svnhelper.h \
+ quickbeamerdialog.h \
- hunspell/affentry.hxx \
- hunspell/affixmgr.hxx \
- hunspell/atypes.hxx \
@@ -40,7 +35,7 @@
singleapp/qtlocalpeer.h \
singleapp/qtlockedfile.h \
singleapp/qtsingleapplication.h \
-@@ -210,18 +191,6 @@ SOURCES += main.cpp \
+@@ -502,18 +485,6 @@ SOURCES += main.cpp \
unicodeview.cpp \
quickbeamerdialog.cpp \
svnhelper.cpp \
@@ -59,7 +54,7 @@
singleapp/qtlocalpeer.cpp \
singleapp/qtlockedfile.cpp \
singleapp/qtsingleapplication.cpp \
-@@ -395,13 +364,6 @@ utilities.files = doc/doc1.png \
+@@ -1104,13 +1075,6 @@ utilities.files = doc/doc10.png \
utilities/AUTHORS \
utilities/COPYING \
utilities/CHANGELOG.txt \
@@ -72,8 +67,8 @@
- utilities/texmaker.svg \
scripts/titlecase_selection.tms \
scripts/hardwordwrap_selection_80col.tms \
- locale/qt_cs.qm \
-@@ -477,4 +439,20 @@ INSTALLS += desktop
+ locale/qt_ar.qm \
+@@ -1201,6 +1165,22 @@ INSTALLS += desktop
icon.files = utilities/texmaker.png
INSTALLS += icon
@@ -93,4 +88,6 @@
+iconscale.path=$${PREFIX}/share/icons/hicolor/scalable/apps
+iconscale.files=utilities/texmaker.svg
+INSTALLS += icon16 icon22 icon32 icon48 icon64 icon128 iconscale
- }
+
+ #not for openSUSE :
+ metainfo.files = utilities/texmaker.appdata.xml
diff --git a/editors/texmaker/pkg-descr b/editors/texmaker/pkg-descr
index 0bb1739b3fe8..7fab3bfcd4c5 100644
--- a/editors/texmaker/pkg-descr
+++ b/editors/texmaker/pkg-descr
@@ -17,4 +17,4 @@ Features :
* by clicking on the number of a line in the log file, the cursor jumps to
the corresponding line in the editor
-WWW: http://www.xm1math.net/texmaker/
+WWW: https://www.xm1math.net/texmaker/
diff --git a/editors/texmaker/pkg-plist b/editors/texmaker/pkg-plist
index e27ce50b3554..08502d81e651 100644
--- a/editors/texmaker/pkg-plist
+++ b/editors/texmaker/pkg-plist
@@ -7,6 +7,7 @@ share/icons/hicolor/32x32/apps/texmaker32x32.png
share/icons/hicolor/48x48/apps/texmaker48x48.png
share/icons/hicolor/64x64/apps/texmaker64x64.png
share/icons/hicolor/scalable/apps/texmaker.svg
+share/metainfo/texmaker.appdata.xml
share/pixmaps/texmaker.png
share/texmaker/AUTHORS
share/texmaker/CHANGELOG.txt
@@ -19,58 +20,33 @@ share/texmaker/README_es_ES.txt
share/texmaker/README_hu_HU.txt
share/texmaker/README_pl.txt
share/texmaker/README_pt_PT.txt
-share/texmaker/atd.css
share/texmaker/ca_CA.aff
share/texmaker/ca_CA.dic
share/texmaker/cs_CZ.aff
share/texmaker/cs_CZ.dic
-share/texmaker/csshttprequest.js
share/texmaker/de_DE.aff
share/texmaker/de_DE.dic
share/texmaker/doc1.png
share/texmaker/doc10.png
-share/texmaker/doc10hu.png
share/texmaker/doc11.png
-share/texmaker/doc11hu.png
share/texmaker/doc12.png
-share/texmaker/doc12hu.png
share/texmaker/doc13.png
-share/texmaker/doc13hu.png
share/texmaker/doc14.png
-share/texmaker/doc14hu.png
share/texmaker/doc15.png
-share/texmaker/doc15hu.png
share/texmaker/doc16.png
-share/texmaker/doc16hu.png
share/texmaker/doc17.png
-share/texmaker/doc17hu.png
-share/texmaker/doc18.png
-share/texmaker/doc19.png
-share/texmaker/doc1hu.png
share/texmaker/doc2.png
share/texmaker/doc20.png
-share/texmaker/doc20hu.png
share/texmaker/doc21.png
-share/texmaker/doc21hu.png
share/texmaker/doc22.png
-share/texmaker/doc22hu.png
-share/texmaker/doc2hu.png
share/texmaker/doc3.png
-share/texmaker/doc3hu.png
share/texmaker/doc4.png
-share/texmaker/doc4hu.png
share/texmaker/doc5.png
-share/texmaker/doc5hu.png
share/texmaker/doc6.png
-share/texmaker/doc6ahu.png
share/texmaker/doc6bis.png
-share/texmaker/doc6hu.png
share/texmaker/doc7.png
-share/texmaker/doc7hu.png
share/texmaker/doc8.png
-share/texmaker/doc8hu.png
share/texmaker/doc9.png
-share/texmaker/doc9hu.png
share/texmaker/en_GB.aff
share/texmaker/en_GB.dic
share/texmaker/en_US.aff
@@ -85,7 +61,6 @@ share/texmaker/hu_HU.dic
share/texmaker/it_IT.aff
share/texmaker/it_IT.dic
share/texmaker/it_IT_README.txt
-share/texmaker/jquery.atd.textarea.js
share/texmaker/latexhelp.html
share/texmaker/nl_NL.aff
share/texmaker/nl_NL.dic
@@ -93,15 +68,30 @@ share/texmaker/pl_PL.aff
share/texmaker/pl_PL.dic
share/texmaker/pt_PT.aff
share/texmaker/pt_PT.dic
+share/texmaker/qt_ar.qm
+share/texmaker/qt_ca.qm
share/texmaker/qt_cs.qm
+share/texmaker/qt_da.qm
share/texmaker/qt_de.qm
+share/texmaker/qt_en.qm
share/texmaker/qt_es.qm
share/texmaker/qt_fa.qm
+share/texmaker/qt_fi.qm
share/texmaker/qt_fr.qm
-share/texmaker/qt_nl.qm
+share/texmaker/qt_gl.qm
+share/texmaker/qt_he.qm
+share/texmaker/qt_hu.qm
+share/texmaker/qt_it.qm
+share/texmaker/qt_ja.qm
+share/texmaker/qt_ko.qm
+share/texmaker/qt_lt.qm
share/texmaker/qt_pl.qm
share/texmaker/qt_pt.qm
share/texmaker/qt_ru.qm
+share/texmaker/qt_sk.qm
+share/texmaker/qt_sl.qm
+share/texmaker/qt_sv.qm
+share/texmaker/qt_uk.qm
share/texmaker/qt_zh_CN.qm
share/texmaker/qt_zh_TW.qm
share/texmaker/texmaker_ar.qm
@@ -129,5 +119,3 @@ share/texmaker/texmaker_zh_TW.qm
share/texmaker/titlecase_selection.tms
share/texmaker/usermanual_en.html
share/texmaker/usermanual_fr.html
-share/texmaker/usermanual_hu.html
-share/texmaker/usermanual_ru.html