aboutsummaryrefslogtreecommitdiff
path: root/editors/vim
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2022-06-02 17:36:43 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2022-06-02 17:41:47 +0000
commitf27ea6b18516fad5be76ba20ce8f53f5ba9c1081 (patch)
treeaa6d8363f75aabc88d8098d9d2574624209ec51b /editors/vim
parent2c21b98aa4d966f261b0ea46cbf8183d63d1f395 (diff)
downloadports-f27ea6b18516fad5be76ba20ce8f53f5ba9c1081.tar.gz
ports-f27ea6b18516fad5be76ba20ce8f53f5ba9c1081.zip
editors/vim: Update to 8.2.5052 and fix vimrc clobbering
Vim runtime's defaults.vim will clobber global vimrc settings. It's fine for the settings we provide, but other edits to that file can get lost. To work around this, defaults.vim is now directly sourced and a flag is set to stop that file from getting loaded a second time. Thanks go to Anton Saietskii for that bit of magic. PR: 251420
Diffstat (limited to 'editors/vim')
-rw-r--r--editors/vim/Makefile2
-rw-r--r--editors/vim/distinfo6
-rw-r--r--editors/vim/files/vimrc5
3 files changed, 9 insertions, 4 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index c3bea27736b1..65e94b241baf 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -1,7 +1,7 @@
# Created by: David O'Brien <obrien@cs.ucdavis.edu>
PORTNAME= vim
-PORTVERSION= 8.2.5048
+PORTVERSION= 8.2.5052
DISTVERSIONPREFIX= v
CATEGORIES= editors
diff --git a/editors/vim/distinfo b/editors/vim/distinfo
index 2694953f8907..14b9046c259d 100644
--- a/editors/vim/distinfo
+++ b/editors/vim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1654075235
-SHA256 (vim-vim-v8.2.5048_GH0.tar.gz) = 78098f6f61dac7fe2ff8fa3b30e2c464b37c5d3ba41cb313945047916689c989
-SIZE (vim-vim-v8.2.5048_GH0.tar.gz) = 16496596
+TIMESTAMP = 1654191285
+SHA256 (vim-vim-v8.2.5052_GH0.tar.gz) = e96be06c4955cd5b75f0ea026d7845e136d435b9e7621f9534a1034c1a0ca724
+SIZE (vim-vim-v8.2.5052_GH0.tar.gz) = 16496957
diff --git a/editors/vim/files/vimrc b/editors/vim/files/vimrc
index b62c245beaa2..6faf60ca412d 100644
--- a/editors/vim/files/vimrc
+++ b/editors/vim/files/vimrc
@@ -1,3 +1,8 @@
+" defaults.vim will override this file. Sourcing it here and
+" setting the skip flag prevents clobbering settings
+source $VIMRUNTIME/defaults.vim
+let skip_defaults_vim = 1
+
set nocompatible " Enable Vim mode (instead of vi emulation)
let g:is_posix = 1 " Our /bin/sh is POSIX, not bash