aboutsummaryrefslogtreecommitdiff
path: root/editors/vscode
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2024-02-11 14:30:01 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2024-02-11 14:31:10 +0000
commit811ac0d6f493d79212cce590f181b3c961c84b4f (patch)
tree4eb3349809812bafe248cdc73e36d78b873930ac /editors/vscode
parent694cfbe2a427621c16f8bd98b29dc8a5cd0a42d6 (diff)
downloadports-811ac0d6f493d79212cce590f181b3c961c84b4f.tar.gz
ports-811ac0d6f493d79212cce590f181b3c961c84b4f.zip
editors/vscode: update to 1.86.1
Changelog: https://code.visualstudio.com/updates/v1_86 Reported by: GitHub (watch releases)
Diffstat (limited to 'editors/vscode')
-rw-r--r--editors/vscode/Makefile5
-rw-r--r--editors/vscode/distinfo14
-rw-r--r--editors/vscode/files/patch-build_npm_postinstall.js4
3 files changed, 11 insertions, 12 deletions
diff --git a/editors/vscode/Makefile b/editors/vscode/Makefile
index fc7ecfce3b7a..db652363335c 100644
--- a/editors/vscode/Makefile
+++ b/editors/vscode/Makefile
@@ -1,6 +1,5 @@
PORTNAME= vscode
-DISTVERSION= 1.86.0
-PORTREVISION= 1
+DISTVERSION= 1.86.1
CATEGORIES= editors
MASTER_SITES= https://github.com/tagattie/FreeBSD-VSCode/releases/download/${DISTVERSION}/:yarn_cache
DISTFILES= yarn-offline-cache-${DISTVERSION}${EXTRACT_SUFX}:yarn_cache \
@@ -68,7 +67,7 @@ USES= desktop-file-utils gl gmake gnome iconv:wchar_t jpeg \
USE_GITHUB= yes
GH_ACCOUNT= microsoft
-SOURCE_COMMIT_HASH= f5442d1f9fcdc7ce89a34c6e52a11ba44e47b423
+SOURCE_COMMIT_HASH= 31c37ee8f63491495ac49e43b8544550fbae4533
BINARY_ALIAS= python=${PYTHON_CMD}
diff --git a/editors/vscode/distinfo b/editors/vscode/distinfo
index 023ed3093931..84e4a2bed11c 100644
--- a/editors/vscode/distinfo
+++ b/editors/vscode/distinfo
@@ -1,7 +1,7 @@
-TIMESTAMP = 1707038148
-SHA256 (vscode/yarn-offline-cache-1.86.0.tar.gz) = 0e5f95011d687808a6329e69551585008f4fc6f473dba74a67529b4e7a0416f3
-SIZE (vscode/yarn-offline-cache-1.86.0.tar.gz) = 332998780
-SHA256 (vscode/vscode-marketplace-exts-1.86.0.tar.gz) = 5f30bfd81cd2504a299e55fcb460f1c3247bcef102e3b5f42b4a8fc5e1cce3b5
-SIZE (vscode/vscode-marketplace-exts-1.86.0.tar.gz) = 1826339
-SHA256 (vscode/microsoft-vscode-1.86.0_GH0.tar.gz) = 7dca663af6963cf67cae936cc194a2c0510bf13cabcc705b3b6de006cbfb348c
-SIZE (vscode/microsoft-vscode-1.86.0_GH0.tar.gz) = 17353776
+TIMESTAMP = 1707639016
+SHA256 (vscode/yarn-offline-cache-1.86.1.tar.gz) = be56b0b969ea522290c6b06d068ef541bac92612d447fa015d3b22dd20969320
+SIZE (vscode/yarn-offline-cache-1.86.1.tar.gz) = 333001065
+SHA256 (vscode/vscode-marketplace-exts-1.86.1.tar.gz) = 86c21c34c23c2c51de27e3903aaf60e236a259d198be9183852edc90399d7bf8
+SIZE (vscode/vscode-marketplace-exts-1.86.1.tar.gz) = 1817278
+SHA256 (vscode/microsoft-vscode-1.86.1_GH0.tar.gz) = d3942febb8e6dea1f3f473d3035450a09d678e2dbea5412f784814c16fb0bdf6
+SIZE (vscode/microsoft-vscode-1.86.1_GH0.tar.gz) = 17357908
diff --git a/editors/vscode/files/patch-build_npm_postinstall.js b/editors/vscode/files/patch-build_npm_postinstall.js
index 3a2d535861fa..6d991878d2bd 100644
--- a/editors/vscode/files/patch-build_npm_postinstall.js
+++ b/editors/vscode/files/patch-build_npm_postinstall.js
@@ -1,4 +1,4 @@
---- build/npm/postinstall.js.orig 2024-01-31 22:36:21 UTC
+--- build/npm/postinstall.js.orig 2024-02-07 08:28:46 UTC
+++ build/npm/postinstall.js
@@ -41,8 +41,14 @@ function yarnInstall(dir, opts) {
const raw = process.env['npm_config_argv'] || '{}';
@@ -17,7 +17,7 @@
if (opts.ignoreEngines) {
args.push('--ignore-engines');
delete opts.ignoreEngines;
-@@ -116,5 +122,5 @@ for (let dir of dirs) {
+@@ -131,5 +137,5 @@ for (let dir of dirs) {
yarnInstall(dir, opts);
}