aboutsummaryrefslogtreecommitdiff
path: root/editors/web-mode
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
commita3cc513bfc69ef10d52ed310dd9a6e6bb8c57491 (patch)
tree4a6b8513515fb032f2183d945863a1d39dbcd0c1 /editors/web-mode
parent7a6d87cd185d39c7023ee32da472cca4f391e7f2 (diff)
downloadports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.tar.gz
ports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.zip
Flavorize and modernize Emacs ports
- Convert USE_EMACS to USES=emacs - Remove editors/emacs-nox11 (refer to nox flavors of editors/emacs and editors/emacs-devel) - Permit default Emacs flavor to be specified in make.conf - Rename japanese/migemo-emacs23 to japanese/migemo-emacs - Update and simplify audio/emms and fix build on FreeBSD 10 [1] - Update databases/bbdd and fix build on FreeBSD 10 [1] - Update editors/emacs-devel - Ensure Makefile shell commands that change directory are executed in a subshell - Silence some portlint warnings [1] By not depending on base texinfo PR: 225404 Reviewed by: antoine Approved by: portmgr (mat) ashish (maintainer) Differential Revision: https://reviews.freebsd.org/D13506
Notes
Notes: svn path=/head/; revision=460621
Diffstat (limited to 'editors/web-mode')
-rw-r--r--editors/web-mode/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/editors/web-mode/Makefile b/editors/web-mode/Makefile
index 6f15853e92a9..422ec2b95b76 100644
--- a/editors/web-mode/Makefile
+++ b/editors/web-mode/Makefile
@@ -2,27 +2,28 @@
PORTNAME= web-mode
PORTVERSION= 14
-PORTREVISION= 2
DISTVERSIONPREFIX= v
+PORTREVISION= 3
CATEGORIES= editors elisp
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Autonomous Emacs major-mode for editing web templates
LICENSE= GPLv2
+USES= emacs
USE_GITHUB= yes
GH_ACCOUNT= fxbois
-USE_EMACS= yes
+
MAKEFILE= ${FILESDIR}/Makefile
MAKE_ENV= EMACS="${EMACS_CMD}" LISPDIR="${WEBMODE_LISPDIR}" \
DESTDIR="${STAGEDIR}"
SUB_FILES= web-mode-autoloads.el
SUB_LIST= LISPDIR="${WEBMODE_LISPDIR}"
WEBMODE_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/web-mode
-PLIST_FILES= %%EMACS_VERSION_SITE_LISPDIR%%/web-mode/web-mode.elc.gz \
- %%EMACS_VERSION_SITE_LISPDIR%%/web-mode-autoloads.el
+PLIST_FILES= ${EMACS_VERSION_SITE_LISPDIR}/web-mode/web-mode.elc.gz \
+ ${EMACS_VERSION_SITE_LISPDIR}/web-mode-autoloads.el
post-install:
${INSTALL_DATA} ${WRKDIR}/web-mode-autoloads.el \