aboutsummaryrefslogtreecommitdiff
path: root/emulators/aqemu
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-19 14:26:04 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-19 14:26:04 +0000
commit04e1309c57b0669b6c48185c8ca220c4ef96528b (patch)
treed2f004402efeb5ce4791fd3f310ad64e3fc15e86 /emulators/aqemu
parent1959a19744915d6a210daeec96e83779e5bd3fc5 (diff)
downloadports-04e1309c57b0669b6c48185c8ca220c4ef96528b.tar.gz
ports-04e1309c57b0669b6c48185c8ca220c4ef96528b.zip
Add patch to stop building the libvncclient target.
The libvncclient target was removed because it was not used anywhere (aqemu links against the systems libvncclient.so, only the definitions and includes are needed from this block) and did not declare its dependency on the moc and ui files, possibly causing problems in parallel builds (way more often with CMake 3.5.0). PR: 208033
Notes
Notes: svn path=/head/; revision=411403
Diffstat (limited to 'emulators/aqemu')
-rw-r--r--emulators/aqemu/files/patch-CMakeLists.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/emulators/aqemu/files/patch-CMakeLists.txt b/emulators/aqemu/files/patch-CMakeLists.txt
index dca00ea263f6..5ac7206c8a52 100644
--- a/emulators/aqemu/files/patch-CMakeLists.txt
+++ b/emulators/aqemu/files/patch-CMakeLists.txt
@@ -1,6 +1,18 @@
---- ./CMakeLists.txt.orig 2010-12-21 19:45:24.000000000 +0300
-+++ ./CMakeLists.txt 2011-04-17 13:03:32.608958928 +0400
-@@ -318,6 +318,6 @@
+The libvncclient target was removed because it was not used anywhere (aqemu
+links against the systems libvncclient.so, only the definitions and includes
+are needed from this block) and did not declare its dependency on the moc and
+ui files, possibly causing problems in parallel builds.
+--- CMakeLists.txt.orig 2011-01-14 19:38:53 UTC
++++ CMakeLists.txt
+@@ -164,7 +164,6 @@ IF( NOT WITHOUT_EMBEDDED_DISPLAY )
+ Embedded_Display/vncclientthread.cpp Embedded_Display/vncview.cpp )
+
+ ADD_DEFINITIONS( -DVNC_DISPLAY -DQTONLY )
+- ADD_LIBRARY( libvncclient SHARED ${aqemu_headers} ${aqemu_sources} )
+
+ INCLUDE_DIRECTORIES( ${VNCCLIENT_INCLUDE_DIRS} ${LIBVNCCLIENT_INCLUDE_DIR} )
+ ENDIF( NOT WITHOUT_EMBEDDED_DISPLAY )
+@@ -318,6 +317,6 @@ IF( INSTALL_MAN )
MESSAGE( STATUS "MAN_PAGE_COMPRESSOR flag not set. Available values: gzip, bzip2, lzma" )
MESSAGE( STATUS "Will be installed not compressed MAN pages" )