aboutsummaryrefslogtreecommitdiff
path: root/emulators/gxemul
diff options
context:
space:
mode:
authorMitchell Clay <mclay@astate.edu>2022-04-01 04:12:21 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2022-04-01 04:12:21 +0000
commit9478a8c169cd07d375213573bb139dce11f9ee19 (patch)
treef6ad0b427f618cce1f6b0d9f355e3b4007a0a997 /emulators/gxemul
parent1336dfe4a2f99ea19f9a979c1b8e8c499add08e8 (diff)
downloadports-9478a8c169cd07d375213573bb139dce11f9ee19.tar.gz
ports-9478a8c169cd07d375213573bb139dce11f9ee19.zip
emulators/gxemul: Update to 0.7.0 and take maintainership
Diffstat (limited to 'emulators/gxemul')
-rw-r--r--emulators/gxemul/Makefile6
-rw-r--r--emulators/gxemul/distinfo6
-rw-r--r--emulators/gxemul/files/patch-configure27
-rw-r--r--emulators/gxemul/files/patch-src_devices_dev__wdc.c (renamed from emulators/gxemul/files/patch-src_devices_dev__wdc.cc)8
4 files changed, 25 insertions, 22 deletions
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 7f53d8ec6b90..753b69e1c816 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -1,19 +1,17 @@
# Created by: Janni
PORTNAME= gxemul
-PORTVERSION= 0.6.3
+PORTVERSION= 0.7.0
CATEGORIES= emulators
MASTER_SITES= http://gavare.se/gxemul/src/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mclay@astate.edu
COMMENT= Instruction-level machine emulator
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-valgrind \
- --without-unittests
CONFIGURE_ENV= CXX=${CXX} \
LOCALBASE=${LOCALBASE} \
PREFIX=${PREFIX}
diff --git a/emulators/gxemul/distinfo b/emulators/gxemul/distinfo
index 80784d3641aa..4dec1ab0b30c 100644
--- a/emulators/gxemul/distinfo
+++ b/emulators/gxemul/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613553517
-SHA256 (gxemul-0.6.3.tar.gz) = 163604d4888218e5fdbc6858b9fc1ec1607d005eadbec424f3a9663e1f2986ed
-SIZE (gxemul-0.6.3.tar.gz) = 6024573
+TIMESTAMP = 1644505943
+SHA256 (gxemul-0.7.0.tar.gz) = 79c4437c6f8ca904f46d33ac36062a65fdcf4a92a248478e408ab11295cf8e83
+SIZE (gxemul-0.7.0.tar.gz) = 5985021
diff --git a/emulators/gxemul/files/patch-configure b/emulators/gxemul/files/patch-configure
index 8cb11e97e73e..44a604ea7f60 100644
--- a/emulators/gxemul/files/patch-configure
+++ b/emulators/gxemul/files/patch-configure
@@ -1,19 +1,19 @@
---- configure.orig 2018-09-06 07:41:13 UTC
+--- configure.orig 2021-04-22 18:04:21 UTC
+++ configure
-@@ -360,10 +360,10 @@ if [ z$NOX11 = z ]; then
+@@ -330,10 +330,10 @@ if [ z$NOX11 = z ]; then
XOK=0
- XINCLUDE=-I/usr/X11R6/include
+ XINCLUDE=-I${LOCALBASE}/include
- $CXX $CXXFLAGS _test_x11.cc -c -o _test_x11.o $XINCLUDE 2> /dev/null
+ $CC $CFLAGS _test_x11.c -c -o _test_x11.o $XINCLUDE 2> /dev/null
-- XLIB="-L/usr/X11R6/lib -lX11"
-+ XLIB="-L${LOCALBASE}/lib -lX11"
- $CXX $CXXFLAGS _test_x11.o -o _test_x11 $XLIB 2> /dev/null
+- XLIB="-L/usr/X11R6/lib -lX11 -Wl,-rpath,/usr/X11R6/lib"
++ XLIB="-L${LOCALBASE}/lib -lX11 -Wl,-rpath,${LOCALBASE}/lib"
+ $CC $CFLAGS _test_x11.o -o _test_x11 $XLIB 2> /dev/null
if [ -x _test_x11 ]; then
-@@ -578,22 +578,6 @@ else
+@@ -539,27 +539,6 @@ else
fi
fi
rm -f _testprog _testprog.error _testprog.stdout
@@ -21,15 +21,20 @@
-
-# -O optimization for non-debug builds. Try -O and -O3.
-if [ ! z"$DEBUG" = zYES ]; then
-- $CXX $CXXFLAGS -O _testprog.cc -o _testprog 2> /dev/null
+- printf "checking whether -O3 or -O can be used (non-DEBUG build)... "
+- $CC $CFLAGS -O _testprog.c -o _testprog 2> /dev/null
- if [ -x _testprog ]; then
- rm -f _testprog
-- $CXX $CXXFLAGS -O3 _testprog.cc -o _testprog 2> /dev/null
+- $CC $CFLAGS -O3 _testprog.c -o _testprog 2> /dev/null
- if [ -x _testprog ]; then
-- CXXFLAGS="-O3 $CXXFLAGS"
+- CFLAGS="-O3 $CFLAGS"
+- printf "yes, -O3\n"
- else
-- CXXFLAGS="-O $CXXFLAGS"
+- CFLAGS="-O $CFLAGS"
+- printf "yes, -O\n"
- fi
+- else
+- printf "no\n"
- fi
-fi
-rm -f _testprog
diff --git a/emulators/gxemul/files/patch-src_devices_dev__wdc.cc b/emulators/gxemul/files/patch-src_devices_dev__wdc.c
index fc921947292f..113adf3b46ba 100644
--- a/emulators/gxemul/files/patch-src_devices_dev__wdc.cc
+++ b/emulators/gxemul/files/patch-src_devices_dev__wdc.c
@@ -1,6 +1,6 @@
---- src/devices/dev_wdc.cc.orig 2014-08-17 08:45:12 UTC
-+++ src/devices/dev_wdc.cc
-@@ -274,12 +274,12 @@ void wdc__read(struct cpu *cpu, struct w
+--- src/devices/dev_wdc.c.orig 2021-04-22 18:04:20 UTC
++++ src/devices/dev_wdc.c
+@@ -274,12 +274,12 @@ void wdc__read(struct cpu *cpu, struct wdc_data *d)
+ (int64_t)d->head * d->sectors_per_track[d->drive] +
(int64_t)d->heads[d->drive] * d->sectors_per_track[d->drive] * cyl);
@@ -15,7 +15,7 @@
#endif
while (count > 0) {
-@@ -320,12 +320,12 @@ void wdc__write(struct cpu *cpu, struct
+@@ -320,12 +320,12 @@ void wdc__write(struct cpu *cpu, struct wdc_data *d)
uint64_t offset = 512 * (d->sector - 1
+ (int64_t)d->head * d->sectors_per_track[d->drive] +
(int64_t)d->heads[d->drive] * d->sectors_per_track[d->drive] * cyl);