aboutsummaryrefslogtreecommitdiff
path: root/games/nettoe
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-30 11:24:09 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-30 11:24:09 +0000
commit06042cec26c36727683ee891ff2e04d457773e80 (patch)
treed874c0ec9d6cc38ec7e554aeb90fe6988c658052 /games/nettoe
parent996d3c8bd3a98fdc01ecab9d83394d421c024ec3 (diff)
downloadports-06042cec26c36727683ee891ff2e04d457773e80.tar.gz
ports-06042cec26c36727683ee891ff2e04d457773e80.zip
Fix build with -fno-common
Notes
Notes: svn path=/head/; revision=550685
Diffstat (limited to 'games/nettoe')
-rw-r--r--games/nettoe/Makefile6
-rw-r--r--games/nettoe/files/patch-src_game.h14
-rw-r--r--games/nettoe/files/patch-src_misc.c13
3 files changed, 31 insertions, 2 deletions
diff --git a/games/nettoe/Makefile b/games/nettoe/Makefile
index 6a70068c775c..a731ddf1462f 100644
--- a/games/nettoe/Makefile
+++ b/games/nettoe/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nettoe
PORTVERSION= 1.5.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.c-s.li/ports/ \
SF
@@ -12,10 +13,11 @@ COMMENT= Tic tac toe game playable over the network
LICENSE= GPLv2
-PLIST_FILES= bin/nettoe man/man6/nettoe.6.gz
-
USES= gmake
GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/nettoe man/man6/nettoe.6.gz
+
PORTDOCS= AUTHORS BUGS ChangeLog NEWS README TO-DO
OPTIONS_DEFINE= DOCS
diff --git a/games/nettoe/files/patch-src_game.h b/games/nettoe/files/patch-src_game.h
new file mode 100644
index 000000000000..3f5737b54d12
--- /dev/null
+++ b/games/nettoe/files/patch-src_game.h
@@ -0,0 +1,14 @@
+--- src/game.h.orig 2014-03-21 08:38:58 UTC
++++ src/game.h
+@@ -43,8 +43,8 @@
+
+ #define MAX_PNAME_LEN 32 /* this define max chars for the player names*/
+
+-int NO_BEEP;
++extern int NO_BEEP;
+
+-int NO_COLORS;
++extern int NO_COLORS;
+
+-int addrfamily;
++extern int addrfamily;
diff --git a/games/nettoe/files/patch-src_misc.c b/games/nettoe/files/patch-src_misc.c
new file mode 100644
index 000000000000..ceb4b88baa4f
--- /dev/null
+++ b/games/nettoe/files/patch-src_misc.c
@@ -0,0 +1,13 @@
+--- src/misc.c.orig 2014-03-21 08:46:52 UTC
++++ src/misc.c
+@@ -44,6 +44,10 @@
+ #include "misc.h"
+ #include "terminal.h"
+
++int NO_BEEP;
++int NO_COLORS;
++int addrfamily;
++
+ int who_start_first(void)
+ {
+ long generated_number;