aboutsummaryrefslogtreecommitdiff
path: root/games/nonsense
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2013-09-26 19:13:51 +0000
committerEitan Adler <eadler@FreeBSD.org>2013-09-26 19:13:51 +0000
commitae79f47c17fd7aa6defc476cb59616247e990ad0 (patch)
tree8563ec6061c5821b4d12245e486eb874c219ea49 /games/nonsense
parent816fb839d94a06cbb1a1ff1021f170453ab2df18 (diff)
downloadports-ae79f47c17fd7aa6defc476cb59616247e990ad0.tar.gz
ports-ae79f47c17fd7aa6defc476cb59616247e990ad0.zip
Modernize the games/nonsense port:
- Support STAGEDIR - Use DATADIR macros - don't install useless README
Notes
Notes: svn path=/head/; revision=328407
Diffstat (limited to 'games/nonsense')
-rw-r--r--games/nonsense/Makefile21
-rw-r--r--games/nonsense/pkg-plist56
2 files changed, 35 insertions, 42 deletions
diff --git a/games/nonsense/Makefile b/games/nonsense/Makefile
index 76f272eb7f3b..d629ec34fa79 100644
--- a/games/nonsense/Makefile
+++ b/games/nonsense/Makefile
@@ -11,26 +11,19 @@ COMMENT= Nonsense text generator
NO_BUILD= defined
-MAN6= nonsense.6
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-configure:
${REINPLACE_CMD} -e "s,/usr/local,${PREFIX}," ${WRKSRC}/nonsense
${SED} -e "s^%%PREFIX%%^${PREFIX}^g" \
- < ${FILESDIR}/${MAN6} > ${WRKSRC}/${MAN6}
+ < ${FILESDIR}/nonsense.6 > ${WRKSRC}/nonsense.6
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/nonsense ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/share/nonsense/data
- ${MKDIR} ${PREFIX}/share/nonsense/template
- ${INSTALL_DATA} ${WRKSRC}/*.data ${PREFIX}/share/nonsense/data
- ${INSTALL_DATA} ${WRKSRC}/*.template ${PREFIX}/share/nonsense/template
- ${INSTALL_MAN} ${WRKSRC}/${MAN6} ${PREFIX}/man/man6/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${PREFIX}/share/doc/nonsense
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/nonsense/
-.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/nonsense ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}/data
+ ${MKDIR} ${STAGEDIR}${DATADIR}/template
+ ${INSTALL_DATA} ${WRKSRC}/*.data ${STAGEDIR}${DATADIR}/data
+ ${INSTALL_DATA} ${WRKSRC}/*.template ${STAGEDIR}${DATADIR}/template
+ ${INSTALL_MAN} ${WRKSRC}/nonsense.6 ${STAGEDIR}${MAN6PREFIX}/man/man6/
.include <bsd.port.mk>
diff --git a/games/nonsense/pkg-plist b/games/nonsense/pkg-plist
index 0f857f386464..9e4c0c7200bd 100644
--- a/games/nonsense/pkg-plist
+++ b/games/nonsense/pkg-plist
@@ -1,30 +1,30 @@
bin/nonsense
-%%PORTDOCS%%share/doc/nonsense/README
-%%PORTDOCS%%@dirrm share/doc/nonsense
-share/nonsense/data/college.data
-share/nonsense/data/cookie.data
-share/nonsense/data/default.data
-share/nonsense/data/humorix.data
-share/nonsense/data/insults.data
-share/nonsense/data/linux.data
-share/nonsense/data/mission.data
-share/nonsense/data/newspaper.data
-share/nonsense/data/poetry.data
-share/nonsense/data/ratherism.data
-share/nonsense/data/resume.data
-share/nonsense/data/shows.data
-share/nonsense/data/slashdot.data
-share/nonsense/data/stupidlaws.data
-share/nonsense/data/techdirt.data
-share/nonsense/template/bingo.html.template
-share/nonsense/template/bizplan.html.template
-share/nonsense/template/freshmeat.rdf.template
-share/nonsense/template/humorix.html.template
-share/nonsense/template/newspaper.html.template
-share/nonsense/template/resume.html.template
-share/nonsense/template/slashdot.html.template
-share/nonsense/template/slashdot.rdf.template
-share/nonsense/template/techdirt.html.template
-@dirrm share/nonsense/data
-@dirrm share/nonsense/template
+%%DATADIR%%/data/college.data
+%%DATADIR%%/data/cookie.data
+%%DATADIR%%/data/default.data
+%%DATADIR%%/data/humorix.data
+%%DATADIR%%/data/insults.data
+%%DATADIR%%/data/linux.data
+%%DATADIR%%/data/mission.data
+%%DATADIR%%/data/newspaper.data
+%%DATADIR%%/data/poetry.data
+%%DATADIR%%/data/ratherism.data
+%%DATADIR%%/data/resume.data
+%%DATADIR%%/data/shows.data
+%%DATADIR%%/data/slashdot.data
+%%DATADIR%%/data/stupidlaws.data
+%%DATADIR%%/data/techdirt.data
+%%DATADIR%%/template/bingo.html.template
+%%DATADIR%%/template/bizplan.html.template
+%%DATADIR%%/template/freshmeat.rdf.template
+%%DATADIR%%/template/humorix.html.template
+%%DATADIR%%/template/newspaper.html.template
+%%DATADIR%%/template/resume.html.template
+%%DATADIR%%/template/slashdot.html.template
+%%DATADIR%%/template/slashdot.rdf.template
+%%DATADIR%%/template/techdirt.html.template
+man/man6/nonsense.6.gz
+@dirrm %%DATADIR%%
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/template
@dirrm share/nonsense