aboutsummaryrefslogtreecommitdiff
path: root/games/xbomb
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/xbomb
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/xbomb')
-rw-r--r--games/xbomb/Makefile2
-rw-r--r--games/xbomb/files/patch-hiscore.c6
2 files changed, 4 insertions, 4 deletions
diff --git a/games/xbomb/Makefile b/games/xbomb/Makefile
index 6cf711205e44..0d6259197100 100644
--- a/games/xbomb/Makefile
+++ b/games/xbomb/Makefile
@@ -25,7 +25,7 @@ PLIST_FILES= bin/xbomb \
PLIST_DIRS= lib/X11/xbomb
do-build:
- cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} -DX11BASE=\"${X11BASE}\" \
+ cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} -DLOCALBASE=\"${LOCALBASE}\" \
`pkg-config --cflags xaw8` *.c -o xbomb \
`pkg-config --libs xaw8`
diff --git a/games/xbomb/files/patch-hiscore.c b/games/xbomb/files/patch-hiscore.c
index 5ea85294a405..6d7a940dde31 100644
--- a/games/xbomb/files/patch-hiscore.c
+++ b/games/xbomb/files/patch-hiscore.c
@@ -5,9 +5,9 @@
/*+ The names of the high score tables. +*/
-static char *filenames[NTYPES]={"/var/tmp/xbomb6.hi","/var/tmp/xbomb4.hi","/var/tmp/xbomb3.hi"};
-+static char *filenames[NTYPES]={X11BASE"/lib/X11/xbomb/xbomb6.hi",
-+ X11BASE"/lib/X11/xbomb/xbomb4.hi",
-+ X11BASE"/lib/X11/xbomb/xbomb3.hi"};
++static char *filenames[NTYPES]={LOCALBASE"/lib/X11/xbomb/xbomb6.hi",
++ LOCALBASE"/lib/X11/xbomb/xbomb4.hi",
++ LOCALBASE"/lib/X11/xbomb/xbomb3.hi"};
/*+ The names of the positions in the high score tables. +*/
static char pos[11][5]={"Top","2nd","3rd","4th","5th","6th","7th","8th","9th","10th","Lost"};