aboutsummaryrefslogtreecommitdiff
path: root/graphics/dataplot
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-17 14:54:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-17 14:54:57 +0000
commit495a1f1b97da319c2052f7121909e4ad1b5d362e (patch)
tree41e1f5e634d57a6608ca3b59852c4823f842ea37 /graphics/dataplot
parent6ce04c7fc34a068196485c74bc9000e678e570d3 (diff)
downloadports-495a1f1b97da319c2052f7121909e4ad1b5d362e.tar.gz
ports-495a1f1b97da319c2052f7121909e4ad1b5d362e.zip
- Update to 20081002
PR: 140616 Submitted by: "Pedro F. Giffuni" <giffunip@tutopia.com>
Notes
Notes: svn path=/head/; revision=244387
Diffstat (limited to 'graphics/dataplot')
-rw-r--r--graphics/dataplot/Makefile25
-rw-r--r--graphics/dataplot/distinfo6
-rw-r--r--graphics/dataplot/files/Makefile.tmpl20
3 files changed, 32 insertions, 19 deletions
diff --git a/graphics/dataplot/Makefile b/graphics/dataplot/Makefile
index 16e642a354f4..eca73f09dd23 100644
--- a/graphics/dataplot/Makefile
+++ b/graphics/dataplot/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= dataplot
-PORTVERSION= 20080225
-PORTREVISION= 3
+PORTVERSION= 20081002
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.nist.gov/pub/dataplot/unix/:source \
LOCAL/beech:source \
http://www.itl.nist.gov/div898/software/dataplot.html/:doc \
LOCAL/beech:doc
-DISTFILES= dpsrc.02_25_2008${EXTRACT_SUFX}:source \
+DISTFILES= dpsrc.2008_10_02${EXTRACT_SUFX}:source \
dpsnapsh.pdf:doc
DIST_SUBDIR= dataplot
-EXTRACT_ONLY= dpsrc.02_25_2008${EXTRACT_SUFX}
+EXTRACT_ONLY= dpsrc.2008_10_02${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A free software system for statistical visualization
@@ -26,28 +25,34 @@ LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd \
jpeg:${PORTSDIR}/graphics/jpeg
USE_FORTRAN= yes
-FFLAGS+= -fno-range-check
USE_XORG= x11 xi
NO_WRKSUBDIR= yes
-MAXOBV?= 1000000 # Change if you need more observations/variable
+MAXOBV?= 400000 # Change if you need more observations/variable
.include <bsd.port.pre.mk>
+.if ((${ARCH}=="amd64") || (${ARCH}=="sparc64") || (${ARCH}=="ia64"))
+FFLAGS+= -DDD -DI32 -fdefault-real-8 -fdefault-double-8
+.else
+FFLAGS+= -DSD -DI32 -fdefault-real-8 -fdefault-double-8
+.endif
+
post-extract:
@${INSTALL_DATA} ${FILESDIR}/Makefile.tmpl ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's;%%LOCALBASE%%;${LOCALBASE};g ; \
s;%%LOCALBASE%%;${LOCALBASE};g' \
${WRKSRC}/Makefile
+# Ensure preprocessing is done
+ @${CP} ${WRKSRC}/dp1_linux.f ${WRKSRC}/dp1_linux.F
+# Turn off some dependencies
@${MV} ${WRKSRC}/aqua_src.c ${WRKSRC}/aqua_src.c.nop
@${MV} ${WRKSRC}/gl_src.c ${WRKSRC}/gl_src.c.nop
+ @${MV} ${WRKSRC}/libplot_src.c ${WRKSRC}/libplot_src.c.nop
+ @${MV} ${WRKSRC}/rldp.c ${WRKSRC}/rldp.c.nop
pre-patch:
@${REINPLACE_CMD} -e 's/MAXOBV=1000000/MAXOBV=${MAXOBV}/' \
${WRKSRC}/DPCOPA.INC
-.if ((${ARCH}=="amd64") || (${ARCH}=="sparc64") || (${ARCH}=="ia64"))
- @${REINPLACE_CMD} -e 's;dp1_linux;dp1_linux_dp;g' \
- ${WRKSRC}/Makefile
-.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/graphics/dataplot/distinfo b/graphics/dataplot/distinfo
index b2afb260afef..c27c3183be3c 100644
--- a/graphics/dataplot/distinfo
+++ b/graphics/dataplot/distinfo
@@ -1,6 +1,6 @@
-MD5 (dataplot/dpsrc.02_25_2008.tar.gz) = dfbc53609c1fd0b9785af5eb876663b4
-SHA256 (dataplot/dpsrc.02_25_2008.tar.gz) = 794bedcc48cf444c5813f864f4bacb158474d450337279edaf7fba1055c552c6
-SIZE (dataplot/dpsrc.02_25_2008.tar.gz) = 6399167
+MD5 (dataplot/dpsrc.2008_10_02.tar.gz) = 9933e72025750be19b8646a01e389515
+SHA256 (dataplot/dpsrc.2008_10_02.tar.gz) = 01639d9e0cd42adb50c940ff728f980fb2ce4f42699eeb15caa6272226de8d8e
+SIZE (dataplot/dpsrc.2008_10_02.tar.gz) = 6519239
MD5 (dataplot/dpsnapsh.pdf) = 88ca193586405a71387abbeba9be9f0e
SHA256 (dataplot/dpsnapsh.pdf) = 4854cdab00ce10df87686eb025a80f57575fea1b362a22b49f202e10348f0e4b
SIZE (dataplot/dpsnapsh.pdf) = 62085
diff --git a/graphics/dataplot/files/Makefile.tmpl b/graphics/dataplot/files/Makefile.tmpl
index 0251ecb148f8..ba9006aa0927 100644
--- a/graphics/dataplot/files/Makefile.tmpl
+++ b/graphics/dataplot/files/Makefile.tmpl
@@ -19,7 +19,7 @@ LD = $(F77)
LDFLAGS = -L%%LOCALBASE%%/lib
-LIBS = -lgd -lpng -ljpeg -lX11 -lz -lm
+LIBS = -lgd -lpng -ljpeg -lX11 -lz -lfreetype -lpthread
MAKEFILE = Makefile
@@ -79,10 +79,14 @@ OBJS = dp1_linux.o \
edsub.o \
edwrst.o \
fit3b.o \
- gl_src.o \
- aqua_src.o \
starpac.o \
+ cluster.o \
+ compgeom.o \
tcdriv_nopc.o \
+ aqua_src.o \
+ gl_src.o \
+ libplot_src.o \
+ rldp.o \
gd_src.o \
x11_src.o \
main.o
@@ -93,7 +97,7 @@ PROGRAM = dataplot
SHELL = /bin/sh
-SRCS = dp1_linux.f \
+SRCS = dp1_linux.F \
dp2.f \
dp3.f \
dp4.f \
@@ -149,10 +153,14 @@ SRCS = dp1_linux.f \
edsub.f \
edwrst.f \
fit3b.f \
- gl_src.f \
- aqua_src.f \
starpac.f \
+ cluster.f \
+ compgeom.f \
tcdriv_nopc.f \
+ aqua_src.f \
+ gl_src.f \
+ libplot_src.f \
+ rldp.f \
gd_src.c \
x11_src.c \
main.f