aboutsummaryrefslogtreecommitdiff
path: root/graphics/eos-movrec
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-08-04 02:32:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-08-04 02:32:08 +0000
commit3dd75711f95ee31ad9c23c13396a6bbbb117f357 (patch)
treede1d12dab160b83377ca116782b24d48a986c836 /graphics/eos-movrec
parentf1692182dde978bb8d908414312900590c518afa (diff)
downloadports-3dd75711f95ee31ad9c23c13396a6bbbb117f357.tar.gz
ports-3dd75711f95ee31ad9c23c13396a6bbbb117f357.zip
graphics/eos-movrec: take a different approach to unbreak the build
Fix the bad guard around #include <unistd.h> and drop the `register' keyword which is no longer accepted as of C++ 17 instead of forcing the particular (less strict) C++ standard. Reclaim maintainership.
Diffstat (limited to 'graphics/eos-movrec')
-rw-r--r--graphics/eos-movrec/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/eos-movrec/Makefile b/graphics/eos-movrec/Makefile
index cc7c9397ed1a..eeab93e8a40d 100644
--- a/graphics/eos-movrec/Makefile
+++ b/graphics/eos-movrec/Makefile
@@ -4,7 +4,7 @@ PORTREVISION= 6
CATEGORIES= graphics multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Capture short movies with Canon DSLR camera
WWW= https://sourceforge.net/projects/eos-movrec/
@@ -14,7 +14,6 @@ LIB_DEPENDS= libgphoto2.so:graphics/libgphoto2
USES= cmake compiler:c++11-lang dos2unix pkgconfig qt:5 tar:bzip2
DOS2UNIX_FILES= main.cpp
-USE_CXXSTD= c++14
USE_QT= buildtools:build qmake:build core gui widgets
ICON_SIZES= 16x16 32x32 128x128 256x256 512x512
@@ -23,7 +22,9 @@ DESKTOP_ENTRIES="EOS Camera Movie Recorder" "" "${PORTNAME}" \
"eos_movrec" "Graphics;Photography;Qt;" ""
post-patch:
- @${REINPLACE_CMD} -e 's|GLIBC|${OPSYS}|' ${WRKSRC}/os_api.h
+ @${REINPLACE_CMD} -e 's,GLIBC,${OPSYS},' ${WRKSRC}/mjpegwrt.c \
+ ${WRKSRC}/os_api.h
+ @${REINPLACE_CMD} -e '/int/s,register ,,' ${WRKSRC}/histogramwnd.cpp
.for s in 16 32 128 256 512
@cd ${WRKSRC}/mac.icons && \
${MV} ${s}.png ${PORTNAME}_${s}x${s}.png