aboutsummaryrefslogtreecommitdiff
path: root/graphics/jogamp-jogl
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-05-12 12:10:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-05-12 12:10:03 +0000
commitf0ee6c61db8e59923b6f090c26857bfedc25b734 (patch)
tree23015dab36a7416e3d2e83f042151b8780aeef46 /graphics/jogamp-jogl
parent7a1f12d977270effe6e7133db1f8973cad2424ee (diff)
downloadports-f0ee6c61db8e59923b6f090c26857bfedc25b734.tar.gz
ports-f0ee6c61db8e59923b6f090c26857bfedc25b734.zip
graphics/jogamp-jogl:
- Properly rename gluegen library and jar files - Add patch to fix build on i386
Notes
Notes: svn path=/head/; revision=353810
Diffstat (limited to 'graphics/jogamp-jogl')
-rw-r--r--graphics/jogamp-jogl/Makefile17
-rw-r--r--graphics/jogamp-jogl/files/patch-freebsd.x8662
-rw-r--r--graphics/jogamp-jogl/files/patch-gluegen279
-rw-r--r--graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml22
4 files changed, 170 insertions, 10 deletions
diff --git a/graphics/jogamp-jogl/Makefile b/graphics/jogamp-jogl/Makefile
index 6fa3174a3e24..0472ed3ec385 100644
--- a/graphics/jogamp-jogl/Makefile
+++ b/graphics/jogamp-jogl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= jogamp-jogl
PORTVERSION= 2.1.5
+PORTREVISION= 1
CATEGORIES= graphics devel java
MASTER_SITES= http://jogamp.org/deployment/jogamp-current/archive/Sources/
DISTFILES= jogl-v${PORTVERSION}.tar.7z \
@@ -44,17 +45,17 @@ post-patch:
pre-build:
@(cd ${WRKDIR}/gluegen/make; \
- ${SETENV} ${MAKE_ENV} ${ANT} ${MAKE_ARGS} ${ALL_TARGET})
+ ${SETENV} ${MAKE_ENV} ${ANT} ${MAKE_ARGS} all.no_junit)
do-install:
- ${INSTALL_LIB} ${WRKDIR}/gluegen/build/obj/libgluegen-rt.so \
- ${STAGEDIR}${PREFIX}/lib/libgluegen2-rt.so
- ${INSTALL_DATA} ${WRKDIR}/gluegen/build/gluegen-rt.jar \
- ${STAGEDIR}${JAVAJARDIR}/gluegen2-rt.jar
- ${INSTALL_DATA} ${WRKDIR}/gluegen/build/gluegen.jar \
- ${STAGEDIR}${JAVAJARDIR}/gluegen2.jar
- ${INSTALL_LIB} ${WRKDIR}/jogl/build/lib/*.so \
+ ${INSTALL_LIB} \
+ ${WRKDIR}/gluegen/build/obj/libgluegen2-rt.so \
+ ${WRKDIR}/jogl/build/lib/*.so \
${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} \
+ ${WRKDIR}/gluegen/build/gluegen2-rt.jar \
+ ${WRKDIR}/gluegen/build/gluegen2.jar \
+ ${STAGEDIR}${JAVAJARDIR}
${INSTALL_DATA} ${WRKDIR}/jogl/build/jar/jogl-all.jar \
${STAGEDIR}${JAVAJARDIR}/jogl2.jar
diff --git a/graphics/jogamp-jogl/files/patch-freebsd.x86 b/graphics/jogamp-jogl/files/patch-freebsd.x86
new file mode 100644
index 000000000000..e753584956d6
--- /dev/null
+++ b/graphics/jogamp-jogl/files/patch-freebsd.x86
@@ -0,0 +1,62 @@
+--- jogl/make/build-jogl.xml.orig 2014-03-11 00:59:24.000000000 +0000
++++ jogl/make/build-jogl.xml 2014-05-12 07:33:35.849403725 +0000
+@@ -1195,7 +1195,7 @@
+
+ <!-- linker configuration -->
+
+- <linker id="linker.cfg.freebsd.jogl.x11" extends="linker.cfg.freebsd">
++ <linker id="linker.cfg.freebsd.x86.jogl.x11" extends="linker.cfg.freebsd.x86">
+ <syslibset dir="/usr/local/lib" libs="X11"/>
+ </linker>
+
+@@ -1383,7 +1383,7 @@
+ <target name="c.configure.freebsd.x86" depends="c.configure.x11" if="isFreeBSDX86">
+ <echo message="FreeBSD" />
+ <property name="compiler.cfg.id" value="compiler.cfg.freebsd.jogl" />
+- <property name="linker.cfg.id.os" value="linker.cfg.freebsd.jogl.x11" />
++ <property name="linker.cfg.id.os" value="linker.cfg.freebsd.x86.jogl.x11" />
+ </target>
+
+ <target name="c.configure.freebsd.amd64" depends="c.configure.x11" if="isFreeBSDAMD64">
+--- jogl/make/build-nativewindow.xml.orig 2014-03-11 00:59:24.000000000 +0000
++++ jogl/make/build-nativewindow.xml 2014-05-12 07:32:13.047407428 +0000
+@@ -365,7 +365,7 @@
+
+ <!-- linker configuration -->
+
+- <linker id="linker.cfg.freebsd.nativewindow.x11" extends="linker.cfg.freebsd">
++ <linker id="linker.cfg.freebsd.x86.nativewindow.x11" extends="linker.cfg.freebsd.x86">
+ <syslibset dir="/usr/local/lib" libs="X11"/>
+ <syslibset dir="/usr/local/lib" libs="Xxf86vm" />
+ <syslibset dir="/usr/local/lib" libs="Xrender"/>
+@@ -562,7 +562,7 @@
+ <target name="c.configure.freebsd.x86" if="isFreeBSDX86">
+ <echo message="FreeBSD.x86" />
+ <property name="compiler.cfg.id" value="compiler.cfg.freebsd.nativewindow" />
+- <property name="linker.cfg.id.oswin" value="linker.cfg.freebsd.nativewindow.x11" />
++ <property name="linker.cfg.id.oswin" value="linker.cfg.freebsd.x86.nativewindow.x11" />
+ </target>
+
+ <target name="c.configure.freebsd.amd64" if="isFreeBSDAMD64">
+--- jogl/make/build-newt.xml.orig 2014-03-11 00:59:24.000000000 +0000
++++ jogl/make/build-newt.xml 2014-05-12 07:32:57.565406321 +0000
+@@ -273,7 +273,7 @@
+
+ <!-- linker configuration -->
+
+- <linker id="linker.cfg.freebsd.newt.x11" extends="linker.cfg.freebsd">
++ <linker id="linker.cfg.freebsd.x86.newt.x11" extends="linker.cfg.freebsd.x86">
+ <linkerarg value="-L/usr/local/lib"/>
+ <syslibset libs="X11"/>
+ <syslibset libs="Xrandr"/>
+@@ -528,8 +528,8 @@
+ <target name="c.configure.freebsd.x86" if="isFreeBSDX86">
+ <echo message="FreeBSD.x86" />
+ <property name="compiler.cfg.id" value="compiler.cfg.freebsd.newt" />
+- <condition property="linker.cfg.id.oswin" value="linker.cfg.freebsd.newt.x11"
+- else="linker.cfg.freebsd">
++ <condition property="linker.cfg.id.oswin" value="linker.cfg.freebsd.x86.newt.x11"
++ else="linker.cfg.freebsd.x86">
+ <isset property="isX11" />
+ </condition>
+ <echo message="linker.cfg.id.oswin ${linker.cfg.id.oswin}" />
diff --git a/graphics/jogamp-jogl/files/patch-gluegen2 b/graphics/jogamp-jogl/files/patch-gluegen2
new file mode 100644
index 000000000000..fd05d8d44b6d
--- /dev/null
+++ b/graphics/jogamp-jogl/files/patch-gluegen2
@@ -0,0 +1,79 @@
+--- gluegen/make/build.xml.orig 2014-03-10 13:56:04.000000000 +0000
++++ gluegen/make/build.xml 2014-05-08 18:55:36.726179257 +0000
+@@ -439,7 +439,7 @@
+ <property name="c.compiler.src.files.common" value="src/native/common/*.c" />
+ <property name="c.compiler.src.files.os" value="src/native/${c.src.dir.os}/*.c" />
+
+- <property name="output.lib.name" value="gluegen-rt" />
++ <property name="output.lib.name" value="gluegen2-rt" />
+ <condition property="output.lib.name.os" value="lib${output.lib.name}.so"><isset property="isUnix"/></condition>
+ <condition property="output.lib.name.os" value="${output.lib.name}.dll"><isset property="isWindows"/></condition>
+ <condition property="output.lib.name.os" value="lib${output.lib.name}.jnilib"><isset property="isOSX"/></condition>
+@@ -633,14 +633,14 @@
+ <srcfiles dir= "${src.java}" includes="**"/>
+ <srcfiles dir= "${c.grammar}" includes="**/*.g"/>
+ <srcfiles dir= "${j.grammar}" includes="**/*.g"/>
+- <mapper type="merge" to="${build}/gluegen.jar"/>
++ <mapper type="merge" to="${build}/gluegen2.jar"/>
+ </uptodate>
+ <uptodate property="gluegen.build.skip.java2">
+ <srcfiles dir= "." includes="*.xml"/>
+ <srcfiles dir= "${src.java}" includes="**"/>
+ <srcfiles dir= "${c.grammar}" includes="**/*.g"/>
+ <srcfiles dir= "${j.grammar}" includes="**/*.g"/>
+- <mapper type="merge" to="${build}/gluegen-rt.jar"/>
++ <mapper type="merge" to="${build}/gluegen2-rt.jar"/>
+ </uptodate>
+ <condition property="gluegen.build.skip.java" value="true">
+ <or>
+@@ -752,7 +752,7 @@
+ </copy>
+
+ <!-- Build gluegen.jar. -->
+- <jar destfile="${build}/gluegen.jar" manifest="${build}/Manifest.temp">
++ <jar destfile="${build}/gluegen2.jar" manifest="${build}/Manifest.temp">
+ <service type="javax.annotation.processing.Processor">
+ <provider classname="com.jogamp.gluegen.structgen.CStructAnnotationProcessor"/>
+ </service>
+@@ -792,7 +792,7 @@
+ </copy>
+
+ <!-- Build gluegen-rt.jar. -->
+- <jar destfile="${build}/gluegen-rt.jar" manifest="${build}/Manifest-rt.temp">
++ <jar destfile="${build}/gluegen2-rt.jar" manifest="${build}/Manifest-rt.temp">
+ <fileset dir="${classes}">
+ <include name="com/jogamp/gluegen/runtime/*.class" />
+ <include name="com/jogamp/common/**" />
+--- gluegen/src/java/com/jogamp/common/os/Platform.java.orig 2014-03-10 13:56:04.000000000 +0000
++++ gluegen/src/java/com/jogamp/common/os/Platform.java 2014-05-08 18:47:51.760174681 +0000
+@@ -146,7 +146,7 @@
+ private static final String useTempJarCachePropName = "jogamp.gluegen.UseTempJarCache";
+
+ /** fixed basename of JAR file and native library */
+- private static final String libBaseName = "gluegen-rt";
++ private static final String libBaseName = "gluegen2-rt";
+
+ //
+ // static initialization order:
+--- gluegen/src/junit/com/jogamp/common/util/TestTempJarCache.java.orig 2014-03-10 13:56:04.000000000 +0000
++++ gluegen/src/junit/com/jogamp/common/util/TestTempJarCache.java 2014-05-08 18:47:51.758178183 +0000
+@@ -197,8 +197,8 @@
+ @Test
+ public void testTempJarCache02AddNativeLibs() throws IOException, IllegalArgumentException, URISyntaxException {
+ if(AndroidVersion.isAvailable) { System.err.println("n/a on Android"); return; }
+- final String nativeJarName = "gluegen-rt-natives-"+Platform.getOSAndArch()+".jar";
+- final String libBaseName = "gluegen-rt";
++ final String nativeJarName = "gluegen2-rt-natives-"+Platform.getOSAndArch()+".jar";
++ final String libBaseName = "gluegen2-rt";
+ final ClassLoader cl = getClass().getClassLoader();
+
+ URI jarUriRoot = JarUtil.getJarSubURI(TempJarCache.class.getName(), cl);
+@@ -217,7 +217,7 @@
+ @Test
+ public void testTempJarCache03AddNativeJarLibs() throws IOException {
+ if(AndroidVersion.isAvailable) { System.err.println("n/a on Android"); return; }
+- final String libBaseName = "gluegen-rt";
++ final String libBaseName = "gluegen2-rt";
+
+ JNILibLoaderBase.addNativeJarLibs(TempJarCache.class, libBaseName);
+ Assert.assertTrue(JNILibLoaderBase.isLoaded(libBaseName));
diff --git a/graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml b/graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml
index 8f18226de9f2..d4b19a02968e 100644
--- a/graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml
+++ b/graphics/jogamp-jogl/files/patch-jogl__make__build-common.xml
@@ -1,5 +1,5 @@
---- ./jogl/make/build-common.xml.orig 2014-04-29 16:52:29.835776699 +0000
-+++ ./jogl/make/build-common.xml 2014-04-29 16:56:14.552780952 +0000
+--- ./jogl/make/build-common.xml.orig 2014-03-11 00:59:24.000000000 +0000
++++ ./jogl/make/build-common.xml 2014-05-08 19:04:20.951173869 +0000
@@ -128,8 +128,8 @@
<condition property="swt.jar" value="${project.root}/make/lib/swt/win32-win32-x86/swt-debug.jar">
<istrue value="${isWindowsX86}" />
@@ -11,3 +11,21 @@
</condition>
<condition property="swt.jar" value="${project.root}/make/lib/swt/gtk-linux-x86_64/swt-debug.jar">
<istrue value="${isLinuxAMD64}" />
+@@ -208,7 +208,7 @@
+ <property name="gluegen.build.xml" value="${gluegen.make}/build.xml" />
+ <property name="build.gluegen" value="${gluegen.root}/${rootrel.build}" />
+ <property name="obj.gluegen" value="${build.gluegen}/obj"/>
+- <property name="gluegen.jar" value="${build.gluegen}/gluegen.jar" />
++ <property name="gluegen.jar" value="${build.gluegen}/gluegen2.jar" />
+ <property name="ant.jar" value="${ant.home}/lib/ant.jar" />
+ <property name="ant-junit.jar" value="${ant.home}/lib/ant-junit.jar" />
+
+@@ -413,7 +413,7 @@
+ </path>
+
+ <!-- JavaSE combinations -->
+- <property name="gluegen-rt.jar" value="${build.gluegen}/gluegen-rt.jar" />
++ <property name="gluegen-rt.jar" value="${build.gluegen}/gluegen2-rt.jar" />
+ <property name="gluegen-rt-android.jar" value="${build.gluegen}/gluegen-rt-android.jar" />
+ <property name="jogl-test.jar" value="${jar}/jogl-test.jar"/>
+ <property name="jogl-test-android.jar" value="${jar}/jogl-test-android.jar"/>