aboutsummaryrefslogtreecommitdiff
path: root/graphics/kludge3d
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-10-07 23:40:23 +0000
committerJohn Marino <marino@FreeBSD.org>2013-10-07 23:40:23 +0000
commit560d2eb0bf5f933214664a43ad5169397ea0dbff (patch)
treee61a78f0169c5b6d3db742a3a79532ae3afa9fab /graphics/kludge3d
parentdcdd82a024e96cfa26ac85f4ccaa54fe053336b4 (diff)
downloadports-560d2eb0bf5f933214664a43ad5169397ea0dbff.tar.gz
ports-560d2eb0bf5f933214664a43ad5169397ea0dbff.zip
Explicitly link libraries on 10 unmaintained ports
The following ports will not build with a binutils 2.22+ linker built with standard options. This has been obvious with DPorts, but difficult to see on FreeBSD. However, setting the ports compiler as a recent gcc (e.g lang/gcc48) is an excellent way to detect the unspecified but needed libraries as these recent GCC compilers use the latest binutils linkers. These patches were tested on FreeBSD 8.4 and DragonFly 3.5
Notes
Notes: svn path=/head/; revision=329747
Diffstat (limited to 'graphics/kludge3d')
-rw-r--r--graphics/kludge3d/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/kludge3d/Makefile b/graphics/kludge3d/Makefile
index 3aadbd8862d5..e755bf14c91c 100644
--- a/graphics/kludge3d/Makefile
+++ b/graphics/kludge3d/Makefile
@@ -25,7 +25,7 @@ PLIST_FILES= bin/kludge3d
CPPFLAGS+= -I${LOCALBASE}/include \
-I${PYTHON_INCLUDEDIR} ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib \
- -L${PYTHON_LIBDIR}/config ${PTHREAD_LIBS}
+ -L${PYTHON_LIBDIR}/config -lm ${PTHREAD_LIBS}
NO_STAGE= yes
post-patch: