aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawstudio
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-02-19 19:03:43 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-02-19 19:03:43 +0000
commit56719d41329c8c1d0fdae09fc2992b3621d7b3c7 (patch)
treeb6317ee8f50ae826e8725197f927935c9c239df6 /graphics/rawstudio
parentb1008ada68308cc47bab15e975e94ae64a952bb9 (diff)
downloadports-56719d41329c8c1d0fdae09fc2992b3621d7b3c7.tar.gz
ports-56719d41329c8c1d0fdae09fc2992b3621d7b3c7.zip
- fix build with clang
- support staging - convert desktopfileutils dependency to USES PR: 186771 Submitted by: Alex Samorukov <samm@os2.kiev.ua> (maintainer) MFH: 2014Q1
Notes
Notes: svn path=/head/; revision=345132
Diffstat (limited to 'graphics/rawstudio')
-rw-r--r--graphics/rawstudio/Makefile5
-rw-r--r--graphics/rawstudio/files/patch-rs-macros.h16
-rw-r--r--graphics/rawstudio/files/patch-rs-tag-gui.c28
3 files changed, 46 insertions, 3 deletions
diff --git a/graphics/rawstudio/Makefile b/graphics/rawstudio/Makefile
index 3498b11c96b4..5e5012cbf08c 100644
--- a/graphics/rawstudio/Makefile
+++ b/graphics/rawstudio/Makefile
@@ -26,12 +26,11 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES= gettext gmake pkgconfig
-USE_GNOME= gtk20 libxml2 gconf2 desktopfileutils gnomehack
+USES= desktop-file-utils gettext gmake pkgconfig
+USE_GNOME= gtk20 libxml2 gconf2 gnomehack
USE_SQLITE= 3
USE_LDCONFIG= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's, libssl,,' ${WRKSRC}/configure
diff --git a/graphics/rawstudio/files/patch-rs-macros.h b/graphics/rawstudio/files/patch-rs-macros.h
new file mode 100644
index 000000000000..fdc456950c0c
--- /dev/null
+++ b/graphics/rawstudio/files/patch-rs-macros.h
@@ -0,0 +1,16 @@
+--- librawstudio/rs-macros.h 2014-02-19 06:34:15.000000000 +0100
++++ librawstudio/rs-macros.h 2014-02-19 06:34:21.000000000 +0100
+@@ -51,12 +51,12 @@
+ #if __GNUC__ >= 3
+ #define likely(x) __builtin_expect (!!(x), 1)
+ #define unlikely(x) __builtin_expect (!!(x), 0)
+-#define align(x) __attribute__ ((aligned (x)))
++// #define align(x) __attribute__ ((aligned (x)))
+ #define __deprecated __attribute__ ((deprecated))
+ #else
+ #define likely(x) (x)
+ #define unlikely(x) (x)
+-#define align(x)
++// #define align(x)
+ #define __deprecated
+ #endif
diff --git a/graphics/rawstudio/files/patch-rs-tag-gui.c b/graphics/rawstudio/files/patch-rs-tag-gui.c
new file mode 100644
index 000000000000..3bd36dee10d4
--- /dev/null
+++ b/graphics/rawstudio/files/patch-rs-tag-gui.c
@@ -0,0 +1,28 @@
+--- src/rs-tag-gui.c.orig 2011-02-15 18:28:05.000000000 +0100
++++ src/rs-tag-gui.c 2014-02-14 18:36:48.000000000 +0100
+@@ -93,11 +93,6 @@
+ return box;
+ }
+
+-GtkWidget *
+-rs_library_tag_entry_new(RSLibrary *library)
+-{
+- g_assert(RS_IS_LIBRARY(library));
+-
+ gboolean
+ selected(GtkEntryCompletion *completion, GtkTreeModel *model, GtkTreeIter *iter, gpointer user_data)
+ {
+@@ -179,6 +174,13 @@
+ return found;
+ }
+
++
++GtkWidget *
++rs_library_tag_entry_new(RSLibrary *library)
++{
++ g_assert(RS_IS_LIBRARY(library));
++
++
+ GtkWidget *entry = gtk_entry_new();
+ GtkEntryCompletion *completion = gtk_entry_completion_new();
+ GtkListStore *store = gtk_list_store_new(1, G_TYPE_STRING);