aboutsummaryrefslogtreecommitdiff
path: root/japanese/Wnn7-lib
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2008-03-23 16:00:27 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2008-03-23 16:00:27 +0000
commitb31beba8fcece40f9054f0e209d4c50992785483 (patch)
tree10d78503de100e161a044ac5094dcac45966c374 /japanese/Wnn7-lib
parente619ebaa0cff5849a31f1555fe859accbbe0912e (diff)
downloadports-b31beba8fcece40f9054f0e209d4c50992785483.tar.gz
ports-b31beba8fcece40f9054f0e209d4c50992785483.zip
Fix build error with gcc-4.2.
PR: ports/120606 Submitted by: NAKAJI Hiroyuki <nakaji@jp.freebsd.org>
Notes
Notes: svn path=/head/; revision=209630
Diffstat (limited to 'japanese/Wnn7-lib')
-rw-r--r--japanese/Wnn7-lib/Makefile4
-rw-r--r--japanese/Wnn7-lib/files/patch-Wnn_etc_bdic.c12
-rw-r--r--japanese/Wnn7-lib/files/patch-Wnn_jlib_jl.c20
-rw-r--r--japanese/Wnn7-lib/files/patch-Wnn_jlib_js.c23
4 files changed, 55 insertions, 4 deletions
diff --git a/japanese/Wnn7-lib/Makefile b/japanese/Wnn7-lib/Makefile
index a22df8f05bd4..0dde03998800 100644
--- a/japanese/Wnn7-lib/Makefile
+++ b/japanese/Wnn7-lib/Makefile
@@ -24,10 +24,6 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' \
${WRKSRC}/config/Project.tmpl \
diff --git a/japanese/Wnn7-lib/files/patch-Wnn_etc_bdic.c b/japanese/Wnn7-lib/files/patch-Wnn_etc_bdic.c
new file mode 100644
index 000000000000..3861a406d168
--- /dev/null
+++ b/japanese/Wnn7-lib/files/patch-Wnn_etc_bdic.c
@@ -0,0 +1,12 @@
+--- Wnn/etc/bdic.c.orig 2007-11-11 17:46:42.000000000 +0900
++++ Wnn/etc/bdic.c 2007-11-11 17:47:41.000000000 +0900
+@@ -1015,9 +1015,6 @@
+ #ifdef WNN_CHECK_INODE
+ static
+ #else
+-#ifdef JS
+-static
+-#endif
+ #endif
+ int
+ change_file_uniq1(ofpter, file_type, file_passwd, file_uniq)
diff --git a/japanese/Wnn7-lib/files/patch-Wnn_jlib_jl.c b/japanese/Wnn7-lib/files/patch-Wnn_jlib_jl.c
new file mode 100644
index 000000000000..5ec2ec92ca2e
--- /dev/null
+++ b/japanese/Wnn7-lib/files/patch-Wnn_jlib_jl.c
@@ -0,0 +1,20 @@
+--- Wnn/jlib/jl.c.orig 2007-11-11 17:47:05.000000000 +0900
++++ Wnn/jlib/jl.c 2007-11-11 17:47:24.000000000 +0900
+@@ -143,6 +143,8 @@
+ #include "commonhd.h"
+ #include "config.h"
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <sys/types.h>
+ #ifdef SYSVR2
+ # include <string.h>
+@@ -734,7 +736,7 @@
+ js_close(js_id);
+ }
+
+-static void
++void
+ jl_disconnect_if_server_dead_body_by_jsid(jsid)
+ register WNN_JSERVER_ID *jsid;
+ {
diff --git a/japanese/Wnn7-lib/files/patch-Wnn_jlib_js.c b/japanese/Wnn7-lib/files/patch-Wnn_jlib_js.c
new file mode 100644
index 000000000000..ab5c21ff0217
--- /dev/null
+++ b/japanese/Wnn7-lib/files/patch-Wnn_jlib_js.c
@@ -0,0 +1,23 @@
+--- Wnn/jlib/js.c.orig 2007-11-11 17:46:58.000000000 +0900
++++ Wnn/jlib/js.c 2007-11-11 17:47:59.000000000 +0900
+@@ -159,9 +159,9 @@
+ */
+
+
+-extern char *malloc();
+-
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <ctype.h>
+ #ifdef UX386
+ #include <X11/Xos.h>
+@@ -199,8 +199,6 @@
+ #include "../etc/pwd.c"
+
+
+-char *malloc();
+-
+ typedef struct _host_address {
+ int address_len;
+ char *address;