aboutsummaryrefslogtreecommitdiff
path: root/japanese/anthy
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2023-01-28 12:37:59 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2023-01-28 12:37:59 +0000
commita2d5d783191e4cb94f51c3a1ddc996b0da8b16a3 (patch)
tree62faf2f2eccc6499c1b7c84b5065222e48056a50 /japanese/anthy
parent7c9bb96a4724df3bf42b1005f9cd6d84c581147f (diff)
downloadports-a2d5d783191e4cb94f51c3a1ddc996b0da8b16a3.tar.gz
ports-a2d5d783191e4cb94f51c3a1ddc996b0da8b16a3.zip
japanese/anthy: Fix runtime error of anthy.el with editors/emacs-devel
Diffstat (limited to 'japanese/anthy')
-rw-r--r--japanese/anthy/Makefile2
-rw-r--r--japanese/anthy/files/patch-src-util_anthy.el9
2 files changed, 10 insertions, 1 deletions
diff --git a/japanese/anthy/Makefile b/japanese/anthy/Makefile
index 2cd6d6d44969..f80dd0c3b327 100644
--- a/japanese/anthy/Makefile
+++ b/japanese/anthy/Makefile
@@ -1,6 +1,6 @@
PORTNAME= anthy
PORTVERSION= 0.4
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= japanese
MASTER_SITES= DEBIAN
diff --git a/japanese/anthy/files/patch-src-util_anthy.el b/japanese/anthy/files/patch-src-util_anthy.el
index b2052a38b369..e8b6d1da7a6d 100644
--- a/japanese/anthy/files/patch-src-util_anthy.el
+++ b/japanese/anthy/files/patch-src-util_anthy.el
@@ -1,5 +1,14 @@
--- src-util/anthy.el.orig 2019-07-05 02:37:13 UTC
+++ src-util/anthy.el
+@@ -71,7 +71,7 @@
+ (defvar anthy-highlight-face nil)
+ (defvar anthy-underline-face nil)
+ (copy-face 'highlight 'anthy-highlight-face)
+-(set-face-underline-p 'anthy-highlight-face t)
++(set-face-underline 'anthy-highlight-face t)
+ (copy-face 'underline 'anthy-underline-face)
+
+ ;;
@@ -745,7 +745,7 @@
(if anthy-agent-process
(kill-process anthy-agent-process))