aboutsummaryrefslogtreecommitdiff
path: root/japanese/eb
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-03-22 20:14:45 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-03-22 20:14:45 +0000
commit2685843a9389cdaf8912f0b57545f86bc9590e76 (patch)
tree0871487a188f40f4cbc7a0ed3ce543ef538b5ce7 /japanese/eb
parentc4d156427ad15cf1562cbcfa1881c4946d1b4604 (diff)
downloadports-2685843a9389cdaf8912f0b57545f86bc9590e76.tar.gz
ports-2685843a9389cdaf8912f0b57545f86bc9590e76.zip
- Strip shared library [1]
- Convert 'USE_BZIP2' to 'USES=tar.bzip2' [1] - Make ${PORTDOCS} always install [1] - Use options subs, helpers - Define perl path in CONFIGURE_ENV so that port sets correct shebangs PR: ports/187828 [1] Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=348805
Diffstat (limited to 'japanese/eb')
-rw-r--r--japanese/eb/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index 4e79c0819cc6..f5f3069485ab 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eb
PORTVERSION= 4.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/ \
ftp://ftp.sra.co.jp/pub/misc/eb/old/eb-${PORTVERSION:C/^([0-9]+)\.([0-9]+).*/\1.\2/}/
@@ -64,30 +64,24 @@ PORTDOCS= eb-01.html eb-02.html eb-03.html eb-04.html eb-05.html eb-06.html \
ebzip-08.html ebzip-09.html ebzip-10.html ebzip.html
USE_AUTOTOOLS= libtool
-USE_BZIP2= yes
-USES= perl5
+USES= perl5 tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-pkgdocdir=${DOCSDIR}
+CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
APPENDIXDIR= ${DATADIR}/appendix
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext iconv
-CONFIGURE_ARGS+= --enable-nls \
+NLS_USES= gettext iconv
+NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_ON= \
--with-gettext-includes=${LOCALBASE}/include \
--with-gettext-libraries=${LOCALBASE}/lib \
--with-iconv-includes=${ICONV_PREFIX}/include \
--with-iconv-libraries=${ICONV_PREFIX}/lib
-PLIST_SUB= NLS=""
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
post-extract:
${RM} -fr ${WRKSRC}/zlib
@@ -99,9 +93,8 @@ post-extract:
post-install:
(cd ${WRKDIR}/appendix && ${COPYTREE_SHARE} . ${STAGEDIR}${APPENDIXDIR} )
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/doc/,} ${STAGEDIR}${DOCSDIR}
-.endif
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libeb.so
.include <bsd.port.mk>