aboutsummaryrefslogtreecommitdiff
path: root/japanese/ebview-gtk2
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-12 14:53:13 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-12 14:57:24 +0000
commit43569aa1657055418738f3c294b77aaedb37afe5 (patch)
tree15f3b97b98723f50fe7e2dccbaf372a2d2eb4118 /japanese/ebview-gtk2
parentd5f731c045241a132fc67d34ca17d239b9141c90 (diff)
downloadports-43569aa1657055418738f3c294b77aaedb37afe5.tar.gz
ports-43569aa1657055418738f3c294b77aaedb37afe5.zip
japanese/ebview-gtk2: Unbreak on HEAD
- Optionize post-install target for DOCS - Utilize USES=localbase
Diffstat (limited to 'japanese/ebview-gtk2')
-rw-r--r--japanese/ebview-gtk2/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/japanese/ebview-gtk2/Makefile b/japanese/ebview-gtk2/Makefile
index 4bea062bfb1d..5718f5dbd2f3 100644
--- a/japanese/ebview-gtk2/Makefile
+++ b/japanese/ebview-gtk2/Makefile
@@ -13,21 +13,25 @@ LICENSE= GPLv2+
LIB_DEPENDS= libeb.so:japanese/eb
-CONFLICTS= ja-ebview
-
-USES= gettext gmake gnome pkgconfig
-USE_GNOME= gtk20 pangox-compat
+USES= gettext gmake gnome localbase:ldflags pkgconfig
USE_CSTD= gnu89
+USE_GNOME= gtk20 pangox-compat
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-eb-conf=${LOCALBASE}/etc/eb.conf
-SUB_FILES= ebview.desktop
+CONFLICTS= ja-ebview
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+SUB_FILES= ebview.desktop
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|#define GTK_DISABLE_DEPRECATED 1||g' \
${WRKSRC}/src/ebview.c
@@ -37,9 +41,11 @@ post-install:
${STAGEDIR}${DESKTOPDIR})
(cd ${WRKSRC}/pixmaps && ${INSTALL_DATA} ebview.xpm \
${STAGEDIR}${PREFIX}/share/pixmaps)
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ChangeLog README
(cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>