aboutsummaryrefslogtreecommitdiff
path: root/japanese/gedy
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2014-10-15 11:45:45 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2014-10-15 11:45:45 +0000
commit0c333a0fd8486afb30a3e688ad39a83fd8e8be35 (patch)
tree2c69e0a9a67d0f3b8659fa2e90328edccfa27481 /japanese/gedy
parent78a3ed4d90328ee57bb7881e9f17607986b099fe (diff)
downloadports-0c333a0fd8486afb30a3e688ad39a83fd8e8be35.tar.gz
ports-0c333a0fd8486afb30a3e688ad39a83fd8e8be35.zip
- Fix segmentation fault with recent Ruby-GNOME2.
- Use USES=shebangfix.
Notes
Notes: svn path=/head/; revision=370907
Diffstat (limited to 'japanese/gedy')
-rw-r--r--japanese/gedy/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/japanese/gedy/Makefile b/japanese/gedy/Makefile
index 6189f66e95a8..15168b337778 100644
--- a/japanese/gedy/Makefile
+++ b/japanese/gedy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gedy
PORTVERSION= 0.9.0
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= japanese ruby
MASTER_SITES= http://homepage3.nifty.com/slokar/pasori/
DISTNAME= ${PORTNAME}
@@ -19,6 +19,9 @@ RUN_DEPENDS= rubygem-gtk2>0:${PORTSDIR}/x11-toolkits/rubygem-gtk2 \
${RUBY_SITEARCHLIBDIR}/pasori.so:${PORTSDIR}/devel/libpafe-ruby
USE_RUBY= yes
+USES= shebangfix
+SHEBANG_FILES= ${PORTNAME}
+ruby_OLD_CMD= /usr/bin/ruby1.9.3
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS= -p
@@ -28,18 +31,11 @@ NO_BUILD= yes
PLIST_FILES= bin/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_DEFAULT_VER} != ${RUBY_VER}
-IGNORE= requires RUBY_DEFAULT_VER=${RUBY_VER}
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's,#! /usr/bin/ruby1.9.3,#!${RUBY},g' \
- ${WRKSRC}/${PORTNAME}
+ @${REINPLACE_CMD} -e 's/Gdk::Atom.new(0)/Gdk::Selection::CLIPBOARD/g' \
+ ${WRKSRC}/${PORTNAME}
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} \
- ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>