aboutsummaryrefslogtreecommitdiff
path: root/japanese/gsuica
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2012-09-15 15:32:30 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2012-09-15 15:32:30 +0000
commitfc7976bed78defb5644ced0a15baf67365a3704b (patch)
tree0a68549745026cad28a874c21f5984d32f001fd2 /japanese/gsuica
parent4c76c61a117b552c44e745fcd0be8d5a69d87437 (diff)
downloadports-fc7976bed78defb5644ced0a15baf67365a3704b.tar.gz
ports-fc7976bed78defb5644ced0a15baf67365a3704b.zip
It requires some additional ruby libs build for ruby19.
So, mark IGNORE when RUBY_DEFAULT_VER is not 1.9. Spotted by: pointyhat via beat
Notes
Notes: svn path=/head/; revision=304319
Diffstat (limited to 'japanese/gsuica')
-rw-r--r--japanese/gsuica/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/japanese/gsuica/Makefile b/japanese/gsuica/Makefile
index f55d7e7adc4c..8454202c25a6 100644
--- a/japanese/gsuica/Makefile
+++ b/japanese/gsuica/Makefile
@@ -32,6 +32,12 @@ NO_BUILD= yes
PLIST_FILES= bin/${PORTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_DEFAULT_VER} != ${RUBY_VER}
+IGNORE= requires RUBY_DEFAULT_VER=${RUBY_VER}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,#! /usr/bin/ruby1.9.3,#!${RUBY},g' \
${WRKSRC}/${PORTNAME}
@@ -55,4 +61,4 @@ station-code-fetch:
station-code-install:
@(cd ${WRKDIR}; ${SH} station_code_conv.sh StationCode.xls)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>