aboutsummaryrefslogtreecommitdiff
path: root/japanese/ibus-mozc
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2010-06-12 07:31:06 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2010-06-12 07:31:06 +0000
commite8a1f3b855155cabe9c74089d386c7197dd6b015 (patch)
tree7b59792a9537b44f7df719033124748157f8c927 /japanese/ibus-mozc
parent04b3c2c9dcbf48606103ed5e3f2f80cb0bd92c6f (diff)
downloadports-e8a1f3b855155cabe9c74089d386c7197dd6b015.tar.gz
ports-e8a1f3b855155cabe9c74089d386c7197dd6b015.zip
- update to mozc-0.11.365.102
- you need 8.0 or over to build mozc - added UT dictionary options to add UT extra dictionary. default is disable: WITH_DIC_UT_MEISHI, WITH_DIC_UT_JINMEI, WITH_DIC_UT_KAOMOJI, WITH_DIC_UT_EDICTKATAKANAGO, WITH_DIC_UT_ZIPCODE, WITH_DIC_UT_JIGYOSHO, WITH_DIC_UT_GCANNAKIHONMEISHI WITH_DIC_UT is shortcut of: WITH_DIC_UT_MEISHI WITH_DIC_UT_JINMEI WITH_DIC_UT_FULL is shortcut of: WITH_DIC_UT_MEISHI WITH_DIC_UT_JINMEI WITH_DIC_UT_KAOMOJI WITH_DIC_UT_EDICTKATAKANAGO WITH_DIC_UT_ZIPCODE WITH_DIC_UT_JIGYOSHO WITH_DIC_UT_GCANNAKIHONMEISHI - added two original icons because mozc has no icon files.
Notes
Notes: svn path=/head/; revision=256437
Diffstat (limited to 'japanese/ibus-mozc')
-rw-r--r--japanese/ibus-mozc/Makefile127
-rw-r--r--japanese/ibus-mozc/distinfo18
-rw-r--r--japanese/ibus-mozc/files/patch-src_base_iconv.cc4
-rw-r--r--japanese/ibus-mozc/files/patch-src_base_mutex.h4
-rw-r--r--japanese/ibus-mozc/files/patch-src_base_process.cc4
-rw-r--r--japanese/ibus-mozc/files/patch-src_base_util.cc4
-rw-r--r--japanese/ibus-mozc/files/patch-src_build_mozc.py4
-rw-r--r--japanese/ibus-mozc/files/patch-src_gyp_common.gypi4
-rw-r--r--japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc24
-rw-r--r--japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml13
-rw-r--r--japanese/ibus-mozc/files/patch-src_unix_ibus_mozc_engine.cc11
-rw-r--r--japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc4
-rw-r--r--japanese/ibus-mozc/pkg-plist2
13 files changed, 137 insertions, 86 deletions
diff --git a/japanese/ibus-mozc/Makefile b/japanese/ibus-mozc/Makefile
index 05bb5cf41e27..c6bda6b69b90 100644
--- a/japanese/ibus-mozc/Makefile
+++ b/japanese/ibus-mozc/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= ibus-mozc
-PORTVERSION= r28
-PORTREVISION= 2
+PORTVERSION= 0.11.365.102
+PORTREVISION= 0
CATEGORIES= japanese
MASTER_SITES= http://people.freebsd.org/~daichi/distfiles/
#MASTER_SITES= ${MASTER_SITE_LOCAL}
#MASTER_SITE_SUBDIR= daichi
-DISTNAME= ${PORTNAME}-${PORTVERSION}+gyp-r827
+DISTNAME= mozc-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-freebsd-addition-${PORTVERSION}${EXTRACT_SUFX}
+ mozc_build_tools-r827${EXTRACT_SUFX} \
+ ibus-mozc-freebsd-addition-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= daichi@freebsd.org
COMMENT= Mozc engine for IBus
@@ -27,35 +28,93 @@ LIB_DEPENDS= ibus.2:${PORTSDIR}/textproc/ibus \
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
${PYTHON_SITELIBDIR}/gtk-2.0/pynotify/_pynotify.so:${PORTSDIR}/devel/py-notify
-BROKEN= does not compile
+WRKSRC= ${WRKDIR}/mozc
+WRKADDITIONSRC= ${WRKDIR}/ibus-mozc-freebsd-addition-${PORTVERSION}
+WRKUTDICSRC= ${WRKDIR}/mozcdic-ut-20100612
+PROJECTHOST= ibus
USE_GNOME= pygtk2
USE_GMAKE= yes
USE_PYTHON= yes
USE_QT_VER= 4
-PROJECTHOST= ibus
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800107
+BROKEN= Does not compile on FreeBSD 7.X
+.endif
+
+.if defined(WITH_DIC_UT)
+WITH_DIC_UT_MEISHI=yes
+WITH_DIC_UT_JINMEI=yes
+.endif
+
+.if defined(WITH_DIC_UT_FULL)
+WITH_DIC_UT_MEISHI=yes
+WITH_DIC_UT_JINMEI=yes
+WITH_DIC_UT_KAOMOJI=yes
+WITH_DIC_UT_EDICTKATAKANAGO=yes
+WITH_DIC_UT_ZIPCODE=yes
+WITH_DIC_UT_JIGYOSHO=yes
+WITH_DIC_UT_GCANNAKIHONMEISHI=yes
+.endif
+
+.if defined(WITH_DIC_UT_MEISHI) || \
+ defined(WITH_DIC_UT_JINMEI) || \
+ defined(WITH_DIC_UT_KAOMOJI) || \
+ defined(WITH_DIC_UT_EDICTKATAKANAGO) || \
+ defined(WITH_DIC_UT_ZIPCODE) || \
+ defined(WITH_DIC_UT_JIGYOSHO) || \
+ defined(WITH_DIC_UT_GCANNAKIHONMEISHI)
+DISTFILES+= mozcdic-ut-20100612.tar.bz2
+.endif
-ADDITIONNAME= ${PORTNAME}-freebsd-addition-${PORTVERSION}
-REPLACE_FILES= \
- ${WRKSRC}/src/build_mozc.py \
- ${WRKSRC}/src/gyp/common.gypi \
- ${WRKSRC}/src/unix/ibus/mozc.xml \
- ${WRKSRC}/src/unix/ibus/path_util.cc \
- ${WRKSRC}/src/base/util.cc \
- ${WRKSRC}/src/base/process.cc \
- ${WRKSRC}/../${ADDITIONNAME}/bin/mozc_server_start \
- ${WRKSRC}/../${ADDITIONNAME}/bin/mozc_tool_config \
- ${WRKSRC}/../${ADDITIONNAME}/bin/mozc_tool_dictionary
+REPLACE_FILES= ${WRKSRC}/build_mozc.py \
+ ${WRKSRC}/gyp/common.gypi \
+ ${WRKSRC}/unix/ibus/mozc.xml \
+ ${WRKSRC}/unix/ibus/path_util.cc \
+ ${WRKSRC}/base/util.cc \
+ ${WRKSRC}/base/process.cc \
+ ${WRKADDITIONSRC}/Makefile
post-patch:
- @for FILE in ${REPLACE_FILES}; do \
+ @for FILE in ${REPLACE_FILES}; \
+ do \
${SED} -i .bak -e "s/@@LOCALBASE@@/${LOCALBASE:S/\//\\\//g}/g" \
$${FILE}; \
done;
+ @${CP} -R ${WRKDIR}/mozc_build_tools ${WRKSRC}
+.if defined(WITH_DIC_UT_MEISHI)
+ ${CAT} ${WRKUTDICSRC}/mozcdic-ut-meisi-20100612.txt \
+ >> ${WRKSRC}/data/dictionary/dictionary1.txt
+.endif
+.if defined(WITH_DIC_UT_JINMEI)
+ ${CAT} ${WRKUTDICSRC}/mozcdic-ut-jinmei-20100609.txt \
+ >> ${WRKSRC}/data/dictionary/dictionary1.txt
+.endif
+.if defined(WITH_DIC_UT_KAOMOJI)
+ ${CAT} ${WRKUTDICSRC}/kaomoji/mozcdic-ut-kaomoji-20100611.txt \
+ >> ${WRKSRC}/data/dictionary/dictionary1.txt
+.endif
+.if defined(WITH_DIC_UT_EDICTKATAKANAGO)
+ ${CAT} ${WRKUTDICSRC}/edict-katakanago/mozcdic-ut-edict-katakanago-20100609.txt \
+ >> ${WRKSRC}/data/dictionary/dictionary1.txt
+.endif
+.if defined(WITH_DIC_UT_ZIPCODE)
+ ${CAT} ${WRKUTDICSRC}/mozcdic-ut-zipcode-20100601.txt \
+ >> ${WRKSRC}/data/dictionary/dictionary1.txt
+.endif
+.if defined(WITH_DIC_UT_JIGYOSHO)
+ ${CAT} ${WRKUTDICSRC}/mozcdic-ut-jinmei-20100609.txt \
+ >> ${WRKSRC}/data/dictionary/dictionary1.txt
+.endif
+.if defined(WITH_DIC_UT_GCANNAKIHONMEISHI)
+ ${CAT} ${WRKUTDICSRC}/mozcdic-ut-gcanna-kihonmeisi-20100612.txt \
+ >> ${WRKSRC}/data/dictionary/dictionary1.txt
+.endif
do-build:
- @cd ${WRKSRC}/src; \
+ @cd ${WRKSRC}/; \
${PYTHON_CMD} build_mozc.py gyp; \
${SED} -i .bak -e "s/sed/gsed/g" Makefile; \
${PYTHON_CMD} build_mozc.py build_tools -c Release; \
@@ -67,39 +126,21 @@ do-build:
do-install:
@${MKDIR} ${LOCALBASE}/share/ibus-mozc/server
@${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/src/out/Release/mozc_server \
+ ${WRKSRC}/out/Release/mozc_server \
${LOCALBASE}/share/ibus-mozc/server/mozc_server
@${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/src/out/Release/mozc_tool \
+ ${WRKSRC}/out/Release/mozc_tool \
${LOCALBASE}/share/ibus-mozc/server/mozc_tool
@${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/src/out/Release/ibus_mozc \
+ ${WRKSRC}/out/Release/ibus_mozc \
${LOCALBASE}/libexec/ibus-engine-mozc
@${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/src/unix/ibus/mozc.xml \
+ ${WRKSRC}/unix/ibus/mozc.xml \
${LOCALBASE}/share/ibus/component/mozc.xml
- @${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/../${ADDITIONNAME}/bin/mozc_server_start \
- ${LOCALBASE}/bin/mozc_server_start
- @${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/../${ADDITIONNAME}/bin/mozc_server_stop \
- ${LOCALBASE}/bin/mozc_server_stop
- @${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/../${ADDITIONNAME}/bin/mozc_server_restart \
- ${LOCALBASE}/bin/mozc_server_restart
- @${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/../${ADDITIONNAME}/bin/mozc_tool_config \
- ${LOCALBASE}/bin/mozc_tool_config
- @${INSTALL} -o 0 -g 0 -m 555 \
- ${WRKSRC}/../${ADDITIONNAME}/bin/mozc_tool_dictionary \
- ${LOCALBASE}/bin/mozc_tool_dictionary
- @${MKDIR} ${LOCALBASE}/share/ibus-mozc/icons
- @${INSTALL} -o 0 -g 0 -m 444 \
- ${WRKSRC}/../${ADDITIONNAME}/icons/mozc-temp-icon.png \
- ${LOCALBASE}/share/ibus-mozc/icons/product_icon.png
+ @cd ${WRKADDITIONSRC}; make install
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/ibus-mozc/distinfo b/japanese/ibus-mozc/distinfo
index f8cc8dd52b58..2628cce684f2 100644
--- a/japanese/ibus-mozc/distinfo
+++ b/japanese/ibus-mozc/distinfo
@@ -1,6 +1,12 @@
-MD5 (ibus-mozc-r28+gyp-r827.tar.gz) = 2ee2fe0b8e5997e10d8a186261ca0999
-SHA256 (ibus-mozc-r28+gyp-r827.tar.gz) = 4822ac6398d1e4386ec9666eb151760678340af412b88008401ef29b58f5cd75
-SIZE (ibus-mozc-r28+gyp-r827.tar.gz) = 47912590
-MD5 (ibus-mozc-freebsd-addition-r28.tar.gz) = a00882bd2415ea943e4e6c032ff0bec2
-SHA256 (ibus-mozc-freebsd-addition-r28.tar.gz) = 41a93497daf8ab3c9f0151026bbe3a92e6654d169d32801316265daa048a71bc
-SIZE (ibus-mozc-freebsd-addition-r28.tar.gz) = 2052
+MD5 (mozc-0.11.365.102.tar.gz) = 24b5faa4dc8cd37ee02e914b0d20cc18
+SHA256 (mozc-0.11.365.102.tar.gz) = 91f8d2081a705452012f4e94bc4215872e1465deaa46bad38814668c50511eb7
+SIZE (mozc-0.11.365.102.tar.gz) = 47786830
+MD5 (mozc_build_tools-r827.tar.gz) = 3727faae1268afbe1b740f93db55f933
+SHA256 (mozc_build_tools-r827.tar.gz) = 16f5d25f83a1ed127c7a5ce1192840b6d64435b62991d6bb4815c1549fb91e1c
+SIZE (mozc_build_tools-r827.tar.gz) = 434262
+MD5 (ibus-mozc-freebsd-addition-0.11.365.102.tar.gz) = 552a4d4a9e473bff7db20ba25005e6b8
+SHA256 (ibus-mozc-freebsd-addition-0.11.365.102.tar.gz) = 04a526ae11c3188910d6ab1c40f15a389301da2a747df67e6488113ce6dfa0c4
+SIZE (ibus-mozc-freebsd-addition-0.11.365.102.tar.gz) = 3068
+MD5 (mozcdic-ut-20100612.tar.bz2) = 65787929cc45a648bf91a44635604a46
+SHA256 (mozcdic-ut-20100612.tar.bz2) = d18da85c4a704dffafd892dffd9af2bcb68a4068e615d36ac38320bc721a6b6c
+SIZE (mozcdic-ut-20100612.tar.bz2) = 4334391
diff --git a/japanese/ibus-mozc/files/patch-src_base_iconv.cc b/japanese/ibus-mozc/files/patch-src_base_iconv.cc
index 65ae356ddb6c..7f2f5b122cf5 100644
--- a/japanese/ibus-mozc/files/patch-src_base_iconv.cc
+++ b/japanese/ibus-mozc/files/patch-src_base_iconv.cc
@@ -1,5 +1,5 @@
---- src/base/iconv.cc.org 2010-05-29 11:06:10.667672161 +0900
-+++ src/base/iconv.cc 2010-05-29 11:22:12.794853968 +0900
+--- base/iconv.cc.org 2010-06-11 18:01:03.000000000 +0900
++++ base/iconv.cc 2010-06-12 10:02:20.315839057 +0900
@@ -52,7 +52,7 @@
size_t olen_org = olen;
iconv(ic, 0, &ilen, 0, &olen); // reset iconv state
diff --git a/japanese/ibus-mozc/files/patch-src_base_mutex.h b/japanese/ibus-mozc/files/patch-src_base_mutex.h
index 1a83b08e7d50..d5bf95f853f5 100644
--- a/japanese/ibus-mozc/files/patch-src_base_mutex.h
+++ b/japanese/ibus-mozc/files/patch-src_base_mutex.h
@@ -1,5 +1,5 @@
---- src/base/mutex.h.org 2010-05-29 11:06:10.678543934 +0900
-+++ src/base/mutex.h 2010-05-29 11:25:17.454000870 +0900
+--- base/mutex.h.org 2010-06-11 18:01:03.000000000 +0900
++++ base/mutex.h 2010-06-12 10:02:50.414966599 +0900
@@ -87,7 +87,7 @@
#endif
diff --git a/japanese/ibus-mozc/files/patch-src_base_process.cc b/japanese/ibus-mozc/files/patch-src_base_process.cc
index 11057c3610d3..9d03245ec4f1 100644
--- a/japanese/ibus-mozc/files/patch-src_base_process.cc
+++ b/japanese/ibus-mozc/files/patch-src_base_process.cc
@@ -1,5 +1,5 @@
---- src/base/process.cc.org 2010-05-29 12:46:19.289472417 +0900
-+++ src/base/process.cc 2010-05-29 20:56:37.509543123 +0900
+--- base/process.cc.org 2010-06-11 18:01:03.000000000 +0900
++++ base/process.cc 2010-06-12 10:03:39.662872618 +0900
@@ -195,7 +195,7 @@
#endif
diff --git a/japanese/ibus-mozc/files/patch-src_base_util.cc b/japanese/ibus-mozc/files/patch-src_base_util.cc
index d8c90d2cf2c7..a5f0b5f99725 100644
--- a/japanese/ibus-mozc/files/patch-src_base_util.cc
+++ b/japanese/ibus-mozc/files/patch-src_base_util.cc
@@ -1,5 +1,5 @@
---- src/base/util.cc.org 2010-05-29 12:46:19.265746218 +0900
-+++ src/base/util.cc 2010-05-29 20:52:31.971118268 +0900
+--- base/util.cc.org 2010-06-11 18:01:03.000000000 +0900
++++ base/util.cc 2010-06-12 10:04:16.922969013 +0900
@@ -1489,7 +1489,7 @@
#endif // OS_MACOSX
diff --git a/japanese/ibus-mozc/files/patch-src_build_mozc.py b/japanese/ibus-mozc/files/patch-src_build_mozc.py
index 78c1f8fc6108..2aee74bfd72e 100644
--- a/japanese/ibus-mozc/files/patch-src_build_mozc.py
+++ b/japanese/ibus-mozc/files/patch-src_build_mozc.py
@@ -1,5 +1,5 @@
---- src/build_mozc.py.org 2010-05-29 11:06:11.353375791 +0900
-+++ src/build_mozc.py 2010-05-29 11:49:27.698956304 +0900
+--- build_mozc.py.org 2010-06-11 18:01:03.000000000 +0900
++++ build_mozc.py 2010-06-12 10:05:39.176190512 +0900
@@ -67,7 +67,7 @@
def IsLinux():
diff --git a/japanese/ibus-mozc/files/patch-src_gyp_common.gypi b/japanese/ibus-mozc/files/patch-src_gyp_common.gypi
index f1461a302069..8e637be0cfac 100644
--- a/japanese/ibus-mozc/files/patch-src_gyp_common.gypi
+++ b/japanese/ibus-mozc/files/patch-src_gyp_common.gypi
@@ -1,5 +1,5 @@
---- src/gyp/common.gypi.org 2010-05-29 11:05:15.815250973 +0900
-+++ src/gyp/common.gypi 2010-05-29 11:30:52.119608091 +0900
+--- gyp/common.gypi.org 2010-06-11 18:00:39.000000000 +0900
++++ gyp/common.gypi 2010-06-12 10:06:52.655552554 +0900
@@ -420,6 +420,8 @@
'-lssl',
'-lz',
diff --git a/japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc b/japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc
index 50b641d1cb1a..6c18ebd6aa34 100644
--- a/japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc
+++ b/japanese/ibus-mozc/files/patch-src_ipc_unix_ipc.cc
@@ -1,11 +1,11 @@
---- src/ipc/unix_ipc.cc.org 2010-05-29 11:06:11.125610530 +0900
-+++ src/ipc/unix_ipc.cc 2010-05-29 11:33:18.938743764 +0900
+--- ipc/unix_ipc.cc.org 2010-06-11 18:01:03.000000000 +0900
++++ ipc/unix_ipc.cc 2010-06-12 10:21:51.905675963 +0900
@@ -41,7 +41,7 @@
#include <sys/time.h>
#include <sys/types.h>
#include <sys/un.h>
-#ifdef OS_MACOSX
-+#ifdef __FreeBSD__
++#if defined(__FreeBSD__) || defined(OS_MACOSX)
#include <sys/ucred.h>
#endif
#include <sys/wait.h>
@@ -14,24 +14,16 @@
*pid = 0;
-#ifdef OS_MACOSX
-+#ifdef __FreeBSD__
++#if defined(__FreeBSD__) || defined(OS_MACOSX)
// If the OS is MAC, we should validate the peer by using LOCAL_PEERCRED.
struct xucred peer_cred;
socklen_t peer_cred_len = sizeof(struct xucred);
-@@ -146,6 +146,7 @@
+@@ -146,7 +146,7 @@
*pid = 0;
#endif
-+/*
- #ifdef OS_LINUX
+-#ifdef OS_LINUX
++#if !defined(__FreeBSD__) && defined(OS_LINUX)
// On ARM Linux, we do nothing and just return true since the platform (at
// least the qemu emulator) doesn't support the getsockopt(sock, SOL_SOCKET,
-@@ -171,7 +172,7 @@
- *pid = peer_cred.pid;
- #endif // __arm__
- #endif
--
-+*/
- return true;
- }
-
+ // SO_PEERCRED) system call.
diff --git a/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml b/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml
index 500c3f4c2eae..cc26cb581a02 100644
--- a/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml
+++ b/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc.xml
@@ -1,17 +1,16 @@
---- src/unix/ibus/mozc.xml.org 2010-05-29 12:45:05.978914232 +0900
-+++ src/unix/ibus/mozc.xml 2010-05-29 20:08:12.040296893 +0900
-@@ -2,12 +2,12 @@
- <component>
+--- unix/ibus/mozc.xml.org 2010-06-11 18:00:39.000000000 +0900
++++ unix/ibus/mozc.xml 2010-06-12 10:22:30.668862555 +0900
+@@ -3,6 +3,7 @@
<name>com.google.IBus.Mozc</name>
<description>Mozc Component</description>
-- <exec>/usr/libexec/ibus-engine-mozc --ibus</exec>
+ <exec>/usr/libexec/ibus-engine-mozc --ibus</exec>
+ <exec>@@LOCALBASE@@/libexec/ibus-engine-mozc --ibus</exec>
<!-- TODO(mazda): Generate the version number -->
<version>0.0.0.0</version>
<author>Google Inc.</author>
- <license>New BSD</license>
+@@ -10,4 +11,5 @@
<homepage>http://code.google.com/p/mozc/</homepage>
<textdomain>ibus-mozc</textdomain>
-- <engines exec="/usr/libexec/ibus-engine-mozc --xml" />
+ <engines exec="/usr/libexec/ibus-engine-mozc --xml" />
+ <engines exec="@@LOCALBASE@@/libexec/ibus-engine-mozc --xml" />
</component>
diff --git a/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc_engine.cc b/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc_engine.cc
new file mode 100644
index 000000000000..d338366bec65
--- /dev/null
+++ b/japanese/ibus-mozc/files/patch-src_unix_ibus_mozc_engine.cc
@@ -0,0 +1,11 @@
+--- unix/ibus/mozc_engine.cc.org 2010-06-11 18:00:39.000000000 +0900
++++ unix/ibus/mozc_engine.cc 2010-06-12 13:19:26.188760964 +0900
+@@ -59,7 +59,7 @@
+
+ // Icon path for MozcTool
+ // TODO(taku): currently, unknown icon is displayed.
+-const char kMozcToolIconPath[] = "unknown.ico";
++const char kMozcToolIconPath[] = "toolicon_setting.png";
+
+ // for every 5 minutes, call SyncData
+ const uint64 kSyncDataInterval = 5 * 60;
diff --git a/japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc b/japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc
index 8fb37976c244..824dd8e4fa9e 100644
--- a/japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc
+++ b/japanese/ibus-mozc/files/patch-src_unix_ibus_path_util.cc
@@ -1,5 +1,5 @@
---- src/unix/ibus/path_util.cc.org 2010-05-29 12:45:05.983913471 +0900
-+++ src/unix/ibus/path_util.cc 2010-05-29 21:43:40.031728485 +0900
+--- unix/ibus/path_util.cc.org 2010-06-11 18:00:39.000000000 +0900
++++ unix/ibus/path_util.cc 2010-06-12 10:23:37.582580151 +0900
@@ -30,14 +30,14 @@
#include "unix/ibus/path_util.h"
diff --git a/japanese/ibus-mozc/pkg-plist b/japanese/ibus-mozc/pkg-plist
index 1f111b267cee..4a45a460b5c0 100644
--- a/japanese/ibus-mozc/pkg-plist
+++ b/japanese/ibus-mozc/pkg-plist
@@ -1,3 +1,4 @@
+bin/ibus-daemon_restart
bin/mozc_server_restart
bin/mozc_server_start
bin/mozc_server_stop
@@ -6,6 +7,7 @@ bin/mozc_tool_dictionary
libexec/ibus-engine-mozc
share/ibus/component/mozc.xml
share/ibus-mozc/icons/product_icon.png
+share/ibus-mozc/icons/toolicon_setting.png
share/ibus-mozc/server/mozc_tool
share/ibus-mozc/server/mozc_server
@dirrm share/ibus-mozc/icons