aboutsummaryrefslogtreecommitdiff
path: root/japanese/jacode.pl
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-05-30 15:12:45 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-05-30 15:12:45 +0000
commitc149c0d890e18090887f2d1ad09a4ccf2f8a2328 (patch)
tree09f336ca9dbd86c16a9f9bc58f120363742bc3ca /japanese/jacode.pl
parent7ebda4d09726511d7fda3fc06f61e0791575103e (diff)
downloadports-c149c0d890e18090887f2d1ad09a4ccf2f8a2328.tar.gz
ports-c149c0d890e18090887f2d1ad09a4ccf2f8a2328.zip
- Add a new port: japanese/jacode.pl
jacode.pl - Perl library for Japanese character code conversion This software has upper compatibility to jcode.pl. * jcode.pl upper compatible * Perl4 script * Acts as a wrapper to Encode::from_to * Support HALFWIDTH KATAKANA * Support UTF-8 by cp932 to Unicode table http://unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT http://support.microsoft.com/kb/170559/ja (JIS X 0221:2007 BASIC JAPANESE and COMMON JAPANESE) * Hidden UTF8 flag * No Object oriented * Possible to re-use past code and how to WWW: http://search.cpan.org/dist/jacode/ PR: ports/156972 Submitted by: Takefu <takefu_AT_airport_DOT_fm>
Notes
Notes: svn path=/head/; revision=274812
Diffstat (limited to 'japanese/jacode.pl')
-rw-r--r--japanese/jacode.pl/Makefile32
-rw-r--r--japanese/jacode.pl/distinfo2
-rw-r--r--japanese/jacode.pl/pkg-descr17
3 files changed, 51 insertions, 0 deletions
diff --git a/japanese/jacode.pl/Makefile b/japanese/jacode.pl/Makefile
new file mode 100644
index 000000000000..f8439a1e148f
--- /dev/null
+++ b/japanese/jacode.pl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: jacode.pl
+# Date created: 2011-05-11
+# Whom: Takefu
+#
+# $FreeBSD$
+#
+
+PORTNAME= jacode.pl
+PORTVERSION= 2.13.4.9
+CATEGORIES= japanese perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IN/INA/${PORTNAME:S|.pl||}
+DISTNAME= ${PORTNAME:S|.pl||}-${PORTVERSION}
+
+MAINTAINER= takefu@airport.fm
+COMMENT= Perl library for Japanese character code conversion
+
+USE_PERL5_RUN= yes
+PLIST_FILES= ${SITE_PERL_REL}/${PORTNAME}
+NO_BUILD= yes
+
+LICENSE= GPLv1 ART10
+LICENSE_COMB= dual
+
+pre-install:
+ @cd ${WRKSRC}; ${PERL} ${WRKSRC}/test.pl
+
+do-install:
+ @${MKDIR} ${PREFIX}/${SITE_PERL_REL}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME} ${PREFIX}/${SITE_PERL_REL}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/japanese/jacode.pl/distinfo b/japanese/jacode.pl/distinfo
new file mode 100644
index 000000000000..0f781bf24cfa
--- /dev/null
+++ b/japanese/jacode.pl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jacode-2.13.4.9.tar.gz) = 6a53976fbc7f2abcba6dbba6203366912a9a9b297548cc22f4a5ed12fa99c08c
+SIZE (jacode-2.13.4.9.tar.gz) = 285542
diff --git a/japanese/jacode.pl/pkg-descr b/japanese/jacode.pl/pkg-descr
new file mode 100644
index 000000000000..3de9c6b2c6ca
--- /dev/null
+++ b/japanese/jacode.pl/pkg-descr
@@ -0,0 +1,17 @@
+jacode.pl - Perl library for Japanese character code conversion
+
+This software has upper compatibility to jcode.pl.
+
+* jcode.pl upper compatible
+* Perl4 script
+* Acts as a wrapper to Encode::from_to
+* Support HALFWIDTH KATAKANA
+* Support UTF-8 by cp932 to Unicode table
+ http://unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
+ http://support.microsoft.com/kb/170559/ja
+ (JIS X 0221:2007 BASIC JAPANESE and COMMON JAPANESE)
+* Hidden UTF8 flag
+* No Object oriented
+* Possible to re-use past code and how to
+
+WWW: http://search.cpan.org/dist/jacode/