aboutsummaryrefslogtreecommitdiff
path: root/japanese/lynx
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-06-18 22:46:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-06-18 22:46:24 +0000
commit9d2daefba9636cc700b57e3e5f88f85c8b539b6d (patch)
tree896fe3e866560384d7114ed99e8c033ade3511d7 /japanese/lynx
parente9841701d7e9d0f67d67dc116174e84cdccfaa49 (diff)
downloadports-9d2daefba9636cc700b57e3e5f88f85c8b539b6d.tar.gz
ports-9d2daefba9636cc700b57e3e5f88f85c8b539b6d.zip
- Resurrect, unbreak and update to 2.8.6.rel4
PR: ports/111326 Submitted by: Watanabe Kazuhiro <CQG00620@nifty.ne.jp>
Notes
Notes: svn path=/head/; revision=215154
Diffstat (limited to 'japanese/lynx')
-rw-r--r--japanese/lynx/Makefile64
-rw-r--r--japanese/lynx/distinfo3
-rw-r--r--japanese/lynx/files/patch-aa46
-rw-r--r--japanese/lynx/pkg-descr5
-rw-r--r--japanese/lynx/pkg-plist108
5 files changed, 226 insertions, 0 deletions
diff --git a/japanese/lynx/Makefile b/japanese/lynx/Makefile
new file mode 100644
index 000000000000..d4b1f436222b
--- /dev/null
+++ b/japanese/lynx/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: ja-lynx
+# Date created: 10 August 1998
+# Whom: Shigeyuki FUKUSHIMA <shige@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lynx
+PORTVERSION= ${VERSION}.${MINOR_VERSION:S/.//}
+CATEGORIES= japanese www ipv6
+MASTER_SITES= http://lynx.isc.org/current/ \
+ http://ftp2.uk.freebsd.org/sites/lynx.isc.org/current/
+DISTNAME= ${PORTNAME}${VERSION}${MINOR_VERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A terminal-based World-Wide Web Client with multi-byte modification
+
+VERSION= 2.8.6
+MINOR_VERSION= rel.4
+
+CONFLICTS= lynx-2.* lynx-ssl-2.*
+
+WRKSRC= ${WRKDIR}/${PORTNAME}${VERSION:S/./-/g}
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-screen=ncurses --with-zlib --libdir="${L_LIB}" \
+ --enable-nsl-fork --enable-ipv6 \
+ --enable-cjk --enable-justify-elts --enable-internal-links
+
+.if defined(ENABLE_COLOR_STYLE)
+PLIST_SUB+= ENABLE_COLOR_STYLE=""
+.else
+CONFIGURE_ARGS+=--disable-color-style
+PLIST_SUB+= ENABLE_COLOR_STYLE="@comment "
+.endif
+
+.if defined(ENABLE_DEFAULT_COLORS)
+CONFIGURE_ARGS+=--enable-default-colors
+.endif
+
+MAKE_ARGS= helpdir=${L_HELP} docdir=${DOCSDIR}
+MAKEFILE= makefile
+MAN1= lynx.1
+
+.if !defined(NOPORTDOCS)
+INSTALL_TARGET= install-full
+.else
+INSTALL_TARGET= install install-help
+.endif
+
+L_LIB= ${PREFIX}/etc
+L_HELP= ${PREFIX}/share/lynx_help
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lssl -lcrypto|-L${OPENSSLLIB} &|g' \
+ ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+.endif
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${L_HELP}
+
+.include <bsd.port.mk>
diff --git a/japanese/lynx/distinfo b/japanese/lynx/distinfo
new file mode 100644
index 000000000000..5d0f03ba082d
--- /dev/null
+++ b/japanese/lynx/distinfo
@@ -0,0 +1,3 @@
+MD5 (lynx2.8.6rel.4.tar.bz2) = dc80497b7dda6a28fd80404684d27548
+SHA256 (lynx2.8.6rel.4.tar.bz2) = c7d876d52d08e4e593e8f3a04ba6d6c86685570828d1b7a16723702c7643c2a3
+SIZE (lynx2.8.6rel.4.tar.bz2) = 2291156
diff --git a/japanese/lynx/files/patch-aa b/japanese/lynx/files/patch-aa
new file mode 100644
index 000000000000..03482bd158e1
--- /dev/null
+++ b/japanese/lynx/files/patch-aa
@@ -0,0 +1,46 @@
+--- makefile.in.orig Mon Sep 4 08:25:39 2006
++++ makefile.in Thu Apr 5 17:42:33 2007
+@@ -360,13 +360,9 @@
+ if test "$(COMPRESS_PROG)" != "" ; then \
+ (cd $(HELPDIR) && $(COMPRESS_PROG) $$files ) \
+ fi'
+- @echo Updating $(sysconfdir)/lynx.cfg
+- @ECHO_CC@$(SHELL) -c 'if test -f $(SYSCONFDIR)/lynx.cfg ; then \
+- mv $(SYSCONFDIR)/lynx.cfg $(SYSCONFDIR)/lynx.tmp ; \
+- else \
+- cp $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.tmp ; \
+- fi'
+- @echo Updating $(sysconfdir)/lynx.cfg to point to installed help-files
++ @echo Updating $(sysconfdir)/lynx.cfg.default
++ cp $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.tmp ;
++ @echo Updating $(sysconfdir)/lynx.cfg.default to point to installed help-files
+ @ECHO_CC@sed -e '/^HELPFILE:http/s!^!#!' \
+ -e '/^#HELPFILE:file/s!#!!' \
+ $(SYSCONFDIR)/lynx.tmp | \
+@@ -374,9 +370,9 @@
+ $(SHELL) $(scripts_dir)/cfg_path.sh lynx_doc $(helpdir) | \
+ sed -e '/^HELPFILE:file/s!$$!$(COMPRESS_EXT)!' \
+ -e '/^HELPFILE:file/s!$(COMPRESS_EXT)$(COMPRESS_EXT)$$!$(COMPRESS_EXT)!' \
+- >$(SYSCONFDIR)/lynx.cfg
+- chmod 644 $(SYSCONFDIR)/lynx.cfg
++ >$(SYSCONFDIR)/lynx.cfg.default
+ -rm -f $(SYSCONFDIR)/lynx.tmp
++ -[ ! -f $(SYSCONFDIR)/lynx.cfg ] && $(INSTALL_DATA) $(SYSCONFDIR)/lynx.cfg.default $(SYSCONFDIR)/lynx.cfg
+
+ LYHelp.h : help_files.sed LYHelp.hin
+ @echo Creating $@
+@@ -398,11 +394,11 @@
+ $(SHELL) -c 'SHELL=$(SHELL) $(SHELL) $(scripts_dir)/cfg_defs.sh $(srcdir)'
+
+ install-cfg : $(SYSCONFDIR)
+- @$(SHELL) $(scripts_dir)/install-cfg.sh "$(INSTALL_DATA)" $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.cfg
++ @$(SHELL) $(scripts_dir)/install-cfg.sh "$(INSTALL_DATA)" $(srcdir)/lynx.cfg $(SYSCONFDIR)/lynx.cfg.default
+
+ install-lss : $(SYSCONFDIR)
+- -mv -f $(SYSCONFDIR)/lynx.lss $(SYSCONFDIR)/lynx.oldlss
+- $(INSTALL_DATA) $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss
++ $(INSTALL_DATA) $(srcdir)/samples/lynx.lss $(SYSCONFDIR)/lynx.lss.default
++ -[ ! -f $(SYSCONFDIR)/lynx.lss ] && $(INSTALL_DATA) $(SYSCONFDIR)/lynx.lss.default $(SYSCONFDIR)/lynx.lss
+
+ uninstall ::
+ @MSG_DIR_MAKE@ cd po && $(MAKE) CC="$(CC)" uninstall
diff --git a/japanese/lynx/pkg-descr b/japanese/lynx/pkg-descr
new file mode 100644
index 000000000000..43da40068d05
--- /dev/null
+++ b/japanese/lynx/pkg-descr
@@ -0,0 +1,5 @@
+lynx is a program which allows a user to access World-Wide Web servers
+and other information servers. It uses only ascii representation so
+that it can be used from ascii-terminals and dial-in lines.
+
+WWW: http://lynx.isc.org/current/
diff --git a/japanese/lynx/pkg-plist b/japanese/lynx/pkg-plist
new file mode 100644
index 000000000000..af7e8b459245
--- /dev/null
+++ b/japanese/lynx/pkg-plist
@@ -0,0 +1,108 @@
+bin/lynx
+@unexec if [ -f %D/etc/lynx.cfg ] && cmp -s %D/etc/lynx.cfg %D/etc/lynx.cfg.default; then rm -f %D/etc/lynx.cfg; fi
+etc/lynx.cfg.default
+@exec if [ ! -f %D/etc/lynx.cfg ] ; then cp -p %D/%F %B/lynx.cfg; fi
+%%ENABLE_COLOR_STYLE%%@unexec if [ -f %D/etc/lynx.lss ] && cmp -s %D/etc/lynx.lss %D/etc/lynx.lss.default; then rm -f %D/etc/lynx.lss; fi
+%%ENABLE_COLOR_STYLE%%etc/lynx.lss.default
+%%ENABLE_COLOR_STYLE%%@exec if [ ! -f %D/etc/lynx.lss ] ; then cp -p %D/%F %B/lynx.lss; fi
+@exec mkdir -p %D/share/lynx_help
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYHEADER
+%%PORTDOCS%%@exec ln -sf %D/%F %D/share/lynx_help
+%%PORTDOCS%%%%DOCSDIR%%/COPYHEADER.asc
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%@exec ln -sf %D/%F %D/share/lynx_help
+%%PORTDOCS%%%%DOCSDIR%%/COPYING.asc
+%%PORTDOCS%%%%DOCSDIR%%/PROBLEMS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.3
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.4
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.5
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.6
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.7
+%%PORTDOCS%%%%DOCSDIR%%/docs/CHANGES2.8
+%%PORTDOCS%%%%DOCSDIR%%/docs/CRAWL.announce
+%%PORTDOCS%%%%DOCSDIR%%/docs/FM.announce
+%%PORTDOCS%%%%DOCSDIR%%/docs/IBMPC-charsets.announce
+%%PORTDOCS%%%%DOCSDIR%%/docs/OS-390.announce
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.TRST
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.chartrans
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.defines
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.jp
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.metrics
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.rootcerts
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.ssl
+%%PORTDOCS%%%%DOCSDIR%%/docs/README.sslcerts
+%%PORTDOCS%%%%DOCSDIR%%/docs/SOCKETSHR.announce
+%%PORTDOCS%%%%DOCSDIR%%/docs/TCPWARE.announce
+%%PORTDOCS%%%%DOCSDIR%%/docs/VMSWAIS.announce
+%%PORTDOCS%%%%DOCSDIR%%/docs/djgpp.key
+%%PORTDOCS%%%%DOCSDIR%%/docs/pdcurses.key
+%%PORTDOCS%%%%DOCSDIR%%/docs/slang.key
+%%PORTDOCS%%%%DOCSDIR%%/docs/win-386.announce
+%%PORTDOCS%%%%DOCSDIR%%/samples/blue-background.lss
+%%PORTDOCS%%%%DOCSDIR%%/samples/bright-blue.lss
+%%PORTDOCS%%%%DOCSDIR%%/samples/cernrules.txt
+%%PORTDOCS%%%%DOCSDIR%%/samples/installdirs.html
+%%PORTDOCS%%%%DOCSDIR%%/samples/jumpsUnix.html
+%%PORTDOCS%%%%DOCSDIR%%/samples/jumpsVMS.html
+%%PORTDOCS%%%%DOCSDIR%%/samples/keepviewer
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx-keymaps
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx.com
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynx.lss
+%%PORTDOCS%%%%DOCSDIR%%/samples/lynxdump
+%%PORTDOCS%%%%DOCSDIR%%/samples/mailcap
+%%PORTDOCS%%%%DOCSDIR%%/samples/mailto-form.pl
+%%PORTDOCS%%%%DOCSDIR%%/samples/mild-colors.lss
+%%PORTDOCS%%%%DOCSDIR%%/samples/mime.types
+%%PORTDOCS%%%%DOCSDIR%%/samples/oldlynx
+%%PORTDOCS%%%%DOCSDIR%%/test/ALT88592.html
+%%PORTDOCS%%%%DOCSDIR%%/test/ISO_LATIN1_test.html
+%%PORTDOCS%%%%DOCSDIR%%/test/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/test/TestComment.html
+%%PORTDOCS%%%%DOCSDIR%%/test/c1.html
+%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-1.html
+%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-2.html
+%%PORTDOCS%%%%DOCSDIR%%/test/koi8-r.html
+%%PORTDOCS%%%%DOCSDIR%%/test/quickbrown.html
+%%PORTDOCS%%%%DOCSDIR%%/test/raw8bit.html
+%%PORTDOCS%%%%DOCSDIR%%/test/sgml.html
+%%PORTDOCS%%%%DOCSDIR%%/test/spaces.html
+%%PORTDOCS%%%%DOCSDIR%%/test/special_urls.html
+%%PORTDOCS%%%%DOCSDIR%%/test/tabtest.html
+%%PORTDOCS%%%%DOCSDIR%%/test/tags.html
+%%PORTDOCS%%%%DOCSDIR%%/test/test-styles.html
+%%PORTDOCS%%%%DOCSDIR%%/test/unicode.html
+%%PORTDOCS%%%%DOCSDIR%%/test/utf-8-demo.html
+%%PORTDOCS%%share/lynx_help/COPYHEADER
+%%PORTDOCS%%share/lynx_help/COPYING
+share/lynx_help/Lynx_users_guide.html
+share/lynx_help/about_lynx.html
+share/lynx_help/keystrokes/alt_edit_help.html
+share/lynx_help/keystrokes/bashlike_edit_help.html
+share/lynx_help/keystrokes/bookmark_help.html
+share/lynx_help/keystrokes/cookie_help.html
+share/lynx_help/keystrokes/dired_help.html
+share/lynx_help/keystrokes/edit_help.html
+share/lynx_help/keystrokes/environments.html
+share/lynx_help/keystrokes/follow_help.html
+share/lynx_help/keystrokes/gopher_types_help.html
+share/lynx_help/keystrokes/history_help.html
+share/lynx_help/keystrokes/keystroke_help.html
+share/lynx_help/keystrokes/movement_help.html
+share/lynx_help/keystrokes/option_help.html
+share/lynx_help/keystrokes/other_help.html
+share/lynx_help/keystrokes/print_help.html
+share/lynx_help/keystrokes/scrolling_help.html
+share/lynx_help/keystrokes/test_display.html
+share/lynx_help/keystrokes/visited_help.html
+share/lynx_help/keystrokes/xterm_help.html
+share/lynx_help/lynx-dev.html
+share/lynx_help/lynx_help_main.html
+share/lynx_help/lynx_url_support.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/docs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/samples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/test
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/lynx_help/keystrokes
+@dirrm share/lynx_help