aboutsummaryrefslogtreecommitdiff
path: root/japanese/mime_pls
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-05-10 16:37:23 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-05-10 16:37:23 +0000
commit5e7ebdf8523b6a3d90f11ed85349ac18d934805f (patch)
tree01855db9c8c32f64458015e1144852ebc60078c1 /japanese/mime_pls
parent3298519937e291f0df6e7ab783f6895d122e7ea6 (diff)
downloadports-5e7ebdf8523b6a3d90f11ed85349ac18d934805f.tar.gz
ports-5e7ebdf8523b6a3d90f11ed85349ac18d934805f.zip
- Add staging support
- Fix few shwbangs
Notes
Notes: svn path=/head/; revision=353579
Diffstat (limited to 'japanese/mime_pls')
-rw-r--r--japanese/mime_pls/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/japanese/mime_pls/Makefile b/japanese/mime_pls/Makefile
index bfc37d944bc8..1989603b66f0 100644
--- a/japanese/mime_pls/Makefile
+++ b/japanese/mime_pls/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mime_pls
PORTVERSION= 2.02
+PORTREVISION= 1
CATEGORIES= japanese perl5 mail
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= nork
@@ -13,7 +14,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl Library for MIME encode/decode
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${BINS}
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -21,9 +23,9 @@ BINS= rmime wmime rbody wbody
LIBS= mimer.pl mimew.pl
PLIST_FILES= ${BINS:C,^,bin/,} ${LIBS:C,^,${SITE_PERL_REL}/,}
-NO_STAGE= yes
do-install:
- @${INSTALL_SCRIPT} ${BINS:C,^,${WRKSRC}/,} ${PREFIX}/bin
- @${INSTALL_DATA} ${LIBS:C,^,${WRKSRC}/,} ${SITE_PERL}
+ ${INSTALL_SCRIPT} ${BINS:C,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${SITE_PERL}
+ ${INSTALL_DATA} ${LIBS:C,^,${WRKSRC}/,} ${STAGEDIR}${SITE_PERL}
.include <bsd.port.mk>