aboutsummaryrefslogtreecommitdiff
path: root/japanese/p5-Text-Kakasi
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-10-05 11:24:29 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-10-05 11:24:29 +0000
commit0b4fc6a9d6b370d5803311aaadda907e42d0f260 (patch)
tree969913a5adafe3a5711fe9967d8083a945628f73 /japanese/p5-Text-Kakasi
parentcd0a61e05ec09a72084be1a86d8654d49e685974 (diff)
downloadports-0b4fc6a9d6b370d5803311aaadda907e42d0f260.tar.gz
ports-0b4fc6a9d6b370d5803311aaadda907e42d0f260.zip
Fix a bug where the following piece of code causes coredump:
perl -e ' use Text::Kakasi; Text::Kakasi::getopt_argv("kakasi", "-ieuc", "-Ha"); Text::Kakasi::do_kakasi("\xa1\xb3"); ' Found by: GOTO Kentaro <gotoken@notwork.org>
Notes
Notes: svn path=/head/; revision=67311
Diffstat (limited to 'japanese/p5-Text-Kakasi')
-rw-r--r--japanese/p5-Text-Kakasi/Makefile1
-rw-r--r--japanese/p5-Text-Kakasi/files/patch-Kakasi.xs11
2 files changed, 12 insertions, 0 deletions
diff --git a/japanese/p5-Text-Kakasi/Makefile b/japanese/p5-Text-Kakasi/Makefile
index 3c6baed601cf..7682d199835a 100644
--- a/japanese/p5-Text-Kakasi/Makefile
+++ b/japanese/p5-Text-Kakasi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Text-Kakasi
PORTVERSION= 1.05
+PORTREVISION= 1
CATEGORIES= japanese perl5
MASTER_SITES= http://www.daionet.gr.jp/~knok/kakasi/
diff --git a/japanese/p5-Text-Kakasi/files/patch-Kakasi.xs b/japanese/p5-Text-Kakasi/files/patch-Kakasi.xs
new file mode 100644
index 000000000000..b4299f41d93c
--- /dev/null
+++ b/japanese/p5-Text-Kakasi/files/patch-Kakasi.xs
@@ -0,0 +1,11 @@
+--- Kakasi.xs.orig Wed Apr 11 16:58:38 2001
++++ Kakasi.xs Sat Oct 5 20:20:42 2002
+@@ -110,7 +110,7 @@
+ tmp ++;
+ cur ++;
+ }
+- free(rtmp);
++ if (*rtmp) free(rtmp);
+ } while (cur < slen);
+ if (ret != NULL) {
+ RETVAL = newSVpv(ret, rcur - 1);