aboutsummaryrefslogtreecommitdiff
path: root/japanese/p5-nkf
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2006-07-03 09:10:27 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2006-07-03 09:10:27 +0000
commit00311baf6aa1fc5f600318609d2a18a7f48a0411 (patch)
treeed37ed2bfbff7b0f8f13cdc84d780aeaa1d78c87 /japanese/p5-nkf
parenta1e2391e7f049251552c75dbfc6f7f583f8c4bd6 (diff)
downloadports-00311baf6aa1fc5f600318609d2a18a7f48a0411.tar.gz
ports-00311baf6aa1fc5f600318609d2a18a7f48a0411.zip
Fix build error.
PR: ports/99737 Submitted by: Yoshisato YANAGISAWA <yanagisawa@csg.is.titech.ac.jp> Pointy hat to: myself
Notes
Notes: svn path=/head/; revision=166819
Diffstat (limited to 'japanese/p5-nkf')
-rw-r--r--japanese/p5-nkf/Makefile2
-rw-r--r--japanese/p5-nkf/files/patch-nkf.c43
2 files changed, 1 insertions, 44 deletions
diff --git a/japanese/p5-nkf/Makefile b/japanese/p5-nkf/Makefile
index 717ba3fd5ae6..309f89d395ac 100644
--- a/japanese/p5-nkf/Makefile
+++ b/japanese/p5-nkf/Makefile
@@ -14,7 +14,7 @@ DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
PERL_CONFIGURE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//:S/./-/}/NKF.mod
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:S/.//g}/NKF.mod
PATCHDIR= ${.CURDIR}/files
MAN3= NKF.3
diff --git a/japanese/p5-nkf/files/patch-nkf.c b/japanese/p5-nkf/files/patch-nkf.c
deleted file mode 100644
index fbae08d14d6b..000000000000
--- a/japanese/p5-nkf/files/patch-nkf.c
+++ /dev/null
@@ -1,43 +0,0 @@
---- ../nkf.c.orig Mon Mar 27 21:46:58 2006
-+++ ../nkf.c Sun May 7 22:37:16 2006
-@@ -3323,9 +3323,9 @@
- void (*f)PROTO((int c2,int c1));
- int c;
- {
-+ int shift = 20;
- const char *hex = "0123456789ABCDEF";
- c &= 0x00FFFFFF;
-- int shift = 20;
- while(shift >= 0){
- if(c >= 1<<shift){
- while(shift >= 0){
-@@ -3417,6 +3417,7 @@
- c = unicode_subchar;
- (*oconv)((c>>8)&0xFF, c&0xFF);
- return;
-+#if 0
- int shift = 16;
- while(shift >= 0){
- if(c >= 1<<shift){
-@@ -3429,10 +3430,13 @@
- }
- }
- return;
-+#endif
- }
- #endif
-
- #ifdef UTF8_OUTPUT_ENABLE
-+extern const unsigned short *const x0212_to_utf8_2bytes[];
-+
- int
- e2w_conv(c2, c1)
- int c2, c1;
-@@ -3449,7 +3453,6 @@
- if(ms_ucs_map_f == UCS_MAP_ASCII&& c2 == 0x8F22 && c1 == 0x43){
- return 0xA6;
- }
-- extern const unsigned short *const x0212_to_utf8_2bytes[];
- c2 = (c2&0x7f) - 0x21;
- if (0<=c2 && c2<sizeof_euc_to_utf8_2bytes)
- p = x0212_to_utf8_2bytes[c2];