aboutsummaryrefslogtreecommitdiff
path: root/japanese/plain2
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-03-01 12:19:31 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-03-01 12:19:31 +0000
commit4d7036c976ce7b87c0085d48a02aa5728b94460a (patch)
tree3b8941ec13ffda3a6cb230ed93e32b869b99cf3c /japanese/plain2
parentce62a93aedec8920229fafa5bf77b67369ee1080 (diff)
downloadports-4d7036c976ce7b87c0085d48a02aa5728b94460a.tar.gz
ports-4d7036c976ce7b87c0085d48a02aa5728b94460a.zip
- Fix build with gcc 4.x
PR: ports/131746 (part of) Submitted by: Tsurutani Naoki <turutani at scphys.kyoto-u.ac.jp>
Notes
Notes: svn path=/head/; revision=229274
Diffstat (limited to 'japanese/plain2')
-rw-r--r--japanese/plain2/Makefile6
-rw-r--r--japanese/plain2/files/patch-src__macro.h17
2 files changed, 18 insertions, 5 deletions
diff --git a/japanese/plain2/Makefile b/japanese/plain2/Makefile
index 7d393f7bc4b8..864cd878bb96 100644
--- a/japanese/plain2/Makefile
+++ b/japanese/plain2/Makefile
@@ -22,15 +22,11 @@ COMMENT= A text converter from plain to any format
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}p${PORTVERSION:E}.orig
BUILD_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}p${PORTVERSION:E}.orig/src
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DBSD -DKANJI -DPICTURE -DHTML -fwritable-strings"
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DBSD -DKANJI -DPICTURE -DHTML"
ALL_TARGET= ${PORTNAME}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/lib/plain2|${DATADIR}|g' ${BUILD_WRKSRC}/plain2.h
diff --git a/japanese/plain2/files/patch-src__macro.h b/japanese/plain2/files/patch-src__macro.h
new file mode 100644
index 000000000000..e0b960a3c406
--- /dev/null
+++ b/japanese/plain2/files/patch-src__macro.h
@@ -0,0 +1,17 @@
+--- src/macro.h.orig 2009-03-01 20:11:52.000000000 +0800
++++ src/macro.h 2009-03-01 20:12:31.000000000 +0800
+@@ -2,6 +2,7 @@
+ * Copyright (C) 1992,1993 NEC Corporation.
+ * $Id: macro.h,v 2.6 1994/04/19 10:16:49 uchida Exp $ (NEC)
+ */
++#define MAX_MACRO_LEN 320
+ #define MACRO_MAXARG 10
+
+ #define M_DOC_BEGIN 0
+@@ -74,5 +75,5 @@
+
+ struct macDefs {
+ int mdef_number;
+- char *mdef_def;
++ char mdef_def[MAX_MACRO_LEN];
+ };