aboutsummaryrefslogtreecommitdiff
path: root/japanese/prn
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-06-23 14:31:12 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-06-23 14:31:12 +0000
commit0f8b5a6653b457d3cef497b751e5bb62e379e638 (patch)
tree413f150c9d10ca031517119450d768a604023ce2 /japanese/prn
parentf41102fc333b8925217c2f60e5113911ea9062c8 (diff)
downloadports-0f8b5a6653b457d3cef497b751e5bb62e379e638.tar.gz
ports-0f8b5a6653b457d3cef497b751e5bb62e379e638.zip
New port, prn:
Yet another text to ps filter with Japanese support. PR: 3934 Submitted by: Satoshi Taoka <taoka@infonets.hiroshima-u.ac.jp>
Notes
Notes: svn path=/head/; revision=7050
Diffstat (limited to 'japanese/prn')
-rw-r--r--japanese/prn/Makefile23
-rw-r--r--japanese/prn/distinfo1
-rw-r--r--japanese/prn/files/patch-aa62
-rw-r--r--japanese/prn/files/patch-ab41
-rw-r--r--japanese/prn/files/patch-ac19
-rw-r--r--japanese/prn/files/patch-ad53
-rw-r--r--japanese/prn/files/patch-ae53
-rw-r--r--japanese/prn/pkg-comment1
-rw-r--r--japanese/prn/pkg-descr6
-rw-r--r--japanese/prn/pkg-plist11
10 files changed, 270 insertions, 0 deletions
diff --git a/japanese/prn/Makefile b/japanese/prn/Makefile
new file mode 100644
index 000000000000..e3e443ccd8b1
--- /dev/null
+++ b/japanese/prn/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: prn
+# Version required: 2.0
+# Date created: 19 Jun 1997
+# Whom: Satoshi TAOKA <taoka@infonets.hiroshima-u.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= prn
+PKGNAME= jp-prn-1.0
+CATEGORIES= japanese print
+MASTER_SITES= ftp://ftp.eos.hokudai.ac.jp/pub/tools/
+
+MAINTAINER= taoka@infonets.hiroshima-u.ac.jp
+
+RUN_DEPENDS= kcc:${PORTSDIR}/japanese/kcc
+
+INSTALL_TARGET= install install.man
+MANLANG= ja_JP.EUC
+MAN1= prn.1 cprn.1 cmt.1 psconv.1
+MAN5= cmtdefs.5
+
+.include <bsd.port.mk>
diff --git a/japanese/prn/distinfo b/japanese/prn/distinfo
new file mode 100644
index 000000000000..696496348207
--- /dev/null
+++ b/japanese/prn/distinfo
@@ -0,0 +1 @@
+MD5 (prn.tar.gz) = a2d483356af2778e3aba2cd897ea6eb9
diff --git a/japanese/prn/files/patch-aa b/japanese/prn/files/patch-aa
new file mode 100644
index 000000000000..74bfe9a00199
--- /dev/null
+++ b/japanese/prn/files/patch-aa
@@ -0,0 +1,62 @@
+*** Makefile.orig Wed May 11 17:00:58 1994
+--- Makefile Mon Jun 23 23:15:39 1997
+***************
+*** 25,35 ****
+ # @(#)Makefile 2.3 (Y.Tonooka) 5/11/94
+ #-
+
+! BINPATH = /usr/local/bin
+! LIBPATH = /usr/local/lib
+! MANPATH = /usr/local/man
+! JMANDIR = japanese
+! CFLAGS = -O
+ # CFLAGS = -g -DDEBUG
+ ARFLAGS = rcv
+
+--- 25,39 ----
+ # @(#)Makefile 2.3 (Y.Tonooka) 5/11/94
+ #-
+
+! PREFIX?=/usr/local
+! BINPATH = ${PREFIX}/bin
+! LIBPATH = ${PREFIX}/lib/prn
+! MANPATH = ${PREFIX}/man
+! JMANDIR = ja_JP.EUC
+! CFLAGS = -O \
+! -DKCCPATH=\"${PREFIX}/bin/kcc\" \
+! -DCMTPATH=\"${PREFIX}/bin/cmt\" \
+! -DPSPATH=\"${PREFIX}/bin/psconv\"
+ # CFLAGS = -g -DDEBUG
+ ARFLAGS = rcv
+
+***************
+*** 39,47 ****
+ AR = ar
+ RANLIB = ranlib
+ LINT = lint
+! INSTALL = install
+ CP = cp
+! LN = ln
+ RM = rm -f
+ TAGS = ctags
+ ETAGS = etags
+--- 43,51 ----
+ AR = ar
+ RANLIB = ranlib
+ LINT = lint
+! INSTALL = install -c
+ CP = cp
+! LN = ln -fs
+ RM = rm -f
+ TAGS = ctags
+ ETAGS = etags
+***************
+*** 98,103 ****
+--- 102,108 ----
+ $(INSTALL) -s cmt $(BINPATH)
+
+ $(LIBPATH)/cmtdefs: cmtdefs
++ mkdir -p $(LIBPATH)
+ $(CP) cmtdefs $@; chmod 644 $@
+
+ $(BINPATH)/psconv: psconv.c
diff --git a/japanese/prn/files/patch-ab b/japanese/prn/files/patch-ab
new file mode 100644
index 000000000000..209fd9298afb
--- /dev/null
+++ b/japanese/prn/files/patch-ab
@@ -0,0 +1,41 @@
+*** prn.c.orig Thu May 26 11:37:45 1994
+--- prn.c Mon Jun 9 12:29:28 1997
+***************
+*** 34,41 ****
+ #include <sys/stat.h>
+ #include "euc.h"
+
+ #define KCCPATH "/usr/local/bin/kcc"
+! #if defined (__bsdi__)
+ #define LPRPATH "/usr/bin/lpr"
+ #else
+ #define LPRPATH "/usr/ucb/lpr"
+--- 34,46 ----
+ #include <sys/stat.h>
+ #include "euc.h"
+
++ #if !defined KCCPATH
+ #define KCCPATH "/usr/local/bin/kcc"
+! #endif
+! #if (defined(__unix__) || defined(unix)) && !defined(USG)
+! #include <sys/param.h>
+! #endif
+! #if defined (__bsdi__) || (defined(BSD) && (BSD >= 199103))
+ #define LPRPATH "/usr/bin/lpr"
+ #else
+ #define LPRPATH "/usr/ucb/lpr"
+***************
+*** 48,55 ****
+--- 53,64 ----
+
+ #else
+
++ #if !defined CMTPATH
+ #define CMTPATH "/usr/local/bin/cmt"
++ #endif
++ #if !defined PSPATH
+ #define PSPATH "/usr/local/bin/psconv"
++ #endif
+
+ #endif
+
diff --git a/japanese/prn/files/patch-ac b/japanese/prn/files/patch-ac
new file mode 100644
index 000000000000..5b5ed58a5585
--- /dev/null
+++ b/japanese/prn/files/patch-ac
@@ -0,0 +1,19 @@
+*** cmt.jman.orig Mon Jun 9 14:19:17 1997
+--- cmt.jman Mon Jun 9 14:19:40 1997
+***************
+*** 91,97 ****
+ るときの名称を示します。
+ .LP
+ .RS
+! .ta +19n; +12n; +20n;
+ ファイル名 言語 指定名称
+ .ie n .br
+ .el .sp .4
+--- 91,97 ----
+ るときの名称を示します。
+ .LP
+ .RS
+! .ta +19n +12n +20n
+ ファイル名 言語 指定名称
+ .ie n .br
+ .el .sp .4
diff --git a/japanese/prn/files/patch-ad b/japanese/prn/files/patch-ad
new file mode 100644
index 000000000000..31ed0e642e6b
--- /dev/null
+++ b/japanese/prn/files/patch-ad
@@ -0,0 +1,53 @@
+*** prn.jman.orig Mon Mar 28 20:06:40 1994
+--- prn.jman Mon Jun 9 14:49:03 1997
+***************
+*** 129,135 ****
+ とにファイル名によって区別します。その規則は以下の表に示すとおりです。
+ .LP
+ .RS
+! .ta +19n; +12n; +20n;
+ ファイル名 言語 \fB\-l\fR オプションでの名称
+ .ie n .br
+ .el .sp .4
+--- 129,135 ----
+ とにファイル名によって区別します。その規則は以下の表に示すとおりです。
+ .LP
+ .RS
+! .ta +18n +11n +20n
+ ファイル名 言語 \fB\-l\fR オプションでの名称
+ .ie n .br
+ .el .sp .4
+***************
+*** 210,216 ****
+ です。
+ .PD
+ .RS
+! .ta +16;
+ .ie n .TP 15
+ .el .TP 10
+ .B \-V
+--- 210,216 ----
+ です。
+ .PD
+ .RS
+! .ta +16
+ .ie n .TP 15
+ .el .TP 10
+ .B \-V
+***************
+*** 242,248 ****
+ .IP
+ 書式は任意に指定することもできます。
+ .RS
+! .ta +16;
+ .ie n .TP 15
+ .el .TP 10
+ .B \-V\fIwid\fB\-\fIlen
+--- 242,248 ----
+ .IP
+ 書式は任意に指定することもできます。
+ .RS
+! .ta +16
+ .ie n .TP 15
+ .el .TP 10
+ .B \-V\fIwid\fB\-\fIlen
diff --git a/japanese/prn/files/patch-ae b/japanese/prn/files/patch-ae
new file mode 100644
index 000000000000..4fcc55904f5a
--- /dev/null
+++ b/japanese/prn/files/patch-ae
@@ -0,0 +1,53 @@
+*** psconv.jman.orig Mon Jun 9 14:16:33 1997
+--- psconv.jman Mon Jun 9 14:18:21 1997
+***************
+*** 104,110 ****
+ です。
+ .PD
+ .RS
+! .ta +16;
+ .ie n .TP 15
+ .el .TP 10
+ .B \-V
+--- 104,110 ----
+ です。
+ .PD
+ .RS
+! .ta +16
+ .ie n .TP 15
+ .el .TP 10
+ .B \-V
+***************
+*** 136,142 ****
+ .IP
+ 書式は任意に指定することもできます。
+ .RS
+! .ta +16;
+ .ie n .TP 15
+ .el .TP 10
+ .B \-V\fIwid\fB\-\fIlen
+--- 136,142 ----
+ .IP
+ 書式は任意に指定することもできます。
+ .RS
+! .ta +16
+ .ie n .TP 15
+ .el .TP 10
+ .B \-V\fIwid\fB\-\fIlen
+***************
+*** 181,187 ****
+ 指示できる要素には以下の 4 種類があります。
+ .LP
+ .RS 10
+! .ta +5n;
+ \fBR\fR 標準
+ .br
+ \fBB\fR 太字(bold)
+--- 181,187 ----
+ 指示できる要素には以下の 4 種類があります。
+ .LP
+ .RS 10
+! .ta +5n
+ \fBR\fR 標準
+ .br
+ \fBB\fR 太字(bold)
diff --git a/japanese/prn/pkg-comment b/japanese/prn/pkg-comment
new file mode 100644
index 000000000000..b19156629490
--- /dev/null
+++ b/japanese/prn/pkg-comment
@@ -0,0 +1 @@
+A yet another converter from text file to postscript (with Japanese support)
diff --git a/japanese/prn/pkg-descr b/japanese/prn/pkg-descr
new file mode 100644
index 000000000000..e2f1f05c9ec2
--- /dev/null
+++ b/japanese/prn/pkg-descr
@@ -0,0 +1,6 @@
+Prn prints out a text file to a postscript printer by converting to
+postscript. If the file has kanji code such as 7-bit JIS, MS-kanji
+(shifted-JIS) or EUC, it can print out by using a kanji code converter
+whose name is kcc. If the file is code of C, C++, FORTRAN, pascal,
+... , printing out by prn with a option '-c' can emphasize keywords
+and comments.
diff --git a/japanese/prn/pkg-plist b/japanese/prn/pkg-plist
new file mode 100644
index 000000000000..6b2292038760
--- /dev/null
+++ b/japanese/prn/pkg-plist
@@ -0,0 +1,11 @@
+bin/prn
+bin/cprn
+bin/cmt
+bin/psconv
+lib/prn/cmtdefs
+man/ja_JP.EUC/man1/prn.1.gz
+man/ja_JP.EUC/man1/cprn.1.gz
+man/ja_JP.EUC/man1/cmt.1.gz
+man/ja_JP.EUC/man1/psconv.1.gz
+man/ja_JP.EUC/man5/cmtdefs.5.gz
+@dirrm lib/prn