aboutsummaryrefslogtreecommitdiff
path: root/japanese/prn
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-24 13:54:11 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-24 13:54:11 +0000
commit2750942f18c7c9b42a36b950d2121dfe778bd934 (patch)
tree9e7e43ef6f11cf6f99de302d92eff10418f9a8cc /japanese/prn
parentbcfc2e3ebf9b58458114c02019ce6604855a964c (diff)
downloadports-2750942f18c7c9b42a36b950d2121dfe778bd934.tar.gz
ports-2750942f18c7c9b42a36b950d2121dfe778bd934.zip
- Fix build with clang
- Remove leading article from COMMENT - Support staging PR: ports/184900 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=337355
Diffstat (limited to 'japanese/prn')
-rw-r--r--japanese/prn/Makefile21
-rw-r--r--japanese/prn/files/patch-aa4
-rw-r--r--japanese/prn/files/patch-cmt.c12
-rw-r--r--japanese/prn/files/patch-defs.c10
-rw-r--r--japanese/prn/files/patch-euc.c12
-rw-r--r--japanese/prn/files/patch-prn.c19
-rw-r--r--japanese/prn/files/patch-psconv.c14
-rw-r--r--japanese/prn/files/patch-reg.y11
-rw-r--r--japanese/prn/pkg-plist13
9 files changed, 97 insertions, 19 deletions
diff --git a/japanese/prn/Makefile b/japanese/prn/Makefile
index 626512b78286..23051206caf7 100644
--- a/japanese/prn/Makefile
+++ b/japanese/prn/Makefile
@@ -3,19 +3,28 @@
PORTNAME= prn
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= japanese print
MASTER_SITES= ${MASTER_SITE_PORTS_JP}
DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A yet another converter from text file to postscript (with Japanese support)
+COMMENT= Yet another converter from text file to postscript (with Japanese support)
RUN_DEPENDS= kcc:${PORTSDIR}/japanese/kcc
-INSTALL_TARGET= install install.man
-MANLANG= ja
-MAN1= prn.1 cprn.1 cmt.1 psconv.1
-MAN5= cmtdefs.5
+do-install:
+.for i in cmt prn psconv
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${i} ${STAGEDIR}${PREFIX}/bin)
+.endfor
+ ${LN} -sf prn ${STAGEDIR}${PREFIX}/bin/cprn
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} cmtdefs ${STAGEDIR}${DATADIR})
+.for i in cmt cprn prn psconv
+ (cd ${WRKSRC} && ${INSTALL_MAN} ${i}.jman \
+ ${STAGEDIR}${MANPREFIX}/man/man1/${i}.1)
+.endfor
+ (cd ${WRKSRC} && ${INSTALL_MAN} cmtdefs.jman \
+ ${STAGEDIR}${MAN5PREFIX}/man/man5/cmtdefs.5)
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/japanese/prn/files/patch-aa b/japanese/prn/files/patch-aa
index d8e9d20eca2e..4dc57104dfba 100644
--- a/japanese/prn/files/patch-aa
+++ b/japanese/prn/files/patch-aa
@@ -19,10 +19,10 @@
! PREFIX?=/usr/local
! BINPATH = ${PREFIX}/bin
-! LIBPATH = ${PREFIX}/lib/prn
+! LIBPATH = ${PREFIX}/share/prn
! MANPATH = ${PREFIX}/man
! JMANDIR = ja
-! CFLAGS = -O \
+! CFLAGS += \
! -DKCCPATH=\"${PREFIX}/bin/kcc\" \
! -DCMTPATH=\"${PREFIX}/bin/cmt\" \
! -DPSPATH=\"${PREFIX}/bin/psconv\"
diff --git a/japanese/prn/files/patch-cmt.c b/japanese/prn/files/patch-cmt.c
index 485ef37112c7..a7da150079d6 100644
--- a/japanese/prn/files/patch-cmt.c
+++ b/japanese/prn/files/patch-cmt.c
@@ -1,6 +1,16 @@
--- cmt.c.orig Mon Apr 25 16:26:57 1994
+++ cmt.c Fri Feb 6 00:18:46 2004
-@@ -352,16 +352,15 @@
+@@ -27,7 +27,9 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <ctype.h>
++#include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include "cmt.h"
+@@ -352,16 +354,15 @@
error(format, arg1, arg2, ...)
char *format;
---------------------------------------------------------------------*/
diff --git a/japanese/prn/files/patch-defs.c b/japanese/prn/files/patch-defs.c
new file mode 100644
index 000000000000..00de93e60f5c
--- /dev/null
+++ b/japanese/prn/files/patch-defs.c
@@ -0,0 +1,10 @@
+--- defs.c.orig
++++ defs.c
+@@ -26,6 +26,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <ctype.h>
+ #include "euc.h"
+ #include "cmt.h"
diff --git a/japanese/prn/files/patch-euc.c b/japanese/prn/files/patch-euc.c
new file mode 100644
index 000000000000..480383cac7fe
--- /dev/null
+++ b/japanese/prn/files/patch-euc.c
@@ -0,0 +1,12 @@
+--- euc.c.orig
++++ euc.c
+@@ -26,6 +26,9 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++#include <ctype.h>
+ #include "euc.h"
+
+ #if defined EUC
diff --git a/japanese/prn/files/patch-prn.c b/japanese/prn/files/patch-prn.c
index b1aac4b50ff9..e34a08d26d69 100644
--- a/japanese/prn/files/patch-prn.c
+++ b/japanese/prn/files/patch-prn.c
@@ -1,7 +1,18 @@
--- prn.c.orig Thu May 26 11:37:45 1994
+++ prn.c Fri Feb 6 00:18:11 2004
-@@ -34,8 +34,13 @@
+@@ -26,16 +26,24 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <ctype.h>
+ #include <fcntl.h>
+ #include <time.h>
++#include <unistd.h>
+ #include <sys/types.h>
#include <sys/stat.h>
++#include <sys/wait.h>
#include "euc.h"
+#if !defined KCCPATH
@@ -15,7 +26,7 @@
#define LPRPATH "/usr/bin/lpr"
#else
#define LPRPATH "/usr/ucb/lpr"
-@@ -48,8 +53,12 @@
+@@ -48,8 +56,12 @@
#else
@@ -28,7 +39,7 @@
#endif
-@@ -96,7 +105,7 @@
+@@ -96,7 +108,7 @@
static char *filename; /* name of the file being processed */
static char *modtime; /* the last modification time */
@@ -37,7 +48,7 @@
static char *basename();
static bool formatopt();
static bool rangeopt();
-@@ -498,16 +507,15 @@
+@@ -498,16 +510,15 @@
error(format, arg1, arg2, ...)
char *format;
---------------------------------------------------------------------*/
diff --git a/japanese/prn/files/patch-psconv.c b/japanese/prn/files/patch-psconv.c
new file mode 100644
index 000000000000..53db07cababb
--- /dev/null
+++ b/japanese/prn/files/patch-psconv.c
@@ -0,0 +1,14 @@
+--- psconv.c.orig
++++ psconv.c
+@@ -64,9 +64,11 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <ctype.h>
+ #include <signal.h>
++#include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
diff --git a/japanese/prn/files/patch-reg.y b/japanese/prn/files/patch-reg.y
index 0fc5d19866b5..5a0017ffdb15 100644
--- a/japanese/prn/files/patch-reg.y
+++ b/japanese/prn/files/patch-reg.y
@@ -1,12 +1,19 @@
--- reg.y.org Mon Nov 29 18:43:56 1993
+++ reg.y Thu Jan 20 12:29:44 2005
-@@ -286,7 +286,7 @@
+@@ -20,6 +20,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <ctype.h>
+ #include "cmt.h"
+ #include "euc.h"
+@@ -286,7 +287,7 @@
* Node Creation Functions *
* *
**********************************************************************/
-extern void error();
+extern void error(char *, ...);
-
/*---------------------------------------------------------------------
NAME
diff --git a/japanese/prn/pkg-plist b/japanese/prn/pkg-plist
index 9106fcb0f87a..1c963e54a0b7 100644
--- a/japanese/prn/pkg-plist
+++ b/japanese/prn/pkg-plist
@@ -1,6 +1,11 @@
-bin/prn
-bin/cprn
bin/cmt
+bin/cprn
+bin/prn
bin/psconv
-lib/prn/cmtdefs
-@dirrm lib/prn
+man/man1/cmt.1.gz
+man/man1/cprn.1.gz
+man/man1/prn.1.gz
+man/man1/psconv.1.gz
+man/man5/cmtdefs.5.gz
+%%DATADIR%%/cmtdefs
+@dirrm %%DATADIR%%