aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk11
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2021-10-15 18:18:36 +0000
committerDimitry Andric <dim@FreeBSD.org>2021-10-16 12:22:03 +0000
commit3822416493cfbbed8fe7a487391b40bec956d671 (patch)
tree928b05b398cb23d296856beeb9c9f16bc1696434 /java/openjdk11
parent86b2f72cb04b41ce5099a7c742b20a56cb30f717 (diff)
downloadports-3822416493cfbbed8fe7a487391b40bec956d671.tar.gz
ports-3822416493cfbbed8fe7a487391b40bec956d671.zip
java/openjdk*: work around UB in markOopDesc, fix builds with clang 13
During an exp-run for llvm 13 (see bug 258209), it turned out that java/openjdk11 through openjdk13 fail to build with clang 13: === Output from failing command(s) repeated here === * For target jdk__packages_attribute.done: These crashes are all caused by the markOop/markOopDesc classes, which are used to keep track of objects, and which are 'marked' using the low few bits. (See https://github.com/openjdk/jdk13u/blob/master/src/hotspot/share/oops/markOop.hpp ). After some laborious bisecting, I found out that these crashes start occuring after the upstream commit https://github.com /llvm/llvm-project/commit/16d03818412 (Return "[CGCall] Annotate this argument with alignment"). What happens afterwards, is that clang considers the "this" pointer to always be aligned to the alignment of the actual object, and then masking or adding a few low bits is not working as expected. The reason openjdk14 and higher work fine with clang 13, and don't crash similarly, is that the OpenJDK people completely redid the markOop/markOopDesc classes in https://github.com/openjdk/jdk/commit/ae5615c6142a4dc0d9033462f4880d7b3c127e26 ("8229258: Rework markOop and markOopDesc into a simpler mark word value carrier"). E.g, the markOopDesc class was renamed to markWord, and *stores* a pointer-like value instead of *being* a pointer-like value. This is a much safer way of handling things. However, this upstream commit is *very* large, as are a few of its follow-ups, which is probably the reason why it has not been backported to JDKs <= 13. I tried manually backporting it, but got lost in many nasty patch conflicts and problems. As a workaround, build openjdk8 through 13 with clang12 from the devel/llvm12 port, for the time being. In addition, allow openjdk14 through 17 to be built with clang 13, by adding -Wno-unused-but-set-parameter to the compilation flags. PR: 258954 Approved by: maintainer timeout (2 weeks) MFH: 2021Q4
Diffstat (limited to 'java/openjdk11')
-rw-r--r--java/openjdk11/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index a6f9fe592ded..68fae74c20b0 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -1,6 +1,7 @@
PORTNAME= openjdk
DISTVERSIONPREFIX= jdk-
DISTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_PATCH_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION}
+PORTREVISION= 1
CATEGORIES= java devel
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
@@ -142,6 +143,14 @@ CONFIGURE_ARGS+= --with-extra-ldflags="-Wl,-rpath=${LOCALBASE}/lib/gcc${GCC_DEFA
--with-extra-cxxflags="-Wl,-rpath=${LOCALBASE}/lib/gcc${GCC_DEFAULT}"
.else
MAKE_ENV+= USE_CLANG=true
+.if ${COMPILER_VERSION} >= 130
+# PR258954: OpenJDK <= 13 crash due to undefined behavior with clang >= 13
+# See also https://bugs.openjdk.java.net/browse/JDK-8229258
+LLVM_VER= 12
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CC= ${LOCALBASE}/bin/clang${LLVM_VER}
+CXX= ${LOCALBASE}/bin/clang++${LLVM_VER}
+.endif
.endif
.if ${ARCH} == aarch64 || ${ARCH:Marmv*} || ${ARCH:Mpowerpc64*}