aboutsummaryrefslogtreecommitdiff
path: root/lang/opencoarrays
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-07-03 23:22:22 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-07-04 00:00:32 +0000
commit11c5cac3277943d881d076cb4d0c45e844f861e9 (patch)
tree02c368b387266a67cdf87851f648237c9c2d7fa3 /lang/opencoarrays
parentd4f11729f5bb5a18c7284bae2eed0ddfcad76861 (diff)
downloadports-11c5cac3277943d881d076cb4d0c45e844f861e9.tar.gz
ports-11c5cac3277943d881d076cb4d0c45e844f861e9.zip
lang/opencoarrays: unbreak on powerpc* / main
Port now builds fine on current. Additionally, since slurm-wlm (a dependency of mpich) doesn't work on 32-bits, make 32-bit architectures use OpenMPI.
Diffstat (limited to 'lang/opencoarrays')
-rw-r--r--lang/opencoarrays/Makefile21
1 files changed, 18 insertions, 3 deletions
diff --git a/lang/opencoarrays/Makefile b/lang/opencoarrays/Makefile
index 4a2d2e74e63b..f67891798037 100644
--- a/lang/opencoarrays/Makefile
+++ b/lang/opencoarrays/Makefile
@@ -10,9 +10,12 @@ COMMENT= Transport layer for coarray Fortran compilers
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-.for arch in aarch64 powerpc powerpc64 powerpc64le
-BROKEN_${arch}= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
-.endfor
+BROKEN_aarch64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
+BROKEN_FreeBSD_12_powerpc= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
+BROKEN_FreeBSD_12_powerpc64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
+BROKEN_FreeBSD_13_powerpc= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
+BROKEN_FreeBSD_13_powerpc64= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
+BROKEN_FreeBSD_13_powerpc64le= Lack of IEEE754 support in gcc causes "Cannot find an intrinsic module named 'ieee_arithmetic'", see bug#255890
BUILD_DEPENDS= bash:shells/bash
RUN_DEPENDS= bash:shells/bash
@@ -29,6 +32,18 @@ PLIST_SUB= GCC_VER=${_GCC_VER} PORTVERSION=${PORTVERSION} SOVERSION=3
OPTIONS_SINGLE= MPI
OPTIONS_SINGLE_MPI= MPICH OPENMPI
OPTIONS_DEFAULT= MPICH
+OPTIONS_EXCLUDE_armv6= MPICH
+OPTIONS_EXCLUDE_armv7= MPICH
+OPTIONS_EXCLUDE_i386= MPICH
+OPTIONS_EXCLUDE_mips= MPICH
+OPTIONS_EXCLUDE_powerpc= MPICH
+OPTIONS_EXCLUDE_powerpcspe= MPICH
+OPTIONS_DEFAULT_armv6= OPENMPI
+OPTIONS_DEFAULT_armv7= OPENMPI
+OPTIONS_DEFAULT_i386= OPENMPI
+OPTIONS_DEFAULT_mips= OPENMPI
+OPTIONS_DEFAULT_powerpc= OPENMPI
+OPTIONS_DEFAULT_powerpcspe= OPENMPI
MPICH_BUILD_DEPENDS= mpif90:net/mpich
MPICH_RUN_DEPENDS= mpif90:net/mpich