aboutsummaryrefslogtreecommitdiff
path: root/lang/tcl9/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2024-04-05 12:23:29 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2024-04-05 12:26:51 +0000
commitc562c2e908700878ad60414f307611721d7c80bd (patch)
tree0f036e9ce09dfc6efba940b907718e2a19f1983e /lang/tcl9/Makefile
parent2067ff3c2fbc1493181c0be0aee3609b7b23031a (diff)
downloadports-c562c2e908700878ad60414f307611721d7c80bd.tar.gz
ports-c562c2e908700878ad60414f307611721d7c80bd.zip
lang/tcl9: fix linking with LLVM binutils
PR: 278173 Reported by: emaste
Diffstat (limited to 'lang/tcl9/Makefile')
-rw-r--r--lang/tcl9/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/tcl9/Makefile b/lang/tcl9/Makefile
index 36a9d3bd16e4..3029da451876 100644
--- a/lang/tcl9/Makefile
+++ b/lang/tcl9/Makefile
@@ -1,6 +1,6 @@
PORTNAME= tcl
DISTVERSION= ${TCL_VERSION}${TCL_RC}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= SF/tcl/Tcl/${TCL_VERSION} \
TCLTK/tcl8_7
@@ -94,8 +94,9 @@ post-patch:
${REINPLACE_CMD} \
-e '/^INSTALL_PACKAGE_TARGETS/d' \
-e '/^CONFIG_INSTALL_DIR/s|= .*$$|= $${SCRIPT_INSTALL_DIR}|' \
- -e 's|$$(LIB_INSTALL_DIR)/pkgconfig|${STAGEDIR}$(PREFIX)/libdata/pkgconfig|g' \
+ -e 's|$$(LIB_INSTALL_DIR)/pkgconfig|${STAGEDIR}${PREFIX}/libdata/pkgconfig|g' \
-e 's|pkgconfig/tcl.pc|pkgconfig/tcl${SHORT_TCL_VER}.pc|' \
+ -e 's|strip -x|strip --strip-unneeded|' \
${WRKSRC}/Makefile.in
${REINPLACE_CMD} \
-e '/Target=/s|.$$Section$$Suffix|$$Suffix.$$Section|' \