aboutsummaryrefslogtreecommitdiff
path: root/mail/bincimap
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-17 17:28:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2016-01-17 17:28:08 +0000
commit8b28f3f3ebe53d1e7705172ffc1d12954f97ce9e (patch)
tree482ff1425eee8004e49620870c8753a8a0f3a11b /mail/bincimap
parentce4b7baddc7492daf2badbce92e1c17be2f22650 (diff)
downloadports-8b28f3f3ebe53d1e7705172ffc1d12954f97ce9e.tar.gz
ports-8b28f3f3ebe53d1e7705172ffc1d12954f97ce9e.zip
- Resurrect `mail/bincimap' port (project was moved to SF.net from the
abandoned http://www.bincimap.org/ website) - Distfile is .tar.gz now instead of original .tar.bz2, but the contents is identical (no changes whatsoever) - Clean up and modernize the port: convert to OPTIONS, define LICENSE, get rid of CONFDIR in favor of ETCDIR, allow to build with GCC 4.7+, use @sample in pkg-plist, kill bogus EOL whitespace in pkg-descr, etc.
Notes
Notes: svn path=/head/; revision=406519
Diffstat (limited to 'mail/bincimap')
-rw-r--r--mail/bincimap/Makefile55
-rw-r--r--mail/bincimap/distinfo2
-rw-r--r--mail/bincimap/files/bincimapd.in45
-rw-r--r--mail/bincimap/files/patch-Makefile.in11
-rw-r--r--mail/bincimap/files/patch-src_convert.h11
-rw-r--r--mail/bincimap/files/patch-src_tools.cc11
-rw-r--r--mail/bincimap/pkg-descr7
-rw-r--r--mail/bincimap/pkg-plist23
8 files changed, 165 insertions, 0 deletions
diff --git a/mail/bincimap/Makefile b/mail/bincimap/Makefile
new file mode 100644
index 000000000000..0326fb1dff11
--- /dev/null
+++ b/mail/bincimap/Makefile
@@ -0,0 +1,55 @@
+# Created by: Sergei Kolobov <sergei@kolobov.com>
+# $FreeBSD$
+
+PORTNAME= bincimap
+PORTVERSION= 1.2.13
+PORTREVISION= 2
+CATEGORIES= mail
+MASTER_SITES= SF/${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}final
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Light-weight IMAP server for Maildir
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= checkpassword-pam:${PORTSDIR}/security/checkpassword-pam \
+ tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
+
+USE_RC_SUBR= bincimapd
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --sysconfdir=${ETCDIR}
+
+DOCS= AUTHORS ChangeLog README doc/bincimap* \
+ doc/manual/bincimap-manual.ps
+EXAMPLES= conf/bincimap.conf conf/checkpassword.pl conf/toimapdir \
+ conf/tomaildir++ conf/xinetd-bincimap conf/xinetd-bincimaps
+CONTRIB= contrib/README contrib/authenticators/bincimap-auth-teapop.sh
+
+OPTIONS_DEFINE= DOCS EXAMPLES OPENSSL
+OPTIONS_DEFAULT= OPENSSL
+
+OPENSSL_USE= OPENSSL=yes
+OPENSSL_CONFIGURE_OFF= --without-ssl
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/conf/bincimap.conf \
+ ${STAGEDIR}${ETCDIR}/bincimap.conf.sample
+ cd ${WRKSRC}/man && ${INSTALL_MAN} bincimap-up.1 bincimapd.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/bincimap.conf.5 \
+ ${STAGEDIR}${MANPREFIX}/man/man5
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/contrib
+ cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${CONTRIB} \
+ ${STAGEDIR}${EXAMPLESDIR}/contrib
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/mail/bincimap/distinfo b/mail/bincimap/distinfo
new file mode 100644
index 000000000000..cfa30b2db99f
--- /dev/null
+++ b/mail/bincimap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bincimap-1.2.13final.tar.gz) = 5ad2cc45da86e1e32f230f10e733a045f51197fdb54043df7c3a385caf2fc6f5
+SIZE (bincimap-1.2.13final.tar.gz) = 511059
diff --git a/mail/bincimap/files/bincimapd.in b/mail/bincimap/files/bincimapd.in
new file mode 100644
index 000000000000..083c13eeab3a
--- /dev/null
+++ b/mail/bincimap/files/bincimapd.in
@@ -0,0 +1,45 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Copyright 2007, AnyWi Technologies
+#
+# PROVIDE: bincimapd
+# REQUIRE: LOGIN cleanvar
+# KEYWORD: shutdown
+#
+# Note: tcpserver can be found in the sysutils/ucspi-tcp package.
+. /etc/rc.subr
+name="bincimapd"
+rcvar=`set_rcvar`
+load_rc_config $name
+: ${bincimapd_enable="NO"}
+: ${bincimapd_tcpserver="%%PREFIX%%/bin/tcpserver"}
+: ${bincimapd_tcpserver_flags="-R -H"}
+: ${bincimapd_host="0"}
+: ${bincimapd_port="imap"}
+: ${bincimapd_conf="%%PREFIX%%/etc/bincimap/bincimap.conf"}
+: ${bincimapd_pidfile="/var/run/bincimapd.pid"}
+: ${bincimapd_checkpassword="%%PREFIX%%/bin/checkpassword-pam"} # e.g. /usr/local/bin/checkpassword-pam
+: ${bincimapd_checksubprogram="/usr/bin/true"}
+
+bincimapd_start()
+{
+ rc_pid=$(check_pidfile ${pidfile} ${bincimapd_tcpserver})
+ if [ -z "$rc_pid" ]; then
+ echo -n "Starting bincimapd: "
+ $bincimapd_tcpserver $bincimapd_tcpserver_flags $bincimapd_host $bincimapd_port \
+ %%PREFIX%%/bin/bincimap-up --conf=$bincimapd_conf -- \
+ %%PREFIX%%/bin/checkpassword-pam -s imap -- %%PREFIX%%/bin/bincimapd &
+ echo $! > $bincimapd_pidfile
+ echo "."
+ else
+ echo "${name} already running? (check ${pidfile}"
+ return 1
+ fi
+}
+
+start_cmd="bincimapd_start"
+command=${bincimapd_tcpserver}
+pidfile=${bincimapd_pidfile}
+run_rc_command "$1"
diff --git a/mail/bincimap/files/patch-Makefile.in b/mail/bincimap/files/patch-Makefile.in
new file mode 100644
index 000000000000..572d7181d04a
--- /dev/null
+++ b/mail/bincimap/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Aug 26 19:12:42 2004
++++ Makefile.in Thu Aug 26 19:17:29 2004
+@@ -87,7 +87,7 @@
+ prefix = @prefix@
+ sysconfdir = @sysconfdir@
+
+-SUBDIRS = conf contrib doc man service src
++SUBDIRS = contrib man src
+
+ #--------------------------------------------------------------------------
+ EXTRA_DIST = bincimap.spec config.h COPYING.OpenSSL config.h.in README.SSL
diff --git a/mail/bincimap/files/patch-src_convert.h b/mail/bincimap/files/patch-src_convert.h
new file mode 100644
index 000000000000..75f0a9dc998c
--- /dev/null
+++ b/mail/bincimap/files/patch-src_convert.h
@@ -0,0 +1,11 @@
+--- src/convert.h.orig 2005-02-08 20:30:22 UTC
++++ src/convert.h
+@@ -43,6 +43,8 @@
+ #include <iostream>
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
+ #include <sys/stat.h>
+
+ #include "address.h"
diff --git a/mail/bincimap/files/patch-src_tools.cc b/mail/bincimap/files/patch-src_tools.cc
new file mode 100644
index 000000000000..9a7e5c874f04
--- /dev/null
+++ b/mail/bincimap/files/patch-src_tools.cc
@@ -0,0 +1,11 @@
+--- src/tools.cc.orig 2005-01-08 10:20:48 UTC
++++ src/tools.cc
+@@ -35,6 +35,8 @@
+ #include <config.h>
+ #endif
+ #include <errno.h>
++#include <stdlib.h>
++#include <string.h>
+
+ #include "tools.h"
+
diff --git a/mail/bincimap/pkg-descr b/mail/bincimap/pkg-descr
new file mode 100644
index 000000000000..3e9fa8b456ed
--- /dev/null
+++ b/mail/bincimap/pkg-descr
@@ -0,0 +1,7 @@
+Binc IMAP is a GPL licensed IMAP4rev1 server for Maildir, written in C++.
+It strives to be stable, fast, flexible, and RFC compliant.
+
+For those familiar with qmail-pop3d, this IMAP server will be the natural
+choice. It is invoked similarly and uses checkpassword to authenticate.
+
+WWW: https://sourceforge.net/projects/bincimap/
diff --git a/mail/bincimap/pkg-plist b/mail/bincimap/pkg-plist
new file mode 100644
index 000000000000..7b5e6b516030
--- /dev/null
+++ b/mail/bincimap/pkg-plist
@@ -0,0 +1,23 @@
+bin/bincimapd
+bin/bincimap-up
+@sample etc/bincimap/bincimap.conf.sample
+man/man1/bincimap-up.1.gz
+man/man1/bincimapd.1.gz
+man/man5/bincimap.conf.5.gz
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/bincimap-faq.html
+%%PORTDOCS%%%%DOCSDIR%%/bincimap-goals.html
+%%PORTDOCS%%%%DOCSDIR%%/bincimap-imapdir.html
+%%PORTDOCS%%%%DOCSDIR%%/bincimap-manual.ps
+%%PORTDOCS%%%%DOCSDIR%%/bincimap-tech.html
+%%PORTDOCS%%%%DOCSDIR%%/bincimap.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/contrib/bincimap-auth-teapop.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bincimap.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/checkpassword.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/toimapdir
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tomaildir++
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xinetd-bincimap
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xinetd-bincimaps