aboutsummaryrefslogtreecommitdiff
path: root/math/orpie
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-08-02 10:57:23 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-08-02 10:57:23 +0000
commit93dc8c8d6eda9735192dce3ce4477ef35cb38230 (patch)
treeffe6dc701c27534002a44e700f98768c341bf8fd /math/orpie
parent397dffc2304c548cb359fbfe646d501ccf18577e (diff)
downloadports-93dc8c8d6eda9735192dce3ce4477ef35cb38230.tar.gz
ports-93dc8c8d6eda9735192dce3ce4477ef35cb38230.zip
Unbreak `math/orpie' against OCaml 4.05.0 and make it fetchable
Obtained from: Debian Bug-Debian: https://bugs.debian.org/868849
Notes
Notes: svn path=/head/; revision=476230
Diffstat (limited to 'math/orpie')
-rw-r--r--math/orpie/Makefile2
-rw-r--r--math/orpie/files/patch-Makefile.in9
-rw-r--r--math/orpie/files/patch-gsl_gsl__sf.ml18
-rw-r--r--math/orpie/files/patch-gsl_mlgsl__error.c10
4 files changed, 38 insertions, 1 deletions
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index 63f04dcddec7..ac60a9ffa9c9 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -5,7 +5,7 @@ PORTNAME= orpie
PORTVERSION= 1.5.2
PORTREVISION= 4
CATEGORIES+= math
-MASTER_SITES= http://pessimization.com/software/orpie/
+MASTER_SITES= GENTOO http://pessimization.com/software/orpie/
MAINTAINER= ports@FreeBSD.org
COMMENT= Fullscreen RPN calculator for the console
diff --git a/math/orpie/files/patch-Makefile.in b/math/orpie/files/patch-Makefile.in
index a4b77a26dff9..73797efdf893 100644
--- a/math/orpie/files/patch-Makefile.in
+++ b/math/orpie/files/patch-Makefile.in
@@ -1,5 +1,14 @@
--- Makefile.in.orig
+++ Makefile.in
+@@ -81,7 +81,7 @@ CURSES_OOBJS = $(CURSES_CMX) $(CURSES_CO
+ GSL_CMO = gsl/gsl_error.cmo gsl/gsl_blas.cmo gsl/gsl_complex.cmo gsl/gsl_matrix.cmo gsl/gsl_matrix_complex.cmo \
+ gsl/gsl_vector.cmo gsl/gsl_vector_complex.cmo gsl/gsl_vector_flat.cmo gsl/gsl_matrix_flat.cmo \
+ gsl/gsl_vector_complex_flat.cmo gsl/gsl_matrix_complex_flat.cmo gsl/gsl_vectmat.cmo \
+- gsl/gsl_permut.cmo gsl/gsl_linalg.cmo gsl/gsl_fun.cmo
++ gsl/gsl_permut.cmo gsl/gsl_linalg.cmo gsl/gsl_fun.cmo gsl/gsl_sf.cmo gsl/gsl_math.cmo
+ GSL_CMX = $(GSL_CMO:.cmo=.cmx)
+ GSL_COBJS = gsl/mlgsl_error.o gsl/mlgsl_blas.o gsl/mlgsl_blas_complex.o gsl/mlgsl_complex.o gsl/mlgsl_blas_float.o \
+ gsl/mlgsl_blas_complex_float.o gsl/mlgsl_matrix_complex.o gsl/mlgsl_matrix_double.o gsl/mlgsl_matrix_float.o \
@@ -201,7 +201,7 @@
GSL_INCLUDES = -I ./gsl
GSL_BFLAGS = -g $(GSL_INCLUDES) -thread
diff --git a/math/orpie/files/patch-gsl_gsl__sf.ml b/math/orpie/files/patch-gsl_gsl__sf.ml
new file mode 100644
index 000000000000..06cad5a5f304
--- /dev/null
+++ b/math/orpie/files/patch-gsl_gsl__sf.ml
@@ -0,0 +1,18 @@
+--- gsl/gsl_sf.ml.orig 2014-04-12 01:43:31 UTC
++++ gsl/gsl_sf.ml
+@@ -1142,6 +1142,7 @@ external legendre_Ql_e : int -> float -> result
+
+
+
++(*
+ (* Associated LEGENDRE functions *)
+ external legendre_Plm : int -> int -> float -> float
+ = "ml_gsl_sf_legendre_Plm"
+@@ -1167,6 +1168,7 @@ external legendre_sphPlm_array : int -> int -> float
+
+ external legendre_array_size : int -> int -> int
+ = "ml_gsl_sf_legendre_array_size"
++*)
+
+
+
diff --git a/math/orpie/files/patch-gsl_mlgsl__error.c b/math/orpie/files/patch-gsl_mlgsl__error.c
new file mode 100644
index 000000000000..f3fe29f8e194
--- /dev/null
+++ b/math/orpie/files/patch-gsl_mlgsl__error.c
@@ -0,0 +1,10 @@
+--- gsl/mlgsl_error.c.orig 2014-04-12 01:43:31 UTC
++++ gsl/mlgsl_error.c
+@@ -34,6 +34,7 @@ static value *ml_gsl_exn;
+
+ static void ml_gsl_raise_exn(const char *msg, int gsl_errno)
+ {
++ CAMLparam0();
+ CAMLlocal2(exn_msg, exn_arg);
+ exn_msg = copy_string(msg);
+ exn_arg = alloc_small(2, 0);