aboutsummaryrefslogtreecommitdiff
path: root/math/pdal
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-09-23 20:14:25 +0000
committerSteve Wills <swills@FreeBSD.org>2019-09-23 20:14:25 +0000
commit227b9448dfd1067ab14e41fa3d5dd52871612b4a (patch)
tree3ded3a316fff8249cda1a908edce9aea0983d752 /math/pdal
parent799b1652f18e4e0014d7e0faea3d525a8e70fdb2 (diff)
downloadports-227b9448dfd1067ab14e41fa3d5dd52871612b4a.tar.gz
ports-227b9448dfd1067ab14e41fa3d5dd52871612b4a.zip
math/pdal: Update to 2.0.1
PR: 240693 Submitted by: Loïc Bartoletti <lbartoletti@tuxfamily.org> (maintainer)
Notes
Notes: svn path=/head/; revision=512670
Diffstat (limited to 'math/pdal')
-rw-r--r--math/pdal/Makefile6
-rw-r--r--math/pdal/distinfo6
-rw-r--r--math/pdal/files/patch-cmake_modules_FindJSONCPP.cmake18
-rw-r--r--math/pdal/files/patch-test_unit_filters_DelaunayFilterTest.cpp11
-rw-r--r--math/pdal/files/patch-vendor_gtest_include_gtest_internal_gtest-port.h28
-rw-r--r--math/pdal/pkg-plist66
6 files changed, 46 insertions, 89 deletions
diff --git a/math/pdal/Makefile b/math/pdal/Makefile
index f6fad64f9a3e..76055ead6a9c 100644
--- a/math/pdal/Makefile
+++ b/math/pdal/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pdal
-DISTVERSION= 1.9.1
-PORTREVISION= 3
+DISTVERSION= 2.0.1
CATEGORIES= math databases graphics
MAINTAINER= lbartoletti@tuxfamily.org
@@ -12,6 +11,7 @@ COMMENT= Library for translating and manipulating point cloud data
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= nlohmann-json>0:devel/nlohmann-json
LIB_DEPENDS= libgdal.so:graphics/gdal \
libgeos.so:graphics/geos \
libboost_thread.so:devel/boost-libs \
@@ -19,7 +19,7 @@ LIB_DEPENDS= libgdal.so:graphics/gdal \
libgeotiff.so:graphics/libgeotiff \
libxml2.so:textproc/libxml2 \
liblaszip.so:archivers/laszip \
- libjsoncpp.so:devel/jsoncpp
+ libzstd.so:archivers/zstd
USES= cmake compiler:c++11-lib pathfix pkgconfig
USE_LDCONFIG= yes
diff --git a/math/pdal/distinfo b/math/pdal/distinfo
index 25213ae06856..f644097a730a 100644
--- a/math/pdal/distinfo
+++ b/math/pdal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1557523690
-SHA256 (PDAL-PDAL-1.9.1_GH0.tar.gz) = c388643cc781be39537c17ca48d0a436411ff68baeb0df56daed5e8596e09e92
-SIZE (PDAL-PDAL-1.9.1_GH0.tar.gz) = 81342934
+TIMESTAMP = 1568356237
+SHA256 (PDAL-PDAL-2.0.1_GH0.tar.gz) = bf85c0d826c644a2c52791c62227a5fbfeae845dd9d2c8bdad2d002035673e21
+SIZE (PDAL-PDAL-2.0.1_GH0.tar.gz) = 100076022
diff --git a/math/pdal/files/patch-cmake_modules_FindJSONCPP.cmake b/math/pdal/files/patch-cmake_modules_FindJSONCPP.cmake
deleted file mode 100644
index 06cbe0423b01..000000000000
--- a/math/pdal/files/patch-cmake_modules_FindJSONCPP.cmake
+++ /dev/null
@@ -1,18 +0,0 @@
---- cmake/modules/FindJSONCPP.cmake.orig 2017-08-11 17:29:28 UTC
-+++ cmake/modules/FindJSONCPP.cmake
-@@ -77,6 +77,7 @@ find_library(JSONCPP_LIBRARY
- PATHS
- "${JSONCPP_ROOT_DIR}/libs"
- /usr/lib/${CMAKE_LIBRARY_ARCHITECTURE}
-+ /usr/local/lib/${CMAKE_LIBRARY_ARCHITECTURE}
- PATH_SUFFIXES
- ${_pathsuffixes})
-
-@@ -86,6 +87,7 @@ find_path(JSONCPP_INCLUDE_DIR
- PATHS
- "${JSONCPP_ROOT_DIR}"
- /usr/include/jsoncpp
-+ /usr/local/include/jsoncpp
- PATH_SUFFIXES
- include)
-
diff --git a/math/pdal/files/patch-test_unit_filters_DelaunayFilterTest.cpp b/math/pdal/files/patch-test_unit_filters_DelaunayFilterTest.cpp
deleted file mode 100644
index ba990b2d92f6..000000000000
--- a/math/pdal/files/patch-test_unit_filters_DelaunayFilterTest.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- test/unit/filters/DelaunayFilterTest.cpp.orig 2019-05-10 22:11:49 UTC
-+++ test/unit/filters/DelaunayFilterTest.cpp
-@@ -92,7 +92,7 @@ TEST(DelaunayFilterTest, test1)
-
- // Build a vector so we can compare to an expected triangle with
- // the == operator.
-- std::vector<size_t> triangleVector = {triangle.m_a, triangle.m_b, triangle.m_c};
-+ std::vector<size_t> triangleVector = {static_cast<unsigned int>(triangle.m_a), static_cast<unsigned int>(triangle.m_b), static_cast<unsigned int>(triangle.m_c)};
-
- // Go through all of the expected triangles to check for a
- // match.
diff --git a/math/pdal/files/patch-vendor_gtest_include_gtest_internal_gtest-port.h b/math/pdal/files/patch-vendor_gtest_include_gtest_internal_gtest-port.h
deleted file mode 100644
index af296f8fb19c..000000000000
--- a/math/pdal/files/patch-vendor_gtest_include_gtest_internal_gtest-port.h
+++ /dev/null
@@ -1,28 +0,0 @@
---- vendor/gtest/include/gtest/internal/gtest-port.h.orig 2016-12-15 17:52:00 UTC
-+++ vendor/gtest/include/gtest/internal/gtest-port.h
-@@ -92,6 +92,7 @@
- // the given platform; otherwise undefined):
- // GTEST_OS_AIX - IBM AIX
- // GTEST_OS_CYGWIN - Cygwin
-+// GTEST_OS_FREEBSD - FreeBSD
- // GTEST_OS_HPUX - HP-UX
- // GTEST_OS_LINUX - Linux
- // GTEST_OS_LINUX_ANDROID - Google Android
-@@ -267,6 +268,8 @@
- # define GTEST_OS_OPENBSD 1
- #elif defined __QNX__
- # define GTEST_OS_QNX 1
-+#elif defined __FreeBSD__ || defined __DragonFly__
-+# define GTEST_OS_FREEBSD 1
- #endif // __CYGWIN__
-
- #ifndef GTEST_LANG_CXX11
-@@ -646,7 +649,7 @@ using ::std::tuple_size;
- (GTEST_OS_MAC && !GTEST_OS_IOS) || GTEST_OS_IOS_SIMULATOR || \
- (GTEST_OS_WINDOWS_DESKTOP && _MSC_VER >= 1400) || \
- GTEST_OS_WINDOWS_MINGW || GTEST_OS_AIX || GTEST_OS_HPUX || \
-- GTEST_OS_OPENBSD || GTEST_OS_QNX)
-+ GTEST_OS_OPENBSD || GTEST_OS_QNX || GTEST_OS_FREEBSD)
- # define GTEST_HAS_DEATH_TEST 1
- # include <vector> // NOLINT
- #endif
diff --git a/math/pdal/pkg-plist b/math/pdal/pkg-plist
index f0165ad5db61..9e56bf5e29df 100644
--- a/math/pdal/pkg-plist
+++ b/math/pdal/pkg-plist
@@ -4,6 +4,7 @@ include/pdal/Artifact.hpp
include/pdal/ArtifactManager.hpp
include/pdal/compression/Compression.hpp
include/pdal/compression/DeflateCompression.hpp
+include/pdal/compression/ZstdCompression.hpp
include/pdal/DbReader.hpp
include/pdal/DbWriter.hpp
include/pdal/DimDetail.hpp
@@ -19,10 +20,11 @@ include/pdal/filters/ClusterFilter.hpp
include/pdal/filters/ColorinterpFilter.hpp
include/pdal/filters/ColorInterpRamps.hpp
include/pdal/filters/ColorizationFilter.hpp
+include/pdal/filters/CovarianceFeaturesFilter.hpp
include/pdal/filters/CropFilter.hpp
-include/pdal/filters/DEMFilter.hpp
include/pdal/filters/DecimationFilter.hpp
include/pdal/filters/DelaunayFilter.hpp
+include/pdal/filters/DEMFilter.hpp
include/pdal/filters/DividerFilter.hpp
include/pdal/filters/EigenvaluesFilter.hpp
include/pdal/filters/ELMFilter.hpp
@@ -33,29 +35,33 @@ include/pdal/filters/GroupByFilter.hpp
include/pdal/filters/HAGFilter.hpp
include/pdal/filters/HeadFilter.hpp
include/pdal/filters/HexBinFilter.hpp
-include/pdal/filters/IQRFilter.hpp
include/pdal/filters/InfoFilter.hpp
-include/pdal/filters/KDistanceFilter.hpp
+include/pdal/filters/IQRFilter.hpp
+include/pdal/filters/IterativeClosestPoint.hpp
include/pdal/filters/LocateFilter.hpp
include/pdal/filters/LOFFilter.hpp
include/pdal/filters/MADFilter.hpp
include/pdal/filters/MergeFilter.hpp
+include/pdal/filters/MiniballFilter.hpp
include/pdal/filters/MongoExpressionFilter.hpp
-include/pdal/filters/MongusFilter.hpp
include/pdal/filters/MortonOrderFilter.hpp
-include/pdal/filters/NNDistanceFilter.hpp
include/pdal/filters/NeighborClassifierFilter.hpp
+include/pdal/filters/NNDistanceFilter.hpp
include/pdal/filters/NormalFilter.hpp
include/pdal/filters/OutlierFilter.hpp
include/pdal/filters/OverlayFilter.hpp
+include/pdal/filters/PlaneFitFilter.hpp
include/pdal/filters/PMFFilter.hpp
include/pdal/filters/PoissonFilter.hpp
+include/pdal/filters/ProjPipelineFilter.hpp
include/pdal/filters/RadialDensityFilter.hpp
include/pdal/filters/RandomizeFilter.hpp
include/pdal/filters/RangeFilter.hpp
+include/pdal/filters/ReciprocityFilter.hpp
include/pdal/filters/ReprojectionFilter.hpp
include/pdal/filters/ReturnsFilter.hpp
include/pdal/filters/SampleFilter.hpp
+include/pdal/filters/ShellFilter.hpp
include/pdal/filters/SMRFilter.hpp
include/pdal/filters/SortFilter.hpp
include/pdal/filters/SplitterFilter.hpp
@@ -80,6 +86,7 @@ include/pdal/io/FauxReader.hpp
include/pdal/io/GDALReader.hpp
include/pdal/io/GDALWriter.hpp
include/pdal/io/GeotiffSupport.hpp
+include/pdal/io/GltfWriter.hpp
include/pdal/io/HeaderVal.hpp
include/pdal/io/Ilvis2MetadataReader.hpp
include/pdal/io/Ilvis2Reader.hpp
@@ -90,13 +97,18 @@ include/pdal/io/LasSummaryData.hpp
include/pdal/io/LasUtils.hpp
include/pdal/io/LasVLR.hpp
include/pdal/io/LasWriter.hpp
+include/pdal/io/MemoryViewReader.hpp
include/pdal/io/NullWriter.hpp
include/pdal/io/OGRWriter.hpp
include/pdal/io/OptechCommon.hpp
include/pdal/io/OptechReader.hpp
include/pdal/io/OptechRotationMatrix.hpp
+include/pdal/io/PcdHeader.hpp
+include/pdal/io/PcdReader.hpp
+include/pdal/io/PcdWriter.hpp
include/pdal/io/PlyReader.hpp
include/pdal/io/PlyWriter.hpp
+include/pdal/io/point_types.hpp
include/pdal/io/PtsReader.hpp
include/pdal/io/QfitReader.hpp
include/pdal/io/SbetCommon.hpp
@@ -106,6 +118,7 @@ include/pdal/io/TerrasolidReader.hpp
include/pdal/io/TextReader.hpp
include/pdal/io/TextWriter.hpp
include/pdal/io/TIndexReader.hpp
+include/pdal/JsonFwd.hpp
include/pdal/KDIndex.hpp
include/pdal/Kernel.hpp
include/pdal/kernels/DeltaKernel.hpp
@@ -118,8 +131,8 @@ include/pdal/kernels/PipelineKernel.hpp
include/pdal/kernels/RandomKernel.hpp
include/pdal/kernels/SortKernel.hpp
include/pdal/kernels/SplitKernel.hpp
-include/pdal/kernels/TIndexKernel.hpp
include/pdal/kernels/TileKernel.hpp
+include/pdal/kernels/TIndexKernel.hpp
include/pdal/kernels/TranslateKernel.hpp
include/pdal/Log.hpp
include/pdal/Mesh.hpp
@@ -153,6 +166,7 @@ include/pdal/QuickInfo.hpp
include/pdal/Reader.hpp
include/pdal/Scaling.hpp
include/pdal/SpatialReference.hpp
+include/pdal/SrsBounds.hpp
include/pdal/Stage.hpp
include/pdal/StageExtensions.hpp
include/pdal/StageFactory.hpp
@@ -182,36 +196,36 @@ lib/cmake/PDAL/PDALConfigVersion.cmake
lib/cmake/PDAL/PDALTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/PDAL/PDALTargets.cmake
lib/libpdal_base.so
-lib/libpdal_base.so.8
-lib/libpdal_base.so.9.0.1
+lib/libpdal_base.so.9
+lib/libpdal_base.so.10
lib/libpdal_util.so
-lib/libpdal_util.so.8
-lib/libpdal_util.so.9.0.1
+lib/libpdal_util.so.9
+lib/libpdal_util.so.10
lib/libpdalcpp.so
libdata/pkgconfig/pdal.pc
%%BASH%%share/bash-completion/completions/pdal
%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so
-%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so.8
-%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so.9.0.1
+%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so.9
+%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so.10
%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so
-%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so.8
-%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so.9.0.1
+%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so.9
+%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so.10
%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so
-%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so.8
-%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so.9.0.1
+%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so.9
+%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so.10
%%PYTHON%%include/pdal/io/NumpyReader.hpp
%%PYTHON%%lib/libpdal_plugin_filter_python.so
-%%PYTHON%%lib/libpdal_plugin_filter_python.so.8
-%%PYTHON%%lib/libpdal_plugin_filter_python.so.9.0.1
+%%PYTHON%%lib/libpdal_plugin_filter_python.so.9
+%%PYTHON%%lib/libpdal_plugin_filter_python.so.10
%%PYTHON%%lib/libpdal_plugin_reader_numpy.so
-%%PYTHON%%lib/libpdal_plugin_reader_numpy.so.8
-%%PYTHON%%lib/libpdal_plugin_reader_numpy.so.9.0.1
+%%PYTHON%%lib/libpdal_plugin_reader_numpy.so.9
+%%PYTHON%%lib/libpdal_plugin_reader_numpy.so.10
%%SQLITE%%lib/libpdal_plugin_reader_sqlite.so
-%%SQLITE%%lib/libpdal_plugin_reader_sqlite.so.8
-%%SQLITE%%lib/libpdal_plugin_reader_sqlite.so.9.0.1
+%%SQLITE%%lib/libpdal_plugin_reader_sqlite.so.9
+%%SQLITE%%lib/libpdal_plugin_reader_sqlite.so.10
%%SQLITE%%lib/libpdal_plugin_writer_sqlite.so
-%%SQLITE%%lib/libpdal_plugin_writer_sqlite.so.8
-%%SQLITE%%lib/libpdal_plugin_writer_sqlite.so.9.0.1
+%%SQLITE%%lib/libpdal_plugin_writer_sqlite.so.9
+%%SQLITE%%lib/libpdal_plugin_writer_sqlite.so.10
lib/libpdal_plugin_kernel_fauxplugin.so
-lib/libpdal_plugin_kernel_fauxplugin.so.8
-lib/libpdal_plugin_kernel_fauxplugin.so.9.0.1
+lib/libpdal_plugin_kernel_fauxplugin.so.9
+lib/libpdal_plugin_kernel_fauxplugin.so.10