aboutsummaryrefslogtreecommitdiff
path: root/misc/asbutton
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-08-11 09:21:15 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-08-11 09:21:15 +0000
commit2cb4f999be7ca0d9cd52212ade078e6e14a1a26d (patch)
treeb9347c49fb24d8777b83eea3817d9a85cf3d7c8e /misc/asbutton
parente0829d1510742e4a97056184f38ab22d4380d705 (diff)
downloadports-2cb4f999be7ca0d9cd52212ade078e6e14a1a26d.tar.gz
ports-2cb4f999be7ca0d9cd52212ade078e6e14a1a26d.zip
- Fix SIGSEGV after recent fix for gcc 4
PR: ports/115166 Submitted by: Eugene Grosbein <eugen at grosbein.pp.ru>
Notes
Notes: svn path=/head/; revision=197447
Diffstat (limited to 'misc/asbutton')
-rw-r--r--misc/asbutton/Makefile2
-rw-r--r--misc/asbutton/files/patch-asbutton.c9
2 files changed, 4 insertions, 7 deletions
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
index e528e6efcf17..5b9271dd0f34 100644
--- a/misc/asbutton/Makefile
+++ b/misc/asbutton/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asbutton
PORTVERSION= 0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc windowmaker afterstep
MASTER_SITES= http://www.tigr.net/afterstep/download/asbutton/
diff --git a/misc/asbutton/files/patch-asbutton.c b/misc/asbutton/files/patch-asbutton.c
index caeeb866c5c9..dfbbca2cec9b 100644
--- a/misc/asbutton/files/patch-asbutton.c
+++ b/misc/asbutton/files/patch-asbutton.c
@@ -1,14 +1,11 @@
-
-$FreeBSD$
-
---- asbutton.c.orig
-+++ asbutton.c
+--- asbutton.c.orig 1999-07-17 05:59:20.000000000 +0800
++++ asbutton.c 2007-08-03 18:13:09.000000000 +0800
@@ -605,7 +605,7 @@
continue;
}
if ( !strncasecmp(line, "button", 6))
- if (atoi(&(char)line[6]) == position)
-+ if (atoi((char)line[6]) == position)
++ if (atoi(line+6) == position)
break;
}
} while (1);