aboutsummaryrefslogtreecommitdiff
path: root/misc/rname
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 16:21:10 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 16:21:10 +0000
commita838244fba3a1806cf735157ca05956077a09a02 (patch)
tree4edaf62af850f73dd2841297e316665c070e4b92 /misc/rname
parent056f7c682286ce557d89ec68365941d7fd1586e5 (diff)
downloadports-a838244fba3a1806cf735157ca05956077a09a02.tar.gz
ports-a838244fba3a1806cf735157ca05956077a09a02.zip
Stagify.
Notes
Notes: svn path=/head/; revision=357052
Diffstat (limited to 'misc/rname')
-rw-r--r--misc/rname/Makefile2
-rw-r--r--misc/rname/files/patch-Makefie24
2 files changed, 24 insertions, 2 deletions
diff --git a/misc/rname/Makefile b/misc/rname/Makefile
index 146644ba7748..f4214a4c27fa 100644
--- a/misc/rname/Makefile
+++ b/misc/rname/Makefile
@@ -13,8 +13,6 @@ COMMENT= Execute a program with a fake name
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= gmake
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
diff --git a/misc/rname/files/patch-Makefie b/misc/rname/files/patch-Makefie
new file mode 100644
index 000000000000..acf147b36cad
--- /dev/null
+++ b/misc/rname/files/patch-Makefie
@@ -0,0 +1,24 @@
+--- Makefile.orig 2014-06-09 00:18:35.116823595 +0800
++++ Makefile 2014-06-09 00:19:38.891822142 +0800
+@@ -122,8 +122,8 @@ install: install-bin install-inc install
+ @${ECHO} "Use 'make install-doc' to install documentation."
+
+ install-bin: ${TGT}
+- -${MKDIR} ${BINDIR}
+- ${INSTALL_PROGRAM} ${TGT} ${BINDIR}
++ -${MKDIR} $(DESTDIR)${BINDIR}
++ ${INSTALL_PROGRAM} ${TGT} $(DESTDIR)${BINDIR}
+
+ install-inc: ${TGTLIB}
+ # -${MKDIR} ${INCDIR}
+@@ -136,8 +136,8 @@ install-lib: ${TGTLIB}
+ install-share:
+
+ install-doc:
+- -${MKDIR} ${DOCDIR}/html
+- ${INSTALL_DATA} doc/html/*.html doc/html/*.gif ${DOCDIR}/html
++ -${MKDIR} $(DESTDIR)${DOCDIR}/html
++ ${INSTALL_DATA} doc/html/*.html doc/html/*.gif $(DESTDIR)${DOCDIR}/html
+
+ ${TGT}: ${TGTLIB} ${MAINOBJ}
+ ${CC} ${LFLAGS} -o ${TGT} ${MAINOBJ} ${TGTLIB} ${LIBS}