aboutsummaryrefslogtreecommitdiff
path: root/misc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-03-22 10:41:57 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-03-22 10:50:20 +0000
commit90277af827a5c5a194fede830367c602406122c6 (patch)
tree9a371921ee25876af9dcb10d077a26b096398f5c /misc
parent8611a821d71cc868edcb45190de6e223b170214e (diff)
downloadports-90277af827a5c5a194fede830367c602406122c6.tar.gz
ports-90277af827a5c5a194fede830367c602406122c6.zip
misc/py-sigopt: New port: SigOpt Python API client
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-sigopt/Makefile34
-rw-r--r--misc/py-sigopt/distinfo3
-rw-r--r--misc/py-sigopt/pkg-descr8
4 files changed, 46 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 91403f1fa140..b28d7c4302c7 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -488,6 +488,7 @@
SUBDIR += py-serverfiles
SUBDIR += py-shap2
SUBDIR += py-shell-gpt
+ SUBDIR += py-sigopt
SUBDIR += py-soapy_power
SUBDIR += py-spdx
SUBDIR += py-spdx-lookup
diff --git a/misc/py-sigopt/Makefile b/misc/py-sigopt/Makefile
new file mode 100644
index 000000000000..aa67bead5934
--- /dev/null
+++ b/misc/py-sigopt/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= sigopt
+DISTVERSION= 8.8.2 # should be 8.8.2-20240313, but this fails due to *-${DISTVERSION}*.whl, while *-8.8.2.whl is built
+CATEGORIES= misc python # machine-learning
+#MASTER_SITES= PYPI # tarball is broken, see https://github.com/sigopt/sigopt-python/issues/439
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= SigOpt Python API client
+WWW= https://sigopt.org/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backoff>=1.10.0:devel/py-backoff@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=8.0.0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gitpython>=2.0.0:devel/py-gitpython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=21.3:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}png>0:graphics/py-png@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.25.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=1.26.5:net/py-urllib3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= pep517 autoplist # pytest - missing dependencies, like hyperopt
+
+USE_GITHUB= yes
+GH_PROJECT= sigopt-python
+GH_TAGNAME= a52302f
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/misc/py-sigopt/distinfo b/misc/py-sigopt/distinfo
new file mode 100644
index 000000000000..01ff4e1f9ff4
--- /dev/null
+++ b/misc/py-sigopt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1711103764
+SHA256 (sigopt-sigopt-python-8.8.2-a52302f_GH0.tar.gz) = b085d1e686af6b2b083703c5b31de9a673a9b26aba0bfa28a866de872c07b179
+SIZE (sigopt-sigopt-python-8.8.2-a52302f_GH0.tar.gz) = 174472
diff --git a/misc/py-sigopt/pkg-descr b/misc/py-sigopt/pkg-descr
new file mode 100644
index 000000000000..bfdeb33a6082
--- /dev/null
+++ b/misc/py-sigopt/pkg-descr
@@ -0,0 +1,8 @@
+sigopt is an open source version of SigOpt API, performing hyperparameter
+optimization and visualization.
+
+Sigopt-server is an open-source tool for managing adaptive experiments,
+especially for hyperparameter optimization. It uses algorithms to determine
+the best spots in parameter space for metric optimization, and includes web
+visualizations so you can improve your models. For more information you can
+read about our service offering. Our documentation is here.