aboutsummaryrefslogtreecommitdiff
path: root/multimedia/kdenlive
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-07-30 17:39:04 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-07-30 18:14:36 +0000
commit5c8adda9492587fe0c7d9c8160dbdf6f9b2e09a3 (patch)
tree66fc99bf71951a99b308de43eb573838d8458fb1 /multimedia/kdenlive
parentf8617a24662331dd03d72d4bc36a0238ec54d119 (diff)
downloadports-5c8adda9492587fe0c7d9c8160dbdf6f9b2e09a3.tar.gz
ports-5c8adda9492587fe0c7d9c8160dbdf6f9b2e09a3.zip
multimedia/{py-,}mlt{-qt5,}: rename to multimedia/{py-,}mlt6{-qt5,}:
- To make it possible to easily import mlt-7 move the current port to a versioned directory. - Add Mk/Uses/mlt.mk to make it easily possible to depend on a given mlt version: USES=mlt:6 will get you a dependency on multimedia/mlt6, while USES=mlt:7 will get you a dependency on the soon to be added multimedia/mlt7 - Switch the port to use cmake as a build system - While here, provide some more options to make it possible to have a leaner package if required - Bump consumers after rename of the dependency
Diffstat (limited to 'multimedia/kdenlive')
-rw-r--r--multimedia/kdenlive/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/multimedia/kdenlive/Makefile b/multimedia/kdenlive/Makefile
index 77e1b223a9c7..21b72837baba 100644
--- a/multimedia/kdenlive/Makefile
+++ b/multimedia/kdenlive/Makefile
@@ -1,5 +1,6 @@
PORTNAME= kdenlive
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= multimedia kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -7,15 +8,14 @@ COMMENT= KDE professional quality non-linear video editing suite
LICENSE= GPLv2
-LIB_DEPENDS= libmlt.so:multimedia/mlt \
- librttr_core.so:devel/rttr
+LIB_DEPENDS= librttr_core.so:devel/rttr
BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
RUN_DEPENDS= ffmpeg${FFMPEG_SUFX}:multimedia/ffmpeg${FFMPEG_SUFX} \
- ${LOCALBASE}/lib/mlt/libmltqt.so:multimedia/mlt-qt5
+ ${LOCALBASE}/lib/mlt/libmltqt.so:multimedia/mlt6-qt5
USES= cmake compiler:c++11-lang desktop-file-utils gettext-tools \
- gl pkgconfig qt:5 shared-mime-info kde:5 tar:xz xorg
+ gl mlt:6 pkgconfig qt:5 shared-mime-info kde:5 tar:xz xorg
USE_GL= gl glu
USE_KDE= archive attica auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons ecm filemetadata \