aboutsummaryrefslogtreecommitdiff
path: root/net-im/ricochet
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 16:23:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-12-14 17:03:08 +0000
commitc5ebde2ab858e84a03fdc26b576aba65add8a0f3 (patch)
tree2fc572f36910c36c8060a1040123190469d3d7cf /net-im/ricochet
parent871015ac6fafe9fc1c7c11b4a2cbb7259868e7ba (diff)
downloadports-c5ebde2ab858e84a03fdc26b576aba65add8a0f3.tar.gz
ports-c5ebde2ab858e84a03fdc26b576aba65add8a0f3.zip
net-im/ricochet: Fix build with protobuf 22+
Diffstat (limited to 'net-im/ricochet')
-rw-r--r--net-im/ricochet/Makefile4
-rw-r--r--net-im/ricochet/files/patch-ricochet.pro11
2 files changed, 13 insertions, 2 deletions
diff --git a/net-im/ricochet/Makefile b/net-im/ricochet/Makefile
index 962651787961..db96d352d700 100644
--- a/net-im/ricochet/Makefile
+++ b/net-im/ricochet/Makefile
@@ -15,12 +15,14 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libprotobuf.so:devel/protobuf
-USES= compiler:c++11-lib gl gmake pkgconfig qmake qt:5 ssl
+USES= compiler:c++17-lang gl gmake pkgconfig qmake qt:5 ssl
USE_GITHUB= yes
GH_ACCOUNT= ricochet-im
USE_QT= core declarative gui multimedia network quickcontrols widgets \
buildtools:build linguisttools:build
USE_GL= gl
+
+USE_CXXSTD= c++17
QMAKE_ARGS+= DEFINES+=RICOCHET_NO_PORTABLE OPENSSLDIR=${OPENSSLBASE}
OPTIONS_DEFINE= TOR
diff --git a/net-im/ricochet/files/patch-ricochet.pro b/net-im/ricochet/files/patch-ricochet.pro
index 95e60a660f0d..8db388772378 100644
--- a/net-im/ricochet/files/patch-ricochet.pro
+++ b/net-im/ricochet/files/patch-ricochet.pro
@@ -1,6 +1,15 @@
--- ricochet.pro.orig 2016-11-04 22:05:33 UTC
+++ ricochet.pro
-@@ -52,18 +52,18 @@ CONFIG(release,debug|release):DEFINES +=
+@@ -36,7 +36,7 @@ lessThan(QT_MAJOR_VERSION,5)|lessThan(QT_MINOR_VERSION
+ TARGET = ricochet
+ TEMPLATE = app
+ QT += core gui network quick widgets multimedia
+-CONFIG += c++11
++CONFIG += c++17
+
+ VERSION = 1.1.4
+
+@@ -52,18 +52,18 @@ CONFIG(release,debug|release):DEFINES += QT_NO_DEBUG_O
contains(DEFINES, RICOCHET_NO_PORTABLE) {
unix:!macx {