aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/openvmps
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-02-20 16:54:45 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-02-20 16:54:45 +0000
commit81aea4d3ca8ebea86311c300dcc3e8bdd2f07205 (patch)
tree062cebfacac66e6f2a4268f730340718f0661b3b /net-mgmt/openvmps
parent24b2ad8d177a34925eed7a18378b97be500af90f (diff)
downloadports-81aea4d3ca8ebea86311c300dcc3e8bdd2f07205.tar.gz
ports-81aea4d3ca8ebea86311c300dcc3e8bdd2f07205.zip
Resurrected port: net-mgmt/openvmps
VMPS (VLAN Management Policy Server) is a way of assigning switch ports to specific VLANs based on the MAC address of connecting device. OpenVMPS is a GPL implementation of VMPS. WWW: http://vmps.sourceforge.net/ Submitted by: Vladimir Pushkar <vladimir.pushkar@gmail.com>
Notes
Notes: svn path=/head/; revision=409258
Diffstat (limited to 'net-mgmt/openvmps')
-rw-r--r--net-mgmt/openvmps/Makefile28
-rw-r--r--net-mgmt/openvmps/distinfo2
-rw-r--r--net-mgmt/openvmps/files/vmpsd.in29
-rw-r--r--net-mgmt/openvmps/pkg-descr5
-rw-r--r--net-mgmt/openvmps/pkg-plist3
5 files changed, 67 insertions, 0 deletions
diff --git a/net-mgmt/openvmps/Makefile b/net-mgmt/openvmps/Makefile
new file mode 100644
index 000000000000..c1ccc7756933
--- /dev/null
+++ b/net-mgmt/openvmps/Makefile
@@ -0,0 +1,28 @@
+# Created by: Craig Boston <craig@yekse.gank.org>
+# $FreeBSD$
+
+PORTNAME= openvmps
+PORTVERSION= 1.4.06
+CATEGORIES= net-mgmt
+MASTER_SITES= SF/vmps/vmpsd/${PORTVERSION}
+DISTNAME= vmpsd-${PORTVERSION}
+
+MAINTAINER= vladimir.pushkar@gmail.com
+COMMENT= GPL implementation of the VMPS protocol
+
+LICENSE= GPLv2
+
+USE_RC_SUBR= vmpsd
+
+USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS=--bindir=${PREFIX}/sbin
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^install-exec-am:/s|install-sysconfDATA||' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/vlan.db ${STAGEDIR}${PREFIX}/etc/vmps.db.sample
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/openvmps/distinfo b/net-mgmt/openvmps/distinfo
new file mode 100644
index 000000000000..16cfdd4474aa
--- /dev/null
+++ b/net-mgmt/openvmps/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vmpsd-1.4.06.tar.gz) = deda56362c8de967e1b2b7e22f4e0e0b9fcedeaabffebb345b2be02360bdb0b5
+SIZE (vmpsd-1.4.06.tar.gz) = 121063
diff --git a/net-mgmt/openvmps/files/vmpsd.in b/net-mgmt/openvmps/files/vmpsd.in
new file mode 100644
index 000000000000..b2ec03358d07
--- /dev/null
+++ b/net-mgmt/openvmps/files/vmpsd.in
@@ -0,0 +1,29 @@
+#!/bin/sh
+
+# $FreeBSD$
+
+# PROVIDE: vmpsd
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+. /etc/rc.subr
+
+name=vmpsd
+rcvar=vmpsd_enable
+
+load_rc_config $name
+
+# Define these vmpsd_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/vmpsd
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+
+: ${vmpsd_enable:=NO} # Enable vmpsd
+: ${vmpsd_program:=%%PREFIX%%/sbin/vmpsd} # Location of vmpsd
+: ${vmpsd_flags=-f /usr/local/etc/vmps.db} # Flags to vmpsd program
+
+command=%%PREFIX%%/sbin/${name}
+
+run_rc_command $1
diff --git a/net-mgmt/openvmps/pkg-descr b/net-mgmt/openvmps/pkg-descr
new file mode 100644
index 000000000000..f4b21bb58169
--- /dev/null
+++ b/net-mgmt/openvmps/pkg-descr
@@ -0,0 +1,5 @@
+VMPS (VLAN Management Policy Server) is a way of assigning switch ports to
+specific VLANs based on the MAC address of connecting device. OpenVMPS is a
+GPL implementation of VMPS.
+
+WWW: http://vmps.sourceforge.net/
diff --git a/net-mgmt/openvmps/pkg-plist b/net-mgmt/openvmps/pkg-plist
new file mode 100644
index 000000000000..827ce1d36a0d
--- /dev/null
+++ b/net-mgmt/openvmps/pkg-plist
@@ -0,0 +1,3 @@
+@sample etc/vmps.db.sample
+sbin/vmpsd
+man/man1/vmpsd.1.gz