aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/wmi-client
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 23:51:26 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-26 00:09:49 +0000
commit9338523fd051c85755db8c06574a74552025e7b5 (patch)
tree2ee878bc03d3fba3fbe3601a918a82d1b33f14f7 /net-mgmt/wmi-client
parent0f59f3265c75404e19766d04f909e30131f48ba8 (diff)
downloadports-9338523fd051c85755db8c06574a74552025e7b5.tar.gz
ports-9338523fd051c85755db8c06574a74552025e7b5.zip
net-mgmt/wmi-client: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'net-mgmt/wmi-client')
-rw-r--r--net-mgmt/wmi-client/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-mgmt/wmi-client/Makefile b/net-mgmt/wmi-client/Makefile
index b358d7b02df8..13781005989a 100644
--- a/net-mgmt/wmi-client/Makefile
+++ b/net-mgmt/wmi-client/Makefile
@@ -19,6 +19,12 @@ ALL_TARGET= build
PROGS= bin/wmic bin/winexe
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
do-install:
.for x in ${PROGS}
${INSTALL_PROGRAM} ${WRKSRC}/Samba/source/${x} ${STAGEDIR}${PREFIX}/${x}