aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/wmi-client
diff options
context:
space:
mode:
authorMotoyuki Konno <motoyuki@FreeBSD.org>2012-04-21 12:27:40 +0000
committerMotoyuki Konno <motoyuki@FreeBSD.org>2012-04-21 12:27:40 +0000
commitc679424d1752dd4aa64d1f82b2e88214fc7364d1 (patch)
tree44b1b2129b0416abbaaba16b0b253378bbd9e8f2 /net-mgmt/wmi-client
parent9a915cc5a2b7476fb468a56d7b254ddcab299118 (diff)
downloadports-c679424d1752dd4aa64d1f82b2e88214fc7364d1.tar.gz
ports-c679424d1752dd4aa64d1f82b2e88214fc7364d1.zip
Add Pandora FMS 4.0.1 - a Flexible Monitoring System.
WMI client 1.3.16 - a WMI (Windows Management Instrumentation) client which is needed for Pandora FMS. Submitted by: KIKUCHI Koichiro <koichiro@rworks.jp> Junichi Satoh <junichi@junichi.org> WWW; http://pandorafms.org/ Feature safe: yes
Notes
Notes: svn path=/head/; revision=295185
Diffstat (limited to 'net-mgmt/wmi-client')
-rw-r--r--net-mgmt/wmi-client/Makefile39
-rw-r--r--net-mgmt/wmi-client/distinfo2
-rw-r--r--net-mgmt/wmi-client/files/patch-GNUmakefile29
-rw-r--r--net-mgmt/wmi-client/pkg-descr6
-rw-r--r--net-mgmt/wmi-client/pkg-plist32
5 files changed, 108 insertions, 0 deletions
diff --git a/net-mgmt/wmi-client/Makefile b/net-mgmt/wmi-client/Makefile
new file mode 100644
index 000000000000..de294f7bc06c
--- /dev/null
+++ b/net-mgmt/wmi-client/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: wmi
+# Date created: 2011-11-25
+# Whom: KIKUCHI Koichiro <koichiro@rworks.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmi
+PORTVERSION= 1.3.16
+CATEGORIES= net-mgmt
+MASTER_SITES= http://dev.zenoss.org/svn/trunk/inst/externallibs/ \
+ ftp://ftp.mk.bsdclub.org/pub/FreeBSD/distfiles/
+PKGNAMESUFFIX= -client
+
+MAINTAINER= koichiro@rworks.jp
+COMMENT= DCOM/WMI client implementation
+
+CONFLICTS= zenoss-3*
+
+USE_BZIP2= yes
+USE_AUTOTOOLS= autoconf:env
+USE_PYTHON_BUILD= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
+
+#BUILD_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
+#RUN_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
+
+MAKEFILE= GNUmakefile
+MAKE_ENV= ZENHOME="${PREFIX}" PY_LIBDIR="${PYTHONPREFIX_SITELIBDIR}"
+ALL_TARGET= build
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+# do noting
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/wmi-client/distinfo b/net-mgmt/wmi-client/distinfo
new file mode 100644
index 000000000000..3d6bae13fd94
--- /dev/null
+++ b/net-mgmt/wmi-client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wmi-1.3.16.tar.bz2) = 1001e0786485ba70ec5ae94b205b182f9cda50cb305d31d12c0ca2edd4c39aff
+SIZE (wmi-1.3.16.tar.bz2) = 3047783
diff --git a/net-mgmt/wmi-client/files/patch-GNUmakefile b/net-mgmt/wmi-client/files/patch-GNUmakefile
new file mode 100644
index 000000000000..fde4eaa2b8fe
--- /dev/null
+++ b/net-mgmt/wmi-client/files/patch-GNUmakefile
@@ -0,0 +1,29 @@
+--- GNUmakefile.orig 2011-12-23 13:58:36.000000000 +0000
++++ GNUmakefile 2012-04-13 04:10:44.000000000 +0000
+@@ -36,7 +36,7 @@
+ # Install dir for libasync_wmi_lib.so.* and pysamba wrapper code.
+ # e.g., Samba/source/bin/shared/libasync_wmi_lib.so.0.0.1 --> $(PY_LIBDIR)
+ #
+-PY_LIBDIR = $(ZENHOME)/lib/python
++PY_LIBDIR? = $(ZENHOME)/lib/python
+
+ #-------------------------------------------------------------------------#
+ # A key deliverable of this build process is the libasync_wmi shared #
+@@ -70,7 +70,7 @@
+ #-------------------------------------------------------------------------#
+ # Comment out the next line to disable google-breakpad dependency.
+ ifneq ($(shell uname), Darwin)
+-USE_BREAKPAD = 1
++#USE_BREAKPAD = 1
+ endif
+
+ ifneq ($(USE_BREAKPAD),)
+@@ -158,7 +158,7 @@
+ $(SAMBA_SRCDIR)/Makefile: $(SAMBA_SRCDIR)/autogen.sh
+ cd $(SAMBA_SRCDIR) ;\
+ ./autogen.sh ;\
+- CPPFLAGS="$(WMI_CPPFLAGS)" ./configure --without-readline --enable-debug
++ CPPFLAGS="$(WMI_CPPFLAGS)" ./configure --without-readline --enable-debug --disable-gnutls
+
+ ifeq ($(USE_BREAKPAD),)
+ pywmi-build: build-prereqs $(LIBRPC_CONFIG_MK) $(SAMBA_SRCDIR)/Makefile
diff --git a/net-mgmt/wmi-client/pkg-descr b/net-mgmt/wmi-client/pkg-descr
new file mode 100644
index 000000000000..1bd14ca06a4d
--- /dev/null
+++ b/net-mgmt/wmi-client/pkg-descr
@@ -0,0 +1,6 @@
+This DCOM/WMI client implementation is based on Samba4 sources.
+It uses RPC/DCOM mechanism to interact with WMI services on
+Windows machines.
+
+This package contains also winexe - program to remote execution
+Windows commands remotely.
diff --git a/net-mgmt/wmi-client/pkg-plist b/net-mgmt/wmi-client/pkg-plist
new file mode 100644
index 000000000000..5ed2ddd16316
--- /dev/null
+++ b/net-mgmt/wmi-client/pkg-plist
@@ -0,0 +1,32 @@
+@comment $FreeBSD$
+bin/winexe
+bin/wmic
+%%PYTHON_SITELIBDIR%%/libasync_wmi_lib.so.0
+%%PYTHON_SITELIBDIR%%/libasync_wmi_lib.so.0.0.2
+%%PYTHON_SITELIBDIR%%/pysamba/talloc.py
+%%PYTHON_SITELIBDIR%%/pysamba/test/watcher.py
+%%PYTHON_SITELIBDIR%%/pysamba/test/connect.py
+%%PYTHON_SITELIBDIR%%/pysamba/test/wmic.py
+%%PYTHON_SITELIBDIR%%/pysamba/__init__.py
+%%PYTHON_SITELIBDIR%%/pysamba/version.pyc
+%%PYTHON_SITELIBDIR%%/pysamba/library.py
+%%PYTHON_SITELIBDIR%%/pysamba/composite_context.py
+%%PYTHON_SITELIBDIR%%/pysamba/version.py
+%%PYTHON_SITELIBDIR%%/pysamba/ndr.py
+%%PYTHON_SITELIBDIR%%/pysamba/rpc/Rpc.py
+%%PYTHON_SITELIBDIR%%/pysamba/rpc/__init__.py
+%%PYTHON_SITELIBDIR%%/pysamba/rpc/credentials.py
+%%PYTHON_SITELIBDIR%%/pysamba/rpc/dcerpc.py
+%%PYTHON_SITELIBDIR%%/pysamba/rpc/rpc_request.py
+%%PYTHON_SITELIBDIR%%/pysamba/rpc/oxidresolver.py
+%%PYTHON_SITELIBDIR%%/pysamba/wbem/__init__.py
+%%PYTHON_SITELIBDIR%%/pysamba/wbem/Query.py
+%%PYTHON_SITELIBDIR%%/pysamba/wbem/wbem.py
+%%PYTHON_SITELIBDIR%%/pysamba/twisted/callback.py
+%%PYTHON_SITELIBDIR%%/pysamba/twisted/__init__.py
+%%PYTHON_SITELIBDIR%%/pysamba/twisted/reactor.py
+@dirrmtry %%PYTHON_SITELIBDIR%%/pysamba/wbem
+@dirrmtry %%PYTHON_SITELIBDIR%%/pysamba/twisted
+@dirrmtry %%PYTHON_SITELIBDIR%%/pysamba/test
+@dirrmtry %%PYTHON_SITELIBDIR%%/pysamba/rpc
+@dirrmtry %%PYTHON_SITELIBDIR%%/pysamba