aboutsummaryrefslogtreecommitdiff
path: root/net/h323plus
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-24 16:36:01 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-24 16:36:01 +0000
commit721817fc7569ea177810e0b7de1abb8d832a5d30 (patch)
treea5512322b2bb1aa69ba50d0bfae3f6eb0a13b3a6 /net/h323plus
parentae112c4e7a6e46540fe6a2c84d239d2b82630411 (diff)
downloadports-721817fc7569ea177810e0b7de1abb8d832a5d30.tar.gz
ports-721817fc7569ea177810e0b7de1abb8d832a5d30.zip
Add net/h323plus.
H.323 Plus (or, "H323plus") is a multi-platform H323 Video Conferencing library formerly known as OpenH323. The new name was chosen to reflect the fact that the open source H.323 project now contains even more more functionality than ever before. WWW: http://www.h323plus.org/ PR: 192912 Submitted by: Nikola Kolev
Notes
Notes: svn path=/head/; revision=365958
Diffstat (limited to 'net/h323plus')
-rw-r--r--net/h323plus/Makefile32
-rw-r--r--net/h323plus/distinfo2
-rw-r--r--net/h323plus/files/patch-Makefile.in29
-rw-r--r--net/h323plus/files/patch-openh323u.mak.in20
-rw-r--r--net/h323plus/pkg-descr6
-rw-r--r--net/h323plus/pkg-plist129
6 files changed, 218 insertions, 0 deletions
diff --git a/net/h323plus/Makefile b/net/h323plus/Makefile
new file mode 100644
index 000000000000..14ba0af94a6e
--- /dev/null
+++ b/net/h323plus/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= h323plus
+PORTVERSION= 1.26.5
+CATEGORIES= net multimedia
+MASTER_SITES= http://www.h323plus.org/source/download/
+DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}
+
+MAINTAINER= koue@chaosophia.net
+COMMENT= H323 Video Conferencing library
+
+LICENSE= MPL
+
+LIB_DEPENDS= libpt.so:${PORTSDIR}/devel/ptlib
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+CONFLICTS= openh323-[0-9]*
+
+USES= gmake
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+CFLAGS+= -I${LOCALBASE}/include -I${WRKSRC}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+MAKE_JOBS_UNSAFE=yes
+
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libh323.so.1.26.5
+
+.include <bsd.port.mk>
diff --git a/net/h323plus/distinfo b/net/h323plus/distinfo
new file mode 100644
index 000000000000..57a0310ddda6
--- /dev/null
+++ b/net/h323plus/distinfo
@@ -0,0 +1,2 @@
+SHA256 (h323plus-v1_26_5.tar.gz) = 73a5d8bcdbed94a05e4f43a81ef5b41fa5443fe1986ff876d9bebb7656f8ec32
+SIZE (h323plus-v1_26_5.tar.gz) = 4249565
diff --git a/net/h323plus/files/patch-Makefile.in b/net/h323plus/files/patch-Makefile.in
new file mode 100644
index 000000000000..c771e6d83b4f
--- /dev/null
+++ b/net/h323plus/files/patch-Makefile.in
@@ -0,0 +1,29 @@
+--- Makefile.in.orig 2013-12-12 18:16:27.000000000 +0200
++++ Makefile.in 2014-08-22 12:44:18.000000000 +0300
+@@ -46,7 +46,7 @@ endif
+
+ default :: optshared
+
+-all :: bothdepend both
++all :: optdepend opt
+
+ include $(OPENH323DIR)/openh323u.mak
+
+@@ -87,7 +87,7 @@ update:
+ $(MAKE) all
+
+ # standard build command
+-$(subst tagbuild,,$(STANDARD_TARGETS)) ::
++$(subst debug,,$(STANDARD_TARGETS)) ::
+ $(MAKE) -C src $@
+
+ notrace::
+@@ -99,7 +99,7 @@ docs:
+ install:
+ mkdir -p $(DESTDIR)$(LIBDIR)
+ rm -f $(DESTDIR)$(LIBDIR)/libh323_*_r.so*
+- $(INSTALL) -m 444 lib/$(OH323_FILE).@MAJOR_VERSION@.@MINOR_VERSION@.@BUILD_NUMBER@ $(DESTDIR)$(LIBDIR)
++ $(INSTALL) -m 755 lib/$(OH323_FILE).@MAJOR_VERSION@.@MINOR_VERSION@.@BUILD_NUMBER@ $(DESTDIR)$(LIBDIR)
+ (cd $(DESTDIR)$(LIBDIR) ; \
+ rm -f $(OH323_FILE).@MAJOR_VERSION@.@MINOR_VERSION@ ; \
+ ln -sf $(OH323_FILE).@MAJOR_VERSION@.@MINOR_VERSION@.@BUILD_NUMBER@ $(OH323_FILE).@MAJOR_VERSION@.@MINOR_VERSION@ \
diff --git a/net/h323plus/files/patch-openh323u.mak.in b/net/h323plus/files/patch-openh323u.mak.in
new file mode 100644
index 000000000000..fdab3bfbc1c1
--- /dev/null
+++ b/net/h323plus/files/patch-openh323u.mak.in
@@ -0,0 +1,20 @@
+--- openh323u.mak.in.orig 2013-12-13 00:52:13.000000000 +0200
++++ openh323u.mak.in 2014-08-22 12:13:27.000000000 +0300
+@@ -96,7 +96,7 @@ endif # NOTRACE
+ include $(PTLIBDIR)/make/ptlib.mak
+ endif # LIBRARY_MAKEFILE
+
+-LIBDIRS += $(OPENH323DIR)
++LIBDIRS = $(OPENH323DIR)
+
+ #OH323_SUPPRESS_H235 = 1
+
+@@ -132,7 +132,7 @@ OH323_SUFFIX = $(OBJ_SUFFIX)
+ endif # OH323_SUFFIX
+ endif # HAS_PTLIB_LIB_MAK
+
+-OH323_BASE = h323_$(PLATFORM_TYPE)_$(OH323_SUFFIX)$(LIB_TYPE)
++OH323_BASE = h323$(OH323_SUFFIX)$(LIB_TYPE)
+ OH323_FILE = lib$(OH323_BASE).$(LIB_SUFFIX)
+
+ LDFLAGS += -L$(OH323_LIBDIR)
diff --git a/net/h323plus/pkg-descr b/net/h323plus/pkg-descr
new file mode 100644
index 000000000000..5fec38e04b57
--- /dev/null
+++ b/net/h323plus/pkg-descr
@@ -0,0 +1,6 @@
+H.323 Plus (or, "H323plus") is a multi-platform H323 Video Conferencing
+library formerly known as OpenH323. The new name was chosen to reflect
+the fact that the open source H.323 project now contains even
+more more functionality than ever before.
+
+WWW: http://www.h323plus.org/
diff --git a/net/h323plus/pkg-plist b/net/h323plus/pkg-plist
new file mode 100644
index 000000000000..51922b0ff4d3
--- /dev/null
+++ b/net/h323plus/pkg-plist
@@ -0,0 +1,129 @@
+include/openh323/codec/opalplugin.h
+include/openh323/h224/h224.h
+include/openh323/h224/h224handler.h
+include/openh323/h224/h281.h
+include/openh323/h224/h281handler.h
+include/openh323/h224/h284.h
+include/openh323/h224/t140.h
+include/openh323/h230/OID2.h
+include/openh323/h230/h230.h
+include/openh323/h235/h2351.h
+include/openh323/h235/h2356.h
+include/openh323/h235/h235caps.h
+include/openh323/h235/h235chan.h
+include/openh323/h235/h235crypto.h
+include/openh323/h235/h235support.h
+include/openh323/h341/h341.h
+include/openh323/h341/h341_oid.h
+include/openh323/h350/h350.h
+include/openh323/h350/h350_service.h
+include/openh323/h450/h4501.h
+include/openh323/h450/h45010.h
+include/openh323/h450/h45011.h
+include/openh323/h450/h4502.h
+include/openh323/h450/h4503.h
+include/openh323/h450/h4504.h
+include/openh323/h450/h4505.h
+include/openh323/h450/h4506.h
+include/openh323/h450/h4507.h
+include/openh323/h450/h4508.h
+include/openh323/h450/h4509.h
+include/openh323/h450/h450pdu.h
+include/openh323/h460/h460.h
+include/openh323/h460/h4601.h
+include/openh323/h460/h46015.h
+include/openh323/h460/h46018.h
+include/openh323/h460/h46018_h225.h
+include/openh323/h460/h46019.h
+include/openh323/h460/h46024b.h
+include/openh323/h460/h46026.h
+include/openh323/h460/h46026mgr.h
+include/openh323/h460/h4604.h
+include/openh323/h460/h4609.h
+include/openh323/h460/h460_oid3.h
+include/openh323/h460/h460_oid6.h
+include/openh323/h460/h460_oid9.h
+include/openh323/h460/h460_std17.h
+include/openh323/h460/h460_std18.h
+include/openh323/h460/h460_std22.h
+include/openh323/h460/h460_std23.h
+include/openh323/h460/h460_std25.h
+include/openh323/h460/h460_std25_pidf_lo.h
+include/openh323/h460/h460_std26.h
+include/openh323/h460/h460_std9.h
+include/openh323/h460/h460p.h
+include/openh323/h460/h460pres.h
+include/openh323/h460/h460tm.h
+include/openh323/h460/h4610.h
+include/openh323/h460/h461_base.h
+include/openh323/h460/upnpcp.h
+include/openh323/channels.h
+include/openh323/codecs.h
+include/openh323/dynacodec.h
+include/openh323/g711.h
+include/openh323/gccpdu.h
+include/openh323/gkclient.h
+include/openh323/gkserver.h
+include/openh323/gnugknat.h
+include/openh323/guid.h
+include/openh323/h225.h
+include/openh323/h225ras.h
+include/openh323/h235.h
+include/openh323/h235auth.h
+include/openh323/h235plugin.h
+include/openh323/h235pluginmgr.h
+include/openh323/h245.h
+include/openh323/h248.h
+include/openh323/h323.h
+include/openh323/h323caps.h
+include/openh323/h323annexg.h
+include/openh323/h323con.h
+include/openh323/h323ep.h
+include/openh323/h323filetransfer.h
+include/openh323/h323h224.h
+include/openh323/h323neg.h
+include/openh323/h323pdu.h
+include/openh323/h323pluginmgr.h
+include/openh323/h323rtp.h
+include/openh323/h323t120.h
+include/openh323/h323t140.h
+include/openh323/h323t38.h
+include/openh323/h323trans.h
+include/openh323/h501.h
+include/openh323/h501pdu.h
+include/openh323/jitter.h
+include/openh323/mcspdu.h
+include/openh323/mediafmt.h
+include/openh323/opalvxml.h
+include/openh323/opalwavfile.h
+include/openh323/openh323buildopts.h
+include/openh323/peclient.h
+include/openh323/ptlib_extras.h
+include/openh323/q922.h
+include/openh323/q931.h
+include/openh323/rfc2833.h
+include/openh323/rtp.h
+include/openh323/rtp2wav.h
+include/openh323/svcctrl.h
+include/openh323/t120proto.h
+include/openh323/t38.h
+include/openh323/t38proto.h
+include/openh323/transports.h
+include/openh323/x224.h
+include/openh323/x880.h
+lib/libh323.so.1.26.5
+lib/libh323.so.1.26
+lib/libh323.so.1
+lib/libh323.so
+lib/libopenh323.so
+share/openh323/openh323u.mak
+@dirrmtry include/openh323/codec
+@dirrmtry include/openh323/h224
+@dirrmtry include/openh323/h230
+@dirrmtry include/openh323/h235
+@dirrmtry include/openh323/h341
+@dirrmtry include/openh323/h350
+@dirrmtry include/openh323/h450
+@dirrmtry include/openh323/h460
+@dirrmtry include/openh323
+@dirrmtry share/openh323