aboutsummaryrefslogtreecommitdiff
path: root/net/ipxe
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-08-08 20:00:00 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-08-08 20:00:00 +0000
commitc7cf918e832d60a98ff3f27e0ddba9a668124e9c (patch)
treebb49820964634139abd646414a069f6deabf514a /net/ipxe
parent7ddaa7a11c3183f6299b004cd82387cfb5e513a5 (diff)
downloadports-c7cf918e832d60a98ff3f27e0ddba9a668124e9c.tar.gz
ports-c7cf918e832d60a98ff3f27e0ddba9a668124e9c.zip
When ld is lld net/ipxe fails to build with
ld -m elf_i386_fbsd -N --no-check-sections --section-start=.prefix=0 --gc-sections -static -o bin/usbdisk.bin --oformat binary -e 0 bin/usbdisk.o ld: error: unknown argument: --no-check-sections ld: error: unknown argument: --section-start=.prefix=0 The port is supposed to use ld from devel/binutils but does not currently respect ${LD} (or any of the other binutils related variables) and always uses ld from base. Make sure that the build actually uses the binutils from ports. While here: - Remove Perl runtime dependency - Pet portlint - Trim the pkg-message to the actually useful bits
Notes
Notes: svn path=/head/; revision=447572
Diffstat (limited to 'net/ipxe')
-rw-r--r--net/ipxe/Makefile18
-rw-r--r--net/ipxe/files/pkg-message.in29
2 files changed, 18 insertions, 29 deletions
diff --git a/net/ipxe/Makefile b/net/ipxe/Makefile
index e24347c5b44b..cccaaf4b8e1f 100644
--- a/net/ipxe/Makefile
+++ b/net/ipxe/Makefile
@@ -5,7 +5,7 @@
PORTNAME= ipxe
PORTVERSION= 20161208
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MAINTAINER= tobik@FreeBSD.org
@@ -17,6 +17,9 @@ BUILD_DEPENDS= ${LOCALBASE}/share/syslinux/bios/core/isolinux.bin:sysutils/sysli
bash:shells/bash \
mkisofs:sysutils/cdrtools
+USES= gmake perl5 shebangfix
+USE_BINUTILS= yes
+USE_GCC= yes
USE_GITHUB= yes
GH_PROJECT= ipxe
# iPXE hasn't had a release since 2010.
@@ -28,16 +31,21 @@ GH_PROJECT= ipxe
# to be production-ready. You should always use the latest code.
#
GH_TAGNAME= 26050fd4c87c50503d5bd573b2ec91703676e211
+USE_PERL5= build
-USES= gmake perl5 shebangfix
-USE_BINUTILS= yes
-USE_GCC= yes
MAKE_ARGS= PERL=${PERL} \
CC=${CC} \
HOST_CC=${CC} \
+ AS=${AS} \
+ LD=${LD} \
+ SIZE=${SIZE} \
+ AR=${AR} \
+ RANLIB=${RANLIB} \
+ OBJCOPY=${OBJCOPY} \
+ NM=${NM} \
+ OBJDUMP=${OBJDUMP} \
NO_WERROR=1 \
V=1 \
- OBJCOPY="${LOCALBASE}/bin/objcopy" \
ISOLINUX_BIN="${WRKSRC}/isolinux.bin" \
LDLINUX_C32="${LOCALBASE}/share/syslinux/bios/com32/elflink/ldlinux/ldlinux.c32"
WRKSRC_SUBDIR= src
diff --git a/net/ipxe/files/pkg-message.in b/net/ipxe/files/pkg-message.in
index 07555eb528ac..c0eb13f92063 100644
--- a/net/ipxe/files/pkg-message.in
+++ b/net/ipxe/files/pkg-message.in
@@ -1,25 +1,6 @@
The following files have been installed in %%DATADIR%%:
-
-* ipxe.dsk: To create a bootable floppy run
-
- dd if=%%DATADIR%%/ipxe.dsk of=/dev/fd0
-
- where /dev/fd0 is your floppy drive. This will erase any data
- already on the disk.
-
-* ipxe.usb: To create a bootable USB key run
-
- dd if=%%DATADIR%%/ipxe.usb of=/dev/daX
-
- where /dev/daX is your USB key, and is *not* a real hard disk on
- your system. This will erase any data already on the USB key.
-
-* ipxe.iso: To create a bootable CD-ROM run
-
- cdrecord %%DATADIR%%/ipxe.iso
-
- to write the image to a blank CD.
-
-* ipxe.pxe: For chainloading from a PXE ROM.
-
-* ipxe.lkrn: For any boot manager that can boot Linux kernels.
+- ipxe.dsk for creating a bootable floppy disk
+- ipxe.usb for creating a bootable USB key
+- ipxe.iso for creating a bootable CD
+- ipxe.pxe for chainloading from a PXE ROM
+- ipxe.lkrn for any boot manager that can boot Linux kernels