aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:04:47 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:04:47 +0000
commit53dad9625b964a6d2ace8f4260e2b7a30f155213 (patch)
treed787ec7e9c49b0af0da91bb98782c880475930cd /net
parent8235e9b2e3db8070adaab3d4dc61bca21e97387b (diff)
downloadports-53dad9625b964a6d2ace8f4260e2b7a30f155213.tar.gz
ports-53dad9625b964a6d2ace8f4260e2b7a30f155213.zip
net/py-pyshark: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
Diffstat (limited to 'net')
-rw-r--r--net/py-pyshark/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/py-pyshark/Makefile b/net/py-pyshark/Makefile
index f694f3992115..ef6992a9ff29 100644
--- a/net/py-pyshark/Makefile
+++ b/net/py-pyshark/Makefile
@@ -1,5 +1,6 @@
PORTNAME= pyshark
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,6 +11,8 @@ WWW= https://github.com/KimiNewt/pyshark
LICENSE= MIT
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=0:devel/py-appdirs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
@@ -19,7 +22,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes