aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:04:25 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:04:25 +0000
commitc491635fbbe3db023340b90ff9f5a238b17a65cf (patch)
tree08049e798f33aeb6340f683e820a3b5ef08fd5ef /net
parent8a7910a7be8e43d537d623a4cd3fe4b093aa5512 (diff)
downloadports-c491635fbbe3db023340b90ff9f5a238b17a65cf.tar.gz
ports-c491635fbbe3db023340b90ff9f5a238b17a65cf.zip
net/py-geopy: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
Diffstat (limited to 'net')
-rw-r--r--net/py-geopy/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/py-geopy/Makefile b/net/py-geopy/Makefile
index b6cfde7eac7b..d59808086b02 100644
--- a/net/py-geopy/Makefile
+++ b/net/py-geopy/Makefile
@@ -1,5 +1,6 @@
PORTNAME= geopy
PORTVERSION= 2.4.1
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,8 @@ WWW= https://github.com/geopy/geopy
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= geographiclib>=1.52<3:astro/geographiclib
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=0:www/py-aiohttp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}async_generator>=0:devel/py-async_generator@${PY_FLAVOR} \
@@ -22,7 +25,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=0:www/py-aiohttp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urllib3>=1.24.2,1:net/py-urllib3@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils pytest
+USE_PYTHON= autoplist concurrent pep517 pytest
NO_ARCH= yes