aboutsummaryrefslogtreecommitdiff
path: root/print/a2pdf
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-06-11 15:04:34 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-06-11 15:04:34 +0000
commitf6b5cd7fa657d73b1c9b5d1b2c97081e91b873df (patch)
tree6ef709d34320dfde04f34509d9a28a4fa71bb635 /print/a2pdf
parent55ea7d9d59d9bbee408267917ad32c0871d2e603 (diff)
downloadports-f6b5cd7fa657d73b1c9b5d1b2c97081e91b873df.tar.gz
ports-f6b5cd7fa657d73b1c9b5d1b2c97081e91b873df.zip
Add port print/a2pdf:
a2pdf converts ASCII text to PDF format, with optional line/page numbering and Perl syntax highlighting. WWW: http://perl.jonallen.info/projects/a2pdf Author: Jon Allen <jj@jonallen.info>
Notes
Notes: svn path=/head/; revision=193274
Diffstat (limited to 'print/a2pdf')
-rw-r--r--print/a2pdf/Makefile26
-rw-r--r--print/a2pdf/distinfo3
-rw-r--r--print/a2pdf/pkg-descr5
-rw-r--r--print/a2pdf/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/print/a2pdf/Makefile b/print/a2pdf/Makefile
new file mode 100644
index 000000000000..6e34488ab2c3
--- /dev/null
+++ b/print/a2pdf/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: a2pdf
+# Date created: 10 May 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= a2pdf
+PORTVERSION= 1.13
+CATEGORIES= print
+MASTER_SITES= http://perl.jonallen.info/pub/Main/Ascii2Pdf/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Text to PDF converter
+
+BUILD_DEPENDS= p5-PDF-API2>=0:${PORTSDIR}/textproc/p5-PDF-API2 \
+ perltidy>=0:${PORTSDIR}/devel/perltidy \
+ p5-Image-Size>=0:${PORTSDIR}/graphics/p5-Image-Size \
+ p5-File-Type>=0:${PORTSDIR}/devel/p5-File-Type
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+MAN1= ${PORTNAME}.1
+
+.include <bsd.port.mk>
diff --git a/print/a2pdf/distinfo b/print/a2pdf/distinfo
new file mode 100644
index 000000000000..0d1c9eb8de5d
--- /dev/null
+++ b/print/a2pdf/distinfo
@@ -0,0 +1,3 @@
+MD5 (a2pdf-1.13.tar.gz) = 5f397b6faf2f29641e90fc308d6cff99
+SHA256 (a2pdf-1.13.tar.gz) = 6a5fd513b89ca1ecd765d701ef84a0cc2408abc49601f5c47737c0dc4c9b7b06
+SIZE (a2pdf-1.13.tar.gz) = 11079
diff --git a/print/a2pdf/pkg-descr b/print/a2pdf/pkg-descr
new file mode 100644
index 000000000000..b2fe5eb12db8
--- /dev/null
+++ b/print/a2pdf/pkg-descr
@@ -0,0 +1,5 @@
+a2pdf converts ASCII text to PDF format, with optional line/page
+numbering and Perl syntax highlighting.
+
+WWW: http://perl.jonallen.info/projects/a2pdf
+Author: Jon Allen <jj@jonallen.info>
diff --git a/print/a2pdf/pkg-plist b/print/a2pdf/pkg-plist
new file mode 100644
index 000000000000..0ad288f43055
--- /dev/null
+++ b/print/a2pdf/pkg-plist
@@ -0,0 +1,5 @@
+bin/a2pdf
+%%SITE_PERL%%/App/a2pdf.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/a2pdf/.packlist
+@dirrmtry %%SITE_PERL%%/App
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/a2pdf